Gap Block

Beschreibung

This block is intended to work with any WordPress theme that supports the new Block Editor (Gutenberg). It allow you to add responsive Gap / Spacer to your website and customize it, so you can set separate gap heights for different screen sizes (breakpoints) separately.

Features

  • viewport sizes can be customized in plugin options page so you can use this plugin with any theme,
  • ready to use out of the box, no configuration needed,
  • set same height for all viewports or for each of it separately, so you can have bigger gap on desktop and smaller on mobile device within the same block,
  • customize default viewport widths settings using hooks programmatically (for theme authors),
  • create unlimited number of gaps and customize each of it separately,

Screenshots

  • Set custom gap for different screen widths
  • Customize screen width breakpoints and fit this plugin to your theme / website
  • You can set custom gap height for each screen width separately

Installation

  1. Install the plugin through the WordPress plugins screen directly or upload the plugin files to the „/wp-content/plugins/gap-block“ directory.
  2. Activate the plugin through the „Plugins“ screen in WordPress
  3. Go to Block Editor and type /gap to use this block.

Mitwirkende & Entwickler

„Gap Block“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „Gap Block“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.2.2

  • fixed SSL issue

1.2.1

  • Blocks Summary page updated
  • removed outdated method from block class

1.2.0

  • JavaScript code fully rebuilt on React, no more jQuery
  • Blocks Summary page style & script improved
  • AJAX replaced with custom REST endpoint
  • license changed from GPL2+ to GPLv3
  • block code improved

1.1.0

  • dependencies bug fixed

1.0.0

  • initial release