Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

Groups Blog Protect

Beschreibung

This plugin allows to redirect visitors to a blog who do not belong to the blog’s Registered group.

The plugin is an extension to and requires Groups.

Note that the current version does not allow to specify a particular group – at least in that sense, the status of the plugin can be considered somewhat experimental.

The redirection settings can be adjusted in Settings > Groups Blog Protect :

Redirection options can be set for the blog – or for each blog in a multisite setup:

  • no redirection
  • redirect to a specific post, note that with this option the blog is shown to the visitor but only that page can be visited
  • redirect to the WordPress login

The redirect status code can be selected among:

  • Moved Permanently (301)
  • Found (302)
  • See other (303)
  • Temporary Redirect (307)

Screenshots

  • Groups Blog Protect settings.

Installation

  1. Upload or extract the groups-blog-protect folder to your site’s /wp-content/plugins/ directory. You can also use the Add new option found in the Plugins menu in WordPress.
  2. Enable the plugin from the Plugins menu in WordPress.
  3. Go to Settings > Groups Blog Protect and adjust the redirection settings as desired.

FAQ

What do the status codes mean?

Read the section on Status Code Definitions in RFC 2616.

I have a question, where do I ask?

You can leave a comment at the Groups Blog Protect plugin page.

Mitwirkende & Entwickler

„Groups Blog Protect“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „Groups Blog Protect“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.0.1

  • WordPress 3.6 compatible

1.0.0

  • Initial release.