Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

MetaParsedown

Beschreibung

Import markdown and markdown-extra documents to WordPress posts and pages, output as HTML, parse and save YAML front matter to post_meta, tags, and (optionally) the posts tables.

  • Built on MetaParsedown, Parsedown and Symfony YAML components
  • Supports docments in both Markdown and Markdown-Extra formats
  • Easy to use
  • Lighweight
  • Optionally style markdown code snippets for syntax highlighting
  • Maintain cannonical markdown documents through your favourite git repository
  • Works with both Gutenberg and classic wordpress editors

How to use

Simply add the metaparsedown shortcode to your post, identifying the markdown document in the url attribute:

[metaparsedown url='https://gitlab.com/pagerange/docs/raw/master/markdown/test_markdown.md' /]

Optionally, parse and save markdown YAML front matter to the post_meta table by adding the meta attribute.

[metaparsedown url='https://gitlab.com/pagerange/docs/raw/master/markdown/test_markdown.md' meta="true" /]

Optionally, overwrite the post’s ‚post_title‘ and ‚post_excerpt‘ fields with YAML values by adding the overwrite attribute.

[metaparsedown url='https://gitlab.com/pagerange/docs/raw/master/markdown/test_markdown.md' meta="true" overwrite="true" /]<h3>Support</h3>

Add issues at https://github.com/pagerange/metaparsedown-wordpress/issues.

Donate

Donate via Paypal at http://pagerange.com/projects/wordpress/metaparsedown

Installation

Install directly from WordPress plugin repository.

Or, download the ZIP file from https://github.com/pagerange/metaparsedown-wordpress/archive/master.zip

FAQ

How can I add syntax hilighting to my markdown documents?

You can do one of two things:

  1. Add and enqueue a syntax highlighting Javascript package.

or…

  1. Use MetaParsedown’s built-in syntax highlighting using the microlight js highlight package. Simply add the following code to your theme’s functions.php file:

    if(function_exists(‚metaparsedown_plugins_url‘)) {

    function metaparsedown_load_scripts()
    {
        wp_enqueue_style('metaparsedown', 
            metaparsedown_plugins_url('/css/style.css'));
        wp_enqueue_script('microlight', 
            metaparsedown_plugins_url('/js/microlight.js'), [], null, true);
        wp_enqueue_script('metaparsedown', 
            metaparsedown_plugins_url('/js/script.js'), array('microlight'), null, true);
    }
    add_action('wp_enqueue_scripts', 'metaparsedown_load_scripts', 10);
    

    }

Rezensionen

Für dieses Plugin gibt es keine Rezensionen.

Mitwirkende & Entwickler

„MetaParsedown“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „MetaParsedown“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

v1.0.0

  • Version 1.0 released