Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

Restrict Lite

Beschreibung

An easy way to limit what data is shown to users with a simple a shortcode. Any content placed inside the shortcode will be restricted to users with the correct capabilities.

Usage

To restrict just a section of content within a post or page, you may use shortcodes like this:

[restrict capability=“editor“] restricted content goes here [/restrict]

Screenshots

  • Using a shortcode with multiple roles in the WYSIWYG editor.

Installation

  1. Manual Installation: Upload restrict-lite to the /wp-content/plugins/ directory.
  2. Activate the plugin through the ‚Plugins‘ menu in WordPress.

FAQ

Where can i get a list of roles & capabilities?

View what roles are specific to what user here: https://codex.wordpress.org/Roles_and_Capabilities

An example use would be

[restrict capability=“editor“] restricted content goes here [/restrict]

Rezensionen

Für dieses Plugin gibt es keine Rezensionen.

Mitwirkende & Entwickler

„Restrict Lite“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „Restrict Lite“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.3

  • Fixed a bug with capability not working correctly.
  • Tested with latest WordPress.

1.2

  • Updates to readme

1.1.0.3

  • Upgrade notice included.

1.102

  • Fixed Syntax error introduced in 1.1

1.1

  • Important change, role is now capability to better reflect is true name.
  • role will be removed in future builds. Please make changes to your shortcodes!
  • Removed default „read“.

1.0

  • Initial release