Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

Role Quick Changer

Beschreibung

Role Quick Changer is the simple solution to an age old WordPress debugging problem. „How do I see what this page looks like for a subscriber?“. Well, normally you’d have to create a new user with that role and then log in as them, what a pain. Not to mention, you’d have to do this for EVERY role you want to test. Role Quick Changer to the rescue! Now you can do test any page as any role simply by selecting the role from the admin bar. No need to even create a new user.

Simply install and activate the plugin and then select the role to test from the drop-down in the admin bar. It couldn’t be any simpler.

Installation

Install through the install plugin screen in the dashboard. Or download the files and upload to your plugins directory.

Rezensionen

6. März 2017
Hi Joel, Thanks for creating this great plugin. This is my personal favorite plugin when it comes to switching user roles. It's very light weight and does the job with glance. Thanks for sharing this with the community! Best, Niels PS: Good luck with the WordCamp Jackson!
24. März 2017
I use this handy plug-in for some years now and it works perfectly. To my surprise after I installed bbPress on one of the sites that I handle, the forum roles appeared in Role Quick Changer too! Thanks man! Suggestion: 'logged out' added to the list of roles would be handy too!
Alle 4 Rezensionen lesen

Mitwirkende & Entwickler

„Role Quick Changer“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „Role Quick Changer“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

0.2.1

  • Major bug fix

0.2.0

  • Improve capability checking and plugin structure.

0.1.2

  • Fixed fatal error on pre PHP 5.4 servers due to array shorthand syntax.

0.1.1

  • Fixed issue of user object being reset on a multi-site early in the load process.

0.1.0

  • Initial beta release.