Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

TinyMCE Clear Float

Beschreibung

Fügt einen Button zum WordPress-TinyMCE-Editor hinzu, um das Umfließen von Elementen (float) zu beenden.

Screenshots

  • Vorher: Umflossene Bilder im Editor. Das zweite Bild überlagert das erste.
  • Nachher: Umfließen beenden-Element eingefügt (siehe das neue Symbol in der zweiten Werkzeugleiste)
  • Markup im Text-Editor (beachte <br style="clear: both;">).

FAQ

Welches HTML-Markup nutzt das Plugin?

Zeilenumbrüche im Inline-Styles (<br style="clear: both;">).

Beachte: TinyMCE fügt Absätze um Zeilenumbrüche hinzu, die abhängig vom verwendeten Theme zu zusätzlichen Abständen führen können. Um diese Abstände zu verhindern, füge Folgendes in den „Zusätzliches CSS“-Bereich des Customizers ein:
p > br[style=“clear: both;“]:only-child {
content: “;
display: block;
margin-bottom: -1.5em;
}
Der Wert 1.5em entspricht dem margin-bottom-Wert von <p>-Elementen deines Themes.

Rezensionen

Works perfectly, thanks!!

The issue of text appearing up between two images (one floated left, one floated right) was driving me mad and would've looked awful to my client. This plugin quickly and easily solved it - thank you!!

Easy to use

The plugin is very easy to use and a great help for our web editors.
Lies alle 6 Rezensionen

Mitwirkende & Entwickler

„TinyMCE Clear Float“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

„TinyMCE Clear Float“ wurde in 1 Sprache übersetzt. Danke an die Übersetzerinnen und Übersetzer für ihre Mitwirkung.

Übersetze „TinyMCE Clear Float“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.3.2 (08/01/2018)

  • Fix: Rare bug (introduced in v1.2.0) that prevented parsing of deprecated clear element if it contained non breaking space (<div style="clear: both;">&nbsp;</div>)

1.3.1 (05/20/2018)

  • Fehlerbehebung: Fehler (in v1.3.0 eingeführt), der den TinyMCE-Inhalt versteckt hat, wenn kein Clear-Element gefunden wurde

1.3.0 (05/19/2018)

  • Fehlerbehebung: Reguläre Ausdrücke zum Wechseln der Clear-Elemente mit Platzhaltern und umgekehrt mit DOMParser ersetzt, um alle möglichen Schreibweisen des Clear-Elements zu finden (z. B. <br style="clear: both;">, <br style="clear:both">, <br style="clear: both;" />, <br style="clear:both" />)

1.2.2 (05/25/2017)

  • Fehlerbehebung: Seltener Fehler (in v1.2.0 eingeführt), der dazu führte, dass TinyMCE den <br />-Tag entfernt hat
  • Fehlerbehebung: Fehler (in v1.2.0 eingeführt), der verhindert hat, dass das Plugin übersetzt werden konnte (endgültig)
  • Sonstiges: „Requires at least“ auf WordPress 4.6 erhöht

1.2.1 (03/30/2017)

  • Fehlerbehebung: Fehler (in v1.2.0 eingeführt) der verhindert hat, dass das Plugin übersetzt werden konnte

1.2.0 (01/26/2017)

  • Neuer Verwalter; erste Aktualisierung nach sieben Jahren
  • Besonderheit: Umfließen beenden-Buttons (links und rechts) (see FAQ-Sektion)
  • Sonstiges: Plugin-Quellcode komplett umgebaut

1.1 (05/10/2010)

  • Besonderheit: HTML-Block im WordPress-Stil hinzugefügt

1.0 (04/28/2010)

  • Initiale Veröffentlichung