Dieses Plugin ist nicht mit den jüngsten 3 Hauptversionen von WordPress getestet worden. Es wird möglicherweise nicht mehr gewartet oder unterstützt und kann Kompatibilitätsprobleme haben, wenn es mit neueren Versionen von WordPress verwendet wird.

Wildflowerizer

Beschreibung

Wildflowerizer is a sidebar widget that randomly displays a photo that’s been recently added to the Wildflower Field Guide, North America group at Flickr.

Credits

This plugin uses phpFlickr
which is a class written by Dan Coulter
in PHP to act as a wrapper for the Flickr API.

Installation

  1. Install the plugin through the ‚Plugins‘ menu in WordPress. If
    installing from a zip file, place the wildflowerizer folder in your
    wp-content/plugins/ folder.
  2. Activate the plugin on your Manage Plugins page.
  3. In the Appearance section, choose Widgets and drag Bug Of The
    Day to your sidebar. The default image size is 240×180 pixels. If
    your sidebar isn’t that wide, then choose 100×75.

So far the plugin has only been tested with WordPress 2.9.2.

If your theme doesn’t support widgets, you can still use the widget by adding this code to your sidebar, as explained in this post.

<?php { ; ?>
   <?php $instance = array("title" => "My Widget", "number" => 9); ?>
   <?php $args = array("title" => "My Widget", "before_title" => "<h2>", "after_title" => "</h2>"); ?>
   <?php $sb = new Wildflowerizer_Widget(); ?>
   <?php $sb->number = $instance['number']; ?>
   <?php $sb->widget($args,$instance); ?>
<?php } ?>

Rezensionen

Für dieses Plugin gibt es keine Rezensionen.

Mitwirkende & Entwickler

„Wildflowerizer“ ist Open-Source-Software. Folgende Menschen haben an diesem Plugin mitgewirkt:

Mitwirkende

Übersetze „Wildflowerizer“ in deine Sprache.

Interessiert an der Entwicklung?

Durchstöbere den Code, sieh dir das SVN Repository an oder abonniere das Entwicklungsprotokoll per RSS.

Änderungsprotokoll

1.0

  • Initial release

1.1

  • Updated phpFlickr and fixed a data visibility problem with the cache. The plugin will now work on sites that aren’t installed at the domain’s root. Upgrade recommended for all users.