Support » Installation » 404 auf Unterseiten nach PHP 8 Umstellung

  • Gelöst finidesign

    (@finidesign)


    Hallo,

    der Hoster hat Ende des Jahres auf PHP 8 umgestellt, ein Patch für 7.x wird nicht angeboten.

    Nach der Umstellung war die Seite komplett nicht erreichbar mit einem weißen Screen. Wie ich wieder ins Backend gekommen bin, kann ich nicht mehr sagen. Jedenfalls habe folgende Schritte unternommen

    • Plugins aktualisiert >> ohne Erfolg
    • Plugins deaktiviert >> ohne Erfolg
    • Anderes Template Twenty Twenty zugewiesen >> ohne Erfolg(
    • verwendetes Template Kadence upgedated >> die Startseite wird wieder angezeigt, aber nicht die restlichen Menüpunkte auf der obersten Ebene
    • mit dem Hoster gesprochen, der mich auf die o.g. Punkte verwiesen hat
    • Die Website ist keine 2 Jahre alt, ich habe sie allerdings „geerbt“ und nicht selbst erstellt.

      Hat jemand eine Idee, an was das liegen könnte?

      Bestem Dank im Voraus
      Fini

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,
    vielleicht gibt es ein Problem mit den Permalinks: Das könnte möglicherweise wie folgt gelöst werden: Über Einstellungen > Permalinks im WordPress Dashboard unten auf der Seite auf den Button „Änderungen speichern“ klicken. Hier brauchst du keine Änderungen vornehmen – einfach auf die Schaltfläche klicken.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Im Moment scheint es mehr Probleme als nur Permalinks zu geben.

    Erste Maßnahme: Debug-Modus aktivieren.
    Wenn du ins Backend kommst, reicht es, wenn du das Plugin WP Debugging installierst (die anderen, empfohlenen Plugins brauchst du nicht zu installieren).
    Ohne Zugriff aufs Backend kannst du per FTP in der wp-config.php folgende Zeilen einfügen:

    
    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    

    (Quelle: Debugging in WordPress)

    Damit sollten dann Fehlermeldungen in eine Datei wp-content/debug.log geschrieben werden, die hoffentlich einen Tipp geben, wo das Problem ist.

    Thread-Starter finidesign

    (@finidesign)

    Wow, vielen Dank Hans-Gerd. Das hat es jetzt erstmal gebracht.

    • Diese Antwort wurde geändert vor 1 Woche, 2 Tage von finidesign.
    Moderator Bego Mario Garde

    (@pixolin)

    Denke, da gibt es noch andere Fallstricke in der Site.

    Als ich mir die Website gestern angeschaut habe, wurde nur angezeigt, dass es ein Problem mit der Website gibt – das meinte ich mit „andere Probleme“. Scheinbar wurde das inzwischen behoben. Weitere Tipps zur Optimierung findest du im Menü Werkzeuge > Website-Zustand.

    Hallo,

    Woran liegt es, dass man keine Änderungen vornimmt und nach dem nochmaligen Speichern die Seiten dann wieder sichtbar sind?

    Du meinst vermutlich das Problem mit den Permalinks. Das kann ich dir leider nicht beantworten. Du kannst aber dazu gerne auch mal einen Blick in WordPress Trac zu dem Thema werfen.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)