Support » Allgemeine Fragen » 404-Seite statt Suchergebnisse

  • Gelöst winnewoerp

    (@joschi81)


    Moin WordPress-Kenner,

    ich habe ein Problem: Ich versuche nachträglich in einer von anderen Programmierern entwickelten WP-Umgebung eine Suche einzubauen. Statt der Ergebnisliste wird aber eine 404-Seite angezeigt.

    Siehe hier:
    http://bit.ly/1M36GJ4

    Das Theme ist Thematic, wir arbeiten aber mit einem eigenen Childtheme.

    Hat jemand vielleicht einen Hinweis, wo ich mit der Problemermittlung ansetzen sollte?

    Vielen Dank und viele Grüße
    joschi81

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • … wir arbeiten aber mit einem eigenen Childtheme.

    Solange nur ihr da reinschauen könnt, ist es auch ein wenig schwierig, spontan zu rufen „Schau mal in Zeile 42, da müsstest du …“ Habt ihr das Child Theme auf Github?

    Thread-Starter winnewoerp

    (@joschi81)

    Hallo,

    nein, leider nicht bei GitHub. Aber hier nun als .zip:
    http://dev.stadtkreation.com/umlandscout.zip

    Wie gesagt, als Chilc Theme von Thematic verwendet:
    https://thematictheme.com/

    Habe auch gerade noch einmal vorsichtshalber in der .htaccess-Datei geschaut, da sieht auch nichts verdächtig aus m.E.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    
    RewriteCond %{HTTP_HOST} umlandscout\.hamburg\.de [NC]
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteRule ^index\.php$ index.php?theme=hamburg.de [L]
    
    RewriteCond %{HTTP_HOST} umlandscout\.hamburg\.de [NC]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php?theme=hamburg.de [L]
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    php_value upload_max_filesize 512M
    php_value post_max_size 512M
    php_value max_execution_time 300
    php_value max_input_time 300

    Der erste Teil bezieht sich darauf, dass wir mit zwei Themes live sind (wenn alles läuft):
    http://www.umlandscout.de/?theme=hamburg.de

    Danke für mögliche Tipps.

    Viele Grüße
    joschi81

    Thread-Starter winnewoerp

    (@joschi81)

    Das hat sich erledigt. Ganz einfache und peinliche Erklärung: Ohne mein Wissen war das Plugin „Disable Search“ (https://wordpress.org/plugins/disable-search/) installiert worden, warum auch immer. Ich habe es nun deaktiviert.

    Viele Grüße
    joschi81

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „404-Seite statt Suchergebnisse“ ist für neue Antworten geschlossen.