Support » Allgemeine Fragen » ab welcher Version wird STARK zum Update geraten?

  • Hallo, ich betreue aktuell 2-3-Websites wobei eine auf der Version 4.6.12 läuft und eine andere auf 4.9.12. Eine etwas jüngere Seite läuft auf 5.2.4
    Was würdet Ihr sagen, ab welcher Version sollte man DRINGEND ein Update vornehmen – vor allem aus Sicherheitsgründen -? Bei allen 4er und 5er Seiten oder ist die 5er Version noch jung genug?

    Für Eure Stellungnahme und Tipps vielen Dank im Voraus,
    Eric

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Bist du ein Troll, oder meinst du das ernst? Die 4.6er ist beinahe aus dem Mittelalter! Und PHP-Version 5.irgendwas.

    Moderator Bego Mario Garde

    (@pixolin)

    @jostu55 Nein, kein Troll – es gibt viele Entwickler, die Kunden eine WordPress-Installation „abliefern“, ohne sich um die weitere Wartung zu kümmern (nicht zuletzt, weil Kunden nicht bereit sind, laufende Kosten zu tragen). WordPress nimmt automatisch Updates der Zwischenversionen vor, in denen Sicherheitslücken geschlossen werden und so läuft die Website dann auch eine ganze Weile problemlos. Unter Umständen wurde noch ein Theme gekauft, für das der Theme-Entwickler nach zwei Jahren den Support einstellt – da gibt es dann einfach keine Updates mehr. Nach fünf Jahren ist die Website dann technisch so überholt, dass ein Relaunch ansteht. Es ist eher ein Rechenexempel, ob das billiger kommt als eine regelmäßige Wartung.

    @erichlehnsherr Wenn es um die Sicherheit der Website geht, sollten eigentlich die automatischen Updates der Zwischenversionen reichen. Allerdings gibt es dann für die Website keine neuen Features mehr und es könnte sein, dass Plugins oder auch das Theme irgendwann nicht mehr zur inzwischen veralteten WordPress-Version passen. Und Themes und Plugins sollten immer auf dem allerneuesten Stand gehalten werden, weil es hier keine vorgegebene Unterscheidung in Haupt- und Zwischenversionen gibt; Sicherheitslücken und Bugs werden hier fortlaufend behoben.

    Da sich die Core-Entwickler eigentlich immer darum bemüht haben, WordPress abwärtskompatibel zu halten (was ihnen dann auch prompt vorgehalten wird, weil WordPress damit „Legacy Code“ mitschleppt), gibt es aber keinen Grund, nicht unmittelbar nach Veröffentlichung auf die neueste Haupt-Version zu aktualisieren.
    Der neue Block-Editor „Gutenberg“ war bei Einführung von WordPress 5.0 noch recht fehleranfällig, die Fehler sind aber dann sehr, sehr schnell behoben worden, sodass selbst hier eigentlich kein dringender Grund bestand, die Updates auszusetzen.

    Auch wer mit ganzem Herzen am alten TinyMCE-Editor hängt, sollte trotzdem ein Update durchführen (und dann zusätzlich das Plugin Classic Editor installieren, mit dem der klassische Editor vorerst weiter genutzt werden kann).

    Voraussetzung für regelmäßig Updates ist eine aktuelle PHP-Version.

    Ok, sorry war etwas überspitzt!
    Was noch anzuraten wäre, vor irgend einer Aktion würde ich eine Sicherung der gesamten Altlasten inkl. Datenbank empfehlen.

    Als Ergänzung zu den bisherigen Antworten:

    Alle drei genannten WordPress-Versionen haben Sicherheitslücken (4.6.12, 4.9.12 und 5.2.4). Die jeweils aktuellen WordPress-Versionen eines Zweiges findest du hier:
    https://de.wordpress.org/download/releases/

    Momentan wäre das:
    4.6.12 –> 4.6.17
    4.9.12 –> 4.9.13
    5.2.4 –> 5.2.5

    Dieser Artikel gibt dir weitere Antworten:

    Die Aktualisierung von Major- und Minor-Versionen in WordPress

    Nachtrag

    Überprüfe alle 3 Websites dahingehend, ob sie möglicherweise bereits gehackt wurden. Anhaltspunkte darauf kannst du durch einen Check mithilfe z. B. dieser beiden Websites finden:

    Cloaked Link Checker
    Sitecheck

    Nachtrag 2:
    Wie im Thread bereits angesprochen wurde, müssen auch Plugins und Themes stets aktuell gehalten werden – auch sie können erhebliche Sicherheitslücken haben, die mit Updates behoben werden.

    Auf dieser Website, die viele Versionen diverser Plugins und Themes mit Schwachstellen listet, kannst du nach deinen installierten Komponenten samt Version suchen. Allerdings sollte auch das nur als Anhaltspunkt dienen, die Website erhebt keinen Anspruch auf einen kompletten, alles abdeckenden Datensatz.

    Und noch der Link zu den offiziell unterstützten PHP-Versionen.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)