Support » Allgemeine Fragen » Absatz Funktion nicht vorhanden

  • Ich habe WordPress schon seit 2 Jahren auf der Webseite meines Vaters laufen.
    Seit einigen Wochen (ich komme nicht so oft dazu, an der Seite etwas zu ändern) ist die Absatz Funktion im Editor verschwunden. Das heißt, ich kann kein Absatz Texte mehr schreiben.

    WordPress wurde erst auf Version 6.4.2 geupdatet.

    Hatte von Euch schon einmal jemand das Problem und konnte es lösen?

    Ich bin mir recht sicher, dass mein Vater keine besonderen Einstellungen vorgenommen hatte, die so etwas auslösen könnten.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Hallo,
    ohne nähere Infos (URL und Website-Bericht) ist eine Analyse schwierig. Lies bitte mal: Bevor du ein neues Thema (Thread) erstellst.

    Gibt es irgendwelche Fehlermeldungen, wenn Du in die Developer Console im Backend schaust (Aufruf mit F12)?

    Wenn du dann noch die URL oben einträgst, dann kann das für eine Analyse auch hilfreich sein.

    Hilfreich für eine Analyse wäre der Website-Bericht:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    Einen eigenständigen Block Absatz gibt es nicht mehr. Du brauchst nur tippen, um einen Absatz einzufügen:

    Screenshot
    Thread-Starter dantre

    (@dantre)

    Wenn die Seite neu angelegt wird, mag das stimmen. Auf einer Seite mit bestehenden Blöcken, muss ich einen neuen Block (in dem Fall Absatz) auswählen, wenn ich einen Absatz hinzufügen möchte. Das geht aber nicht, wenn es keinen Absatz zur Auswahl gibt. Also kann ich nichts schreiben, falls im ungünstigsten Fall noch kein Absatz vorhanden ist und ich diesen nicht duplizieren kann.
    Nach dem Bericht, muss ich fragen.
    Fehlermeldungen gibt es keine

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.

    Auf einer Seite mit bestehenden Blöcken, muss ich einen neuen Block (in dem Fall Absatz) auswählen …

    Hier sind zwei Bild-Blöcke. Möchte ich dazwischen einen Absatz hinzufügen, wähle ich das erste Bild aus, drücke Enter und fange an, zu schreiben:

    Screenshot

    Alternativ kannst du auch den Block anklicken und dann über das Kebab-Menü rechts „Danach einfügen“ anklicken. Du bekommst dann auch die Möglichkeit, einen Text zu schreiben oder aber einen anderen Block einzufügen.

    So geht es über das Kontext-Menü, nachdem du den vorhandenen Block angeklickt hast:

    Screenshot

    Du kannst auch auf das blau [+]-Icon ganz oben klicken und dann als Block „Absatz“ auswählen.

    Thread-Starter dantre

    (@dantre)

    ENTER funktioniert leider nicht. D.h es passiert nichts und es entsteht deshalb auch nicht automatisch ein neuer Absatz Block.

    Über das Kontext menü gibt es keine Möglichkeit etwas nach einem Block einen neuen einzufügen.

    D.h. hier ist etwas grundsätzliches kaputt.

    Hier der Bericht:

    ` wp-core
    
    version: 6.4.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true wp-paths-sizes
    
    wordpress_path: /home/www/xxx
    wordpress_size: 168,03 MB (176189075 bytes)
    uploads_path: /home/www/xxx/wp-content/uploads
    uploads_size: 112,93 MB (118412550 bytes)
    themes_path: /home/www/xxx/wp-content/themes
    themes_size: 3,56 MB (3735287 bytes)
    plugins_path: /home/www/xxx/wp-content/plugins
    plugins_size: 100,32 MB (105195482 bytes)
    database_size: 3,76 MB (3944322 bytes)
    total_size: 388,60 MB (407476716 bytes) wp-dropins (1)
    
    advanced-cache.php: true wp-active-theme
    
    name: Dorayaki (dorayaki)
    version: 1.0.15
    author: Elmastudio
    author_website: https://www.elmastudio.de/en/
    parent_theme: none
    theme_features: core-block-patterns, wp-block-styles, responsive-embeds, editor-font-sizes, disable-custom-font-sizes, editor-color-palette, editor-style, automatic-feed-links, title-tag, post-formats, menus, post-thumbnails, custom-header, widgets
    theme_path: /home/www/xxx/wp-content/themes/dorayaki
    auto_update: Deaktiviert wp-themes-inactive (1)
    
    Dorayaki Child: version: 1.0, author: Your Name, Automatische Aktualisierungen deaktiviert wp-plugins-active (14)
    
    Akismet Anti-spam: Spam Protection: version: 5.3, author: Automattic - Anti-spam Team, Automatische Aktualisierungen deaktiviert
    Complianz | GDPR/CCPA Cookie Consent: version: 6.5.6, author: Really Simple Plugins, Automatische Aktualisierungen deaktiviert
    Fonts Plugin | Google Fonts Typography: version: 3.4.7, author: Fonts Plugin, Automatische Aktualisierungen deaktiviert
    Hotjar: version: 1.0.16, author: Hotjar, Automatische Aktualisierungen deaktiviert
    Jetpack Boost: version: 2.2.1, author: Automattic - Jetpack Site Speed team, Automatische Aktualisierungen deaktiviert
    Site Kit by Google: version: 1.116.0, author: Google, Automatische Aktualisierungen aktiviert
    Social Feed Gallery: version: 4.2.4, author: QuadLayers, Automatische Aktualisierungen deaktiviert
    Social Gallery and Widget: version: 2.3.3, author: Catch Plugins, Automatische Aktualisierungen deaktiviert
    SVG Support: version: 2.5.5, author: Benbodhi, Automatische Aktualisierungen deaktiviert
    WP-Optimize - Clean, Compress, Cache: version: 3.2.22, author: David Anderson, Ruhani Rabin, Team Updraft, Automatische Aktualisierungen deaktiviert
    WP and Divi Icons: version: 1.6.2, author: Aspen Grove Studios, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.8.5.3, author: WPForms, Automatische Aktualisierungen deaktiviert
    WPFront Scroll Top: version: 2.2, author: WPFront Team, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.11.0, author: Automattic, Automatische Aktualisierungen deaktiviert wp-media
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.7.0
    file_uploads: 1
    post_max_size: 256M
    upload_max_filesize: 256M
    max_effective_size: 256 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 118 GB
    imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    imagick::RESOURCETYPE_FILE: 768
    imagick::RESOURCETYPE_MAP: 118 GB
    imagick::RESOURCETYPE_MEMORY: 59 GB
    imagick::RESOURCETYPE_THREAD: 1
    imagick::RESOURCETYPE_TIME: 9.2233720368548E+18
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.3.3
    gd_formats: GIF, JPEG, PNG, WebP, BMP, AVIF, XPM
    ghostscript_version: 9.53.3 wp-server
    
    server_architecture: Linux 5.10.0-15-amd64 x86_64
    httpd_software: Apache
    php_version: 8.2.13 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: -1
    upload_max_filesize: 256M
    php_post_max_size: 256M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    current: 2023-12-26T09:11:56+00:00
    utc-time: Tuesday, 26-Dec-23 09:11:56 UTC
    server-time: 2023-12-26T10:11:55+01:00 wp-database
    
    extension: mysqli
    server_version: 10.10.5-MariaDB-1:10.10.5+maria~deb11
    client_version: mysqlnd 8.2.13
    max_allowed_packet: 1073741824
    max_connections: 1024 wp-constants
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/xxx/wp-content
    WP_PLUGIN_DIR: /home/www/xxx/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    WP_DEVELOPMENT_MODE: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined wp-filesystem
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable google-site-kit
    
    version: 1.116.0
    php_version: 8.2.13
    wp_version: 6.4.2
    reference_url: https://www.xxx
    amp_mode: no
    site_status: connected-site
    user_status: authenticated
    verification_status: verified-non-site-kit
    connected_user_count: 2
    active_modules: site-verification, search-console, analytics, analytics-4, pagespeed-insights
    recoverable_modules: none
    required_scopes:
    openid: ✅
    https://www.googleapis.com/auth/userinfo.profile: ✅
    https://www.googleapis.com/auth/userinfo.email: ✅
    https://www.googleapis.com/auth/siteverification: ✅
    https://www.googleapis.com/auth/webmasters: ✅
    https://www.googleapis.com/auth/analytics.readonly: ✅
    https://www.googleapis.com/auth/tagmanager.readonly: ✅
    capabilities:
    googlesitekit_authenticate: ✅
    googlesitekit_setup: ✅
    googlesitekit_view_posts_insights: ✅
    googlesitekit_view_dashboard: ✅
    googlesitekit_manage_options: ✅
    googlesitekit_update_plugins: ✅
    googlesitekit_view_splash: ✅
    googlesitekit_view_authenticated_dashboard: ✅
    googlesitekit_view_wp_dashboard_widget: ✅
    googlesitekit_view_admin_bar_menu: ✅
    googlesitekit_view_shared_dashboard: ⭕
    googlesitekit_read_shared_module_data::["search-console"]: ⭕
    googlesitekit_read_shared_module_data::["analytics"]: ⭕
    googlesitekit_read_shared_module_data::["analytics-4"]: ⭕
    googlesitekit_read_shared_module_data::["pagespeed-insights"]: ⭕
    googlesitekit_manage_module_sharing_options::["search-console"]: ✅
    googlesitekit_manage_module_sharing_options::["analytics"]: ✅
    googlesitekit_manage_module_sharing_options::["analytics-4"]: ✅
    googlesitekit_manage_module_sharing_options::["pagespeed-insights"]: ✅
    googlesitekit_delegate_module_sharing_management::["search-console"]: ✅
    googlesitekit_delegate_module_sharing_management::["analytics"]: ✅
    googlesitekit_delegate_module_sharing_management::["analytics-4"]: ✅
    googlesitekit_delegate_module_sharing_management::["pagespeed-insights"]: ⭕
    enabled_features:
    gm3Components: ⭕
    keyMetrics: ✅
    search-console_shared_roles: none
    search-console_management: owner
    analytics_shared_roles: none
    analytics_management: owner
    analytics-4_shared_roles: none
    analytics-4_management: owner
    pagespeed-insights_shared_roles: none
    pagespeed-insights_management: all_admins
    search_console_property: https://www.xxx/
    analytics_account_id: 2512•••••
    analytics_property_id: UA-2512•••••••
    analytics_profile_id: 2813•••••
    analytics_use_snippet: yes
    analytics_4_property_id: 3453788••
    analytics_4_web_data_stream_id: 4338••••••
    analytics_4_measurement_id: G-VJ••••••••
    analytics_4_use_snippet: yes
    analytics_4_available_custom_dimensions: none wpforms
    
    version: 1.8.5.3
    lite: 14. August 2022 um 15:30 Uhr
    upload_dir: Beschreibbar
    total_forms: 3
    total_submissions: 11
    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.
    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.

    ENTER funktioniert leider nicht. D.h es passiert nichts …

    Enter alleine funktioniert auch nicht. Du musst vorher den Block anklicken, unterhalb dem du den Absatz einfügen möchtest.

    Der Website-Bericht gibt keine Anhaltspunkte für einen Fehler. Du kannst, wenn du im Editor Änderungen vornimmst, die Entwickler-Tools deines Browsers öffnen (Taste F12) und prüfen, ob im Tab Konsole JavaScript-Fehler angezeigt werden. Außerdem solltest du prüfen, ob sich etwas ändert, wenn du alle Plugins vorübergehend deaktivierst. Ich nehme allerdings eher einen Bedienungsfehler an.

    Thread-Starter dantre

    (@dantre)

    Den Block hatte ich vorher angeklickt. Ich arbeite seit 8 Jahren mit WordPress.

    Es gibt kein Absatz Block. Weder nach drücken von ENTER (nach dem ein Block markiert wurde), noch gibt es im Blöcke Menü die Option „Absatz“. (siehe Bild)

    Das Deaktivieren aller Plugins ändert nichts an diesem Zustand.

    So wie es aussieht, muss ich WordPress wohl noch einmal komplett neu installieren.

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.
    Thread-Starter dantre

    (@dantre)

    Mein vater hatte mir eben eine EMail weitergeleitet. Das Boldgrid Plugin habe ich aber schon deaktiviert (die Email ist von vor der Deaktivierung)

    Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
    WordPress-Version 6.4.2
    Aktives Theme: Dorayaki (Version 1.0.15)
    Aktuelles Plugin: Total Upkeep (Version 1.15.7)
    PHP-Version 8.0.30



    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 672 der Datei /home/www/xxx/wp-content/plugins/boldgrid-backup/admin/class-boldgrid-backup-admin-test.php verursacht. Fehlermeldung: Uncaught Error: Call to undefined function disk_free_space() in /home/www/xxx/wp-content/plugins/boldgrid-backup/admin/class-boldgrid-backup-admin-test.php:672
    Stack trace:
    #0 /home/www/xxx/wp-content/plugins/boldgrid-backup/admin/class-boldgrid-backup-admin-core.php(2879): Boldgrid_Backup_Admin_Test->get_disk_space()
    #1 /home/www/xxx/wp-includes/class-wp-hook.php(324): Boldgrid_Backup_Admin_Core->page_backup_test(“)
    #2 /home/www/xxx/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters(“, Array)
    #3 /home/www/xxx/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #4 /home/www/xxx/wp-admin/admin.php(259): do_action(‚total-upkeep_pa…‘)
    #5 {main}
     thrown

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.

    Hallo,
    wenn Du eine Überschrift wie im Screenshot erstellt hast, kannst Du diese Überschrift auch normalerweise wieder in einen Absatz ändern. Funktioniert das auch nicht?

    Ich gehe davon aus, dass Du ein Backup vor den folgenden Maßnahmen erstellst, das auf jeden Fall wiederhergestellt werden kann.

    Teste bitte auch, ob das Problem auftaucht, wenn du das Parent Theme Dorayaki aktivierst und/oder ein Standard-Theme wie z. B. Twenty Twenty-One installierst und aktivierst.

    Akismet entspricht nicht den europäischen Datenschutzvorgaben. Schau dir mal Antispam Bee an. Kostenlos, leistungsfähig und datenschutzkonform.
    Jetpack ist ebenfalls unter datenschutzrechtlichen Gesichtspunkten problematisch, siehe hier. Das Plugin solltest du löschen.

    Cache-Plugins wie in deinem Fall WP Super Cache und WP Optimize solltest du solange deaktiviert lassen, wie das Problem besteht. Außerdem kann es gerade bei der Aktivierung von zwei Cache-Plugins zu Konflikten kommen. Wenn der Fehler gefunden wurde, solltest Du nur ein Cache-Plugin aktivieren.

    Viele Grüße
    Hans-Gerd

    Thread-Starter dantre

    (@dantre)

    Ich hatte eben Twenty Twenty aktiviert. Das Theme hat leider keine Auswirkungen auf den Fehler.

    Danke für den Hinweis auf die beiden Plugins. Beide habe ich daraufhin gelöscht.

    Nachdem ich alle Dateien gesichert habe, werde ich morgen früh alles auf dem FTP Server löschen und WP komplett neu hochladen.

    Theoretisch bräuchte ich danach nur folgende Dateien und Ordner erneut hochladen, um den alten Stand zu bekommen. Danach müsste der Fehler behoben sein. Wenn nicht, müsste ich mir jedes einzelne Datenpaket vornehmen:
    – wp-login.php
    – wp-config.php
    – /wp-content/
    – /wp-admin/

    Hallo,
    entsprechende Informationen findest Du im folgenden Beitrag aus unserer FAQ.

    Evtl. reicht es aber auch schon, wenn Du das Update erneut durchführst: Du findest unter Dashboard > Aktualisierungen den Button „Version 6.4.2-de_DE erneut installieren“. Klicke da mal bitte drauf und schau mal, ob das Problem dann erledigt ist.

    Viele Grüße
    Hans-Gerd

    Thread-Starter dantre

    (@dantre)

    Ich bin alles durchgegangen. Nichts half.

    Die debug.log existiert nicht bzw. wird nach der beschrieben Anpassung der wp-config.php, nicht erstellt. Das selbe gilt für die error.log

    Könnte das ein Hinweis auf den Fehler sein?

    Thread-Starter dantre

    (@dantre)

    Ich habe jetzt alles auf dem FTP Server gelöscht und danach durch das neue WordPress ersetzt.

    Lediglich die alte .htaccess und wp-config.php wurde von mir hochgeladen, so dass ich auf die Datenbank zugreifen und mich einloggen konnte. D.h. alles ist auf default eingestellt (Keine Plugins, Themes außer Twenty Twenty, etc.)

    Die Dateien konnte ich bearbeiten, allerdings besteht der Fehler weiterhin. D.h. ich kann weder ENTER drücken, noch einen neunen Absatz Block erstellen, da dieser weiterhin nicht angeboten wird.

    Erst als ich die wp-config.php und die htaccess gelöscht, eine Test DB aufgebaut und alles neu installiert hatte, funktionierte wieder alles.

    Es gab sonst keine, für mich ersichtlichen Probleme mit der Datenbank. Es wurde weder Fehler angezeigt, noch gab es Anzeigeprobleme von Bildern, Videos oder anderer Daten. Einzig die ENTER Taste bzw. Absatz Block ist blockiert.

    Was wird in der DB gespeichert, dass solche Fehler verursacht und wie könnte man es reparieren? Ich hatte bisher noch nicht das Vergnügen, mich mit der Db herumzuärgern.

    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.
    • Diese Antwort wurde geändert vor 3 Monaten, 2 Wochen von dantre.

    Hallo,
    evtl. hilft es auch, die .htaccess neu zu erstellen:

    • per FTP suchst du die .htaccess-Datei in deinem Stammordner
    • lade eine Kopie der Datei als Sicherung auf deinen Computer
    • lösche danach die .htaccess-Datei von deinem Server
    • gehe zu Einstellungen > Permalinks im WordPress Dashboard
    • unten auf der Seite auf den Button „Änderungen speichern“ klicken (du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche)

    Sollt danach das Problem beseitigt sein, lag es an der .htaccess, sonst einfach die gesicherte Datei .htaccess wieder in den Stammordner kopieren.

    Wenn es daran nicht liegt, dann auch mal bitte die wp-config.php überprüfen.

    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)