Support » Themes » Abstände zwischen Blogs entfernen – Theme: „Drive“

  • Gelöst 4three

    (@4three)


    Hallo zusammen,
    auf meiner Website schleichen sich immer wieder weiße „Abstände“ ein.
    Diese möchte ich entfernen, weiß aber nicht wie.
    Wäre toll, wenn mir diesbezüglich jemand helfen könnte.
    Einen Link zum zeigen, auf welche weißen „Abstände“ bzw „Balken“ ich mich beziehe, habe ich hier eingefügt.

    Kleine Anmerkung: Im Editor (das Theme hat Full Site Editing) sind nur die Weißen Abstände von dem Spalten Block zu sehen.
    Siehe hier
    LG,
    4three

    • Dieses Thema wurde geändert vor 1 Monat, 2 Wochen von 4three.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das kommt von

    .wp-site-blocks > * + * {
      margin-block-start: var( --wp--style--block-gap );
    }

    Trage mal im Custom-CSS dies ein:

    .wp-site-blocks > * + * {
      margin-block-start: 0 !important;
    }
    Thread-Starter 4three

    (@4three)

    Danke für die schnelle Antwort!
    Wo kann ich das Custom CSS bei einem Full Site Editing Theme finden?

    Hallo,
    bei Block Themes (Full Site Editing) kannst du Custom CSS auf verschiedene Weise „nachrüsten“. Die einfachste Lösung besteht darin, wenn du z. B. ein Plugin wie Customizer Export/Import installierst. Weitere Lösungen über Snippets, etc. habe ich in einem Beitrag zu dem Thema beschrieben.

    Viele Grüße
    Hans-Gerd

    Nachtrag: Ich vermute allerdings, dass man bei entsprechender Gestaltung des Templates (vermutlich hier die Startseite) sogar auf zusätzliches CSS verzichten kann. Da solltest du mal in den Einstellungen rechts bei den jeweilig benutzten Blöcken (Stichwort Ränder) nachschauen.

    Und noch ein Nachtrag: Über die theme.json kann man die Abstände zwischen den Blöcken entsprechend einstellen. Wenn dir das nicht zu kompliziert ist, musst du das wie folgt in die theme.json eintragen:

    "styles": {	
    ....	
        "spacing": {
          "blockGap": true,
    			"units": [
    				"%",
    				"px",
    				"em",
    				"rem",
    				"vh",
    				"vw"
    			]
    		},
    ...
    }

    Mehr dazu in dem folgenden Beitrag

    Thread-Starter 4three

    (@4three)

    Danke @hage !
    Ich hatte bereits in den Einstellungen vom Editor nachgeschaut.
    Die Ränder als auch die Block-Abstände sind überall auf 0 gesetzt.

    Dann bleibt dir nur Custom CSS oder theme.json. Schon getestet?

    Thread-Starter 4three

    (@4three)

    Ich hatte vor, das direkt nach der ersten Antwort nachzureichen. Konnte ja nicht ahnen, dass du SO SCHNELL antwortest!
    Habe das von dir empfohlene Plugin fürs Custom CSS installiert und den von @bscu genannten Code eingefügt. Hat geklappt. Danke!

    super – freut mich. Danke für die Rückmeldung.
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Thread-Starter 4three

    (@4three)

    Erledigt!

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)