Support » Themes » „Access denied“ -Fehler – themeübergreifend: wie debuggen?

  • Gelöst stnabor

    (@stnabor)


    Hallo und guten Tag community,

    ich bin seit Tagen mit einem Fehler und einem Seitenverhalten konfrontiert, das ich noch nie hatte: es ist ein Access denied fehler – themeübergreifend wie debuggen?

    Was zu berichten ist: Die Site läuft unter
    -Site: WP 5.9
    -MySQL version 5.5.33
    -PHP-Version: 7xy
    Alles läuft auf einem Root-Server – von meinem Freund administriert.

    Einstellung: Static-Page und Post-Page.

    zur Site: Es ist eine BETA-Seite auf der einige Plugins installiert sind:
    #wp-job-manager
    #participants-db usw. usf
    #polylang (weil die Seite zunächst mit einigen Sprachen laufen sollte)
    #zuletzt kam noch ein Theme Jobscout von https://rarathemes.com/ dazu.

    Damit – bzw. bei der Abstimmung dieses Theme (JobScout) haben die Errors begonnen. Ich hatte zunächst Fehler, dass die Anzeige einzelner Jobs nicht funktionierte dass sie
    getrashed waren. Das hab ich dann geändert u. die Jobs die expired waren – alle si datiert dass sie sichtbar sind.

    Etwas später – nach weiteren Einstellungen hab ich dann folgenden Fehler gehabt:

    „access denied“

    und diesen werd ich nun nicht mehr los egal was ich ansehen will
    – das impressum
    – die dsgvo
    – post a job-seite
    oder was auch immer

    Allein die Start oder Indexseite wird noch angezeigt. Alles andere ist „Access denied“
    Nun – das Verhalten hab ich auch auf dem Theme twenty-twenty.

    Ich hab mal der Reihe nach alle (Plugins) deaktiviert – ohne Erfolg; Der Fehler bleibt konstant sichtbar – wanimmer ichz auf die o.g. Seiten gehe, beomme ich access denied oben links im Browser angezeigt.

    Wie würdet ihr hier ansetzen wie debuggen.
    Bin gespannt was ihr hier sagt!?

    VG StNabor

    PS, ich hab mal den Debug-Mode eingeschalten – und hier folgendes gesehen:

    
    WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my_site.com/wp-admin/post.php?post=27&action=edit
    WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my_site.com/wp-admin/themes.php
    WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my_site.com/wp-admin/post.php?post=27&action=edit
    

    Update: Hmm – ggf. ists ein Permission-Problem – was mich aber wundert ist dass es vor Tagen noch ging – und ich an den Permissions zwischenzeitlich nichts geändert habe.

    • Dieses Thema wurde geändert vor 7 Monaten, 2 Wochen von stnabor.
    • Dieses Thema wurde geändert vor 7 Monaten, 2 Wochen von stnabor.
Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Access denied bedeutet eigentlich, dass die Dateirechte nicht stimmen. Deine im Update genannte Vermutung scheint zu passen. Wenn du keine Berechtigungen geändert hast, hat vielleicht der Serveradministrator etwas an der Konfiguration geändert? Oder dir ist der Berechtigungsfehler nicht aufgefallen?

    Geh doch bitte mal auf Einstellungen > Allgemein und schau, welche Sprachen du theoretisch auswählen könntest. Stimmen die Dateirechte nicht, solltest du dort nur Englisch und Deutsch angeboten bekommen, während andere Sprachen wie Spanisch und Französisch gar nicht erst angezeigt werden.

    Wir haben leider sehr wenig Informationen über deine Webseite und Angaben wie „PHP 7xy“ sind auch nicht gerade hilfreich. Ein Website-Bericht wäre toll. Du kannst den Website-Bericht ganz bequem per Button kopieren und hier in einer Antwort einfügen. Du findest den Button unter WerkzeugeWebsite-Zustand im Tab „Bericht“. Warte bitte mit dem Klick auf den Button, bis die Zustandsanzeige abgeschlossen ist.

    Thread-Starter stnabor

    (@stnabor)

    hallo Bego Mario, vielen Dank für dein schnelles Feedback und die vielen guten Tipps und Ideen.

    Finde diese Supportseite einfach klasse.

    Hier noch mehr Daten zum Server und zur Seite:
    Site: WP 5.9
    MySQL version 5.5.33
    PHP-Version: PHP Version 7.4.11

    Also ggf. ist ja im Backend am We was noch gelaufen was mir nicht gleich aufgefallen ist. Aber was ich noch merkwuerdig finde ist folgender Umstand:

    – ich hatte die Seite ursprpünglich mit Polylang für 5 bis 6 Sprachen mal aufgesetzt – die aber dann im Grunde alle verworfen u. will lediglich in Englisch arbeiten

    in der von dir erwähnten „Generellen Einstellung“ ist englisch _US eingetragen.

    bei dem nunmehr noch verbleibendenden Rest den ich in den Postings und PAges noch übrig habe ist die Sprache English: also en_GB eintegtragen – also wohl britisches Englisch.
    Hier frage ich mich, ob das nicht zwangsläufig zu Konfkikten führen kann. Ob ich nicht hier Dinge angleichen muss!?

    Ferner: Ich hab ja auch Polylang auch kpl. abgestellt – das hat keine Änderung gebracht.` Also – ich hab ca. 60 Postings (pages) die in der englischen Locale gefertigt sind – u. die Site-Sprache steht auf US_englisch.
    GGF ist ja hier ein generelles Ausmisten notwendig. Denn dieser kpl Überhang in (5-6) Sprachen, den will ich nächstens kpl. loswerden. Und da bietet es sich ggf. an kpl. ohne Polylang zu arbeiten und stattdessen eine WP 5.9 plain und straightforward durchzuinstallieren – und dann beim Anlegen neuer Postings eben keine dezidierte irgendwie geartete besondere Sprache zu wählen. Dann kommt man ggf. auch nicht in irgendwelche Konflikte rein (von denen ich im Mom. eben nicht genau sagen kann ob diese mich ggf. ereilt haben. 😉

    Unten mehr Infos: die Rechte (CHMOD usw.) hab ich teilweise schon überprüft. Aber ggf. ist mir einfach was entgangen. Werde später auch mal mit dem Backend-Admin reden.

    Hier sind die <strong>Links</strong>, die alle nicht funktionieren:

    https://www.job-starter.com/dsgvo-datenschutzerklarung/
    https://www.job-starter.com/impressum/
    https://www.job-starter.com/job-dashboard/
    https://www.job-starter.com/post-a-job/
    https://www.job-starter.com/job/backend-software-engineer-python-django-at-brisbane-hospital/`

    Wie gesagt: superschlichte Links – die m.E. (zumindest in den ersten drei Links) überhaupt kein einziges Plugin voraussetzen, bei den letzten beiden – hab ich dann nochmals WP_Job_manager hinzugeschaltet. Ohne Effekt.

    Nebenbei bemerkt: dir grundsätzlichen Serverkonfigurationen scheinen ggf. einfach i.O zu sein, denn auf einer anderen Seite, da läuft WP 5.9 und wenn ich hier (was ich am Samstag auf der Konfliktseite gemacht habe – Jobscout als Theme installiere, dann läuft das ohne Probleme vom Start weg.). Ich hab immer noch im Verdacht dass ich beim Abstimmen der Seite halt irgendwie etwas im Profil zerschossen hab.

    Bego Mario – ich freue mich von Euch wieder zu hören.
    Einen schoenen Abend noch,
    VG StNabor 😉

    Hier also noch die Health-Zustandsdaten:

    https://www.job-starter.com/wp-admin/site-health.php?tab=debug

    ### wp-core ###
    
    version: 5.9
    site_language: en_US
    user_language: en_US
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /sites/www.job-starter.com
    wordpress_size: loading...
    uploads_path: /sites/www.job-starter.com/wp-content/uploads
    uploads_size: loading...
    themes_path: /sites/www.job-starter.com/wp-content/themes
    themes_size: loading...
    plugins_path: /sites/www.job-starter.com/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: JobScout (jobscout)
    version: 1.1.3
    author: Rara Theme
    author_website: https://rarathemes.com/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, customize-selective-refresh-widgets, custom-logo, custom-header, starter-content, jetpack-responsive-videos, widgets
    theme_path: /sites/www.job-starter.com/wp-content/themes/jobscout
    auto_update: Disabled
    
    ### wp-themes-inactive (6) ###
    
    Twenty Nineteen: version: 2.1, author: the WordPress team (latest version: 2.2), Auto-updates disabled
    Twenty Seventeen: version: 2.4, author: the WordPress team (latest version: 2.9), Auto-updates disabled
    Twenty Sixteen: version: 2.0, author: the WordPress team (latest version: 2.6), Auto-updates disabled
    Twenty Twenty: version: 1.9, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-One: version: 1.5, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-Two: version: 1.0, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (3) ###
    
    Polylang: version: 2.8.3, author: WP SYNTEX (latest version: 3.1.4), Auto-updates disabled
    RaraTheme Companion: version: 1.3.9, author: Rara Theme, Auto-updates disabled
    WP Job Manager: version: 1.35.2, author: Automattic, Auto-updates disabled
    
    ### wp-plugins-inactive (14) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Auto-updates disabled
    Better Search Replace: version: 1.3.3, author: Delicious Brains (latest version: 1.3.4), Auto-updates disabled
    CoBlocks: version: 2.16.0, author: GoDaddy (latest version: 2.21.6), Auto-updates disabled
    Contact Form 7: version: 5.4.2, author: Takayuki Miyoshi (latest version: 5.5.5), Auto-updates disabled
    Formidable Forms: version: 5.0.06, author: Strategy11 (latest version: 5.2), Auto-updates disabled
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Auto-updates disabled
    Max Mega Menu: version: 2.9.4, author: megamenu.com (latest version: 2.9.5), Auto-updates disabled
    RARA One Click Demo Import: version: 1.2.9, author: raratheme, Auto-updates disabled
    Restricted Site Access: version: 7.2.0, author: Jake Goldman, 10up, Oomph (latest version: 7.3.0), Auto-updates disabled
    TablePress: version: 1.14, author: Tobias Bäthge, Auto-updates disabled
    TF Random Numbers: version: 1.8, author: Themeflection, Auto-updates disabled
    Twentig: version: 1.3.6, author: Twentig (latest version: 1.3.9), Auto-updates disabled
    WP All Import - WP Job Manager Add-On: version: 1.2.1, author: Soflyy, Auto-updates disabled
    WPJM Extra Fields: version: 1.3.0, author: Gabriel Maldonado, Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 16M
    max_effective_size: 8 MB
    max_file_uploads: 32
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, PNG, BMP
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: unknown
    httpd_software: Apache
    php_version: 7.4.11 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 16M
    php_post_max_size: 8M
    curl_version: not available
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.33
    client_version: mysqlnd 7.4.11
    max_allowed_packet: 1048576
    max_connections: 64
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /sites/www.job-starter.com/wp-content
    WP_PLUGIN_DIR: /sites/www.job-starter.com/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: /tmp/wp-errors.log
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: not writable
    uploads: writable
    plugins: not writable
    themes: not writable
    
    ### pll_options ###
    
    browser: 0
    rewrite: 1
    hide_default: 1
    force_lang: 1
    redirect_lang: 0
    media_support: 1
    sync: 0
    post_types: 0
    taxonomies: 0
    domains: 0
    version: 2.8.3
    default_lang: en
    primary: en => 50
    secondary: en => 50
    previous_version: 2.7.4
    
    ### pll_language_en ###
    
    term_id: 10
    name: English
    slug: en
    term_group: 0
    term_taxonomy_id: 10
    count: 60
    tl_term_id: 11
    tl_term_taxonomy_id: 11
    tl_count: 7
    locale: en_GB
    is_rtl: 0
    w3c: en-GB
    facebook: en_GB
    flag_url: https://www.job-starter.com/wp-content/plugins/polylang/flags/gb.png
    home_url: https://www.job-starter.com/
    search_url: https://www.job-starter.com/
    mo_id: 104
    page_on_front: 258
    page_for_posts: 746
    flag_code: gb
    Thread-Starter stnabor

    (@stnabor)

    Hallo und guten Abend Bego Mario,

    zusätzlich: das erhalte in der wp-log (die ich ja aktiviert habe) wenn ich einen Artikel editiere.:

    Deprecated: block_editor_preload_paths is deprecated since version 5.8.0!
    Use block_editor_rest_api_preload_paths instead in /sites/job-starter.com/wp-includes/functions.php on line 5691 

    Zwischenfazit: der Upgrade auf die Version 5.9 lief zwar relativ problemlos – ich hab die Files einfach drübergebügelt u. dann
    beim Einloggen in den Adminbereich gab es die (obligatorische) kurze Nachricht dass die DB angeglichen wird.

    Alles lief im Grunde ziemlich problemlos.

    Dennoch: ich glaube, dass es zeit für eine grundsätzlich frische und neue Installation. M.a.w. die im System bis in die Postings und Texte und
    Pages eingegrabenen Babylonische Sprachenvielfalt, die

    – brauch ich nicht ( mehr );
    – halte ich für einen Overhead;
    – scheint mir das ganze von Grund auf zu verkomplizieren.

    Ich denk ich mache morgen eine ganz frische Installation – von Grund auf und installier das Ding neu (ohnehin Beta) und dann gehts weiter nach einer KISS-Regel.
    Absolute basis-Dinge gehen rein. Und keine umständlichen und schwierigen Dinge die ich ohnehin nicht brauche.

    – Polylang
    – MaxMEGA Menü u.sw. usw.

    BTW – wenn ich alles frisch mache, kann ich ggf. vorbereiten noch gucken wie ich dann auch das (ja hier auch eingerichtete) Better Search and replace – ggf. dann beim Frischen Installieren gleich wieder mit einrichte und wiederherstelle. Ich mach mir ne Checkliste wie ich da am besten vorgehe – und alles bereitstelle.

    Backups ziehe ich gerade.

    VG SNabor 😉

    Thread-Starter stnabor

    (@stnabor)

    Hallo und guten Abend,

    update II: im site health status hab ich noch was Interssantes gsehen
    vgl https://www.my-page.com/wp-admin/site-health.php

    
        The REST API encountered an unexpected result
        Performance
        The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.
        The REST API call gave the following unexpected result: (403) <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"> <html><head> <title>403 Forbidden</title> </head><body> <h1>Forbidden</h1> <p>You don't have permission to access this resource.Reason: The client software did not provide a hostname using Server Name Indication (SNI), which is required to access this server.<br /> </p> </body></html> .

    Das sieht auch sehr interessant aus. Wollte diesen Befund nur noch kurz anmerken…

    vg STNAbor

    In deinem Website-Bericht steht

    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: not writable
    uploads: writable
    plugins: not writable
    themes: not writable
    

    Hier stimmen also teilweise die Dateirechte nicht.

    Kannst du per SSH auf den Server zugreifen? Dann kannst du mit ls -l /sites/www.job-starter.com/ den Dateinhaber und die Rechte der Dateien und Verzeichnisse auslesen. Falls du keinen SSH-Zugriff hast, kannst du die Dateirechte auch per FTP-Client einzeln auslesen (Rechtsklick auf die Datei > Info/Eigenschaften).

    Die Dateirechte sollen für Verzeichnisse auf 755 und für Dateien auf 644 gesetzt sein.

    Thread-Starter stnabor

    (@stnabor)

    Hallo und guten Abend Bego Mario,

    vielen Dank für dein Feedback und die Ideen. Ich bin der Meinung dass du hier wohl richtig liegst.

    Hatte übrigens auch in dem Dateisystem festgestellt, dass hier insgesamt auch verschiedene User drauf sind. Die Uploads hatten einen anderen User als die Files der Installation
    Ich hatte dann noch einige Dinge überprüft und nachgeguckt – (ohne SSH Zugang zum Server – mit SFTP) Da waren wohl Rechte-Fragen wie du sie ansprichst offen -bzw. so verdächtig, dass ich hier auch an Möglichkeiten, etwas herauszufinden glaubte.

    Interessant ist, dass auf demselben Server eine Seite läuft unter den selben Serverbedingungen, mit dem neuen Theme (jobscout) – und zwar ganz ohne Probleme. Bei diesem Theme (um es nochmals zu erwähnen) hatten meine Probleme angefangen.

    Was ich mir noch vorstellen konnte – heute Morgen.
    a. Fehler in Verbindung mit dem Permalink
    vgl permalinks:
    https://wordpress.org/support/article/writing-posts/#post-field-descriptions
    https://wordpress.org/support/article/using-permalinks/
    b. oder ggf. Htaccess-bezogene Fehler.

    Weitere Tests haben ergeben:
    Interessanterweise konnte ich nicht mal bestehend Postings ändern – die Änderungen wurden nicht übernommen. Und darüber hinaus: Der Versuch ein neues Post zu erstellen, endete mit dem Anlegen eines Drafts.

    Last but not least: Was mir auch noch aufgefallen bzw. durch den Kopf gegangen ist: Wenn eine „Zugriff verweigert“-Seite angezeigt wird, gibt der Server doch normalerweise einen 404-Status zurück (d. h. eine fehlende Seite). Was meines Erachtens dann darauf hindeuten würde, dass dies nicht so sehr ein Problem mit eingeschränktem Zugriff ist, sondern eher etwas mit dem WP-Router,
    Darüber hinaus ist auch interessant: auch auf der Seite „Zugriff verweigert“ werden keine WP-Fehler angezeigt (wie auf der Homepage), was ebenfalls darauf hindeuten würde, dass diese addess-denied-Seite von Server bereitgestellt wird, also nicht von WP.

    Nun – ich hab mir heut nicht die Müh gemacht das noch lang mit dem Server-Admin zu besprechen. Dem wär sicher auch noch was eingefallen.
    Ich hab die Seite frisch aufgesetzt – und hab die DB und alles von Grund auf neu eingespielt. Jetzt läufts, und ich bin nebenbei bemerkt den ganzen Overhead los – mit dem (babylonischen) Sprachenwirrwar.

    ich bin wieder etwas weiter – hab WordPress noch an Stellen kennengelernt die ich noch
    gar nicht so kannte. Bin begeistert wie robust alles ist – und wunder mich noch immer etwas – woran sich das System in den letzen Tagen aufgehangen hat.

    Gut dass man das hier austauschen u. auch aufschreiben kann. So ists ggf einem hilfreich, der ähnliche Themen hat oder ggf. sogar Lösungen.

    Das Forum hier ist eine Wucht – ganz vielen Dank für Euren tollen Support – und dass
    es euch gibt!!

    Macht weiter so!

    Dir nochmals ganz vielen vielen Dank
    Viele Grüße
    STNabor

    Hallo,
    vielen Dank für die Rückmeldung und schön, dass du ganz offensichtlich eine Lösung gefunden hast. 👍

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Viele Grüße
    Hans-Gerd

    Kleine Anmerkung für künftige Leser*innen:

    Ich könnte mir vorstellen, dass der Serveradministrator mod_security installiert hat und die 403er von diesem erzeugt werden.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „„Access denied“ -Fehler – themeübergreifend: wie debuggen?“ ist für neue Antworten geschlossen.