Support » Allgemeine Fragen » Admin Bereich – HTTP 500 Internal Server Error

  • Gelöst ckclaus

    (@ckclaus)


    Hallo zusammen, ich brauche einmal eure Hilfe, weil ich selbst keinen Plan habe, mein Problem zu lösen. Leider kann ich mich nicht mehr in den Admin Bereich meiner Seite einloggen.

    Der Fehler ist wie folgt entstanden:
    Ich hatte „All in One SEO Pack“ installiert, leider kam es nach dem letzten Update von WordPress in WordPress zu einem Fehler, wenn dieses Plugin aktiviert war. Ich konnte „customize.php“ nicht mehr aufrufen „HTTP 500 Internal Server Error“ oder eine leere Seite war das Ergebnis nach Aufruf. Wenn „All in One SEO Pack“ deaktiviert war funktionierte dies bestens. Da ich kein großes Wissen besitze um den Fehler zu finden, entschied ich mich kurzerhand mich von diesem Plugin zu verabschieden.
    Ich installierte stattdessen „Yoast SEO Plugin“ mit dem Erfolg, das ich mich jetzt nicht mehr über die „wp-login.php“ einloggen kann. Jetzt habe ich „HTTP 500 Internal Server Error“ oder eine leere Seite schon beim anmelden in WordPress. Versuche ich mich über das „Wordpress Widget“ in meiner Sidebar anzumelden, komme ich einen Schritt weiter und es erscheint wenigstens das Menü für das Backend. Sobald ich einen Menüpunkt wähle, habe ich meinen Fehler wieder. HTTP 500 Internal Server Error“ oder eine leere Seite“

    Ich hoffe mir kann jemand bei der Lösung des Problems helfen.

    PS: Ich habe bevor ich mich auf die Fehlersuche „customize.php“ gemacht habe mein Jarida-Theme und WordPress 4.7.2 neu installiert, um auszuschließen, dass die Fehler hierdurch verursacht werden.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Die HTTP-Fehlermeldung „500 Internal Server Error“ ist alleine genommen in etwa so aussagekräftig wie die Mitteilung „is‘ kaputt“. Um dem Fehler auf den Grund zu gehen, müsstest du den Error-Log deines Servers auslesen. Dort sollte stehen, was zum Fehler geführt hat.

    Zusätzlich kannst du den Debug-Modus aktivieren, indem du in der wp-config.php die entsprechende Zeile auf define( 'WP_DEBUG', true ); änderst. Die Fehlermeldungen geben auch einen Hinweis, was Auslöser des Problems ist.

    Die (erneute) Aktualisierung von WordPress ist schon mal prima. Um weitere Fehler auszuschließen, solltest du per FTP das Plugin-Verzeichnis vorübergehend umbenennen, z.B. in wp-content/plugins.deaktiviert. Geht dann die Anmeldung im Backend? Die Plugins werden durch die Umbenennung deaktiviert und können, wenn du das Verzeichnis wieder in wp-content/plugins benennst, nach und nach wieder aktiviert werden.

    Dass zwei sehr populäre Plugins zu einem Server-Error führen, könnte auch auf eine zu niedrige PHP-Version hinweisen. Schau mal im Kundemenü, was für deine Website eingestellt ist. Alles unter PHP 5.3 ist fehleranfällig, 5.6 OK, PHP 7 ideal.

    PS: Wenn alles läuft, schau dir mal The SEO Framework an. Schlankes, aber sehr effektives Plugin.

    Vielen Dank für Deine schnelle Antwort auf mein Hilfegesuch. Jetzt bin ich nur mal gespannt, ob ich beim Abarbeiten Deiner Hinweise klar komme. Ich werde Dich auf alle Fälle auf dem Laufenden halten. Danke nochmals …

    Hallo Bego Mario, heute kommt meine Rückmeldung zur Fehlerbehebung auf meiner Seite.

    Ich habe alles so ausgeführt wie du es beschrieben und mir aufgetragen hast. Jetzt funktioniert alles wieder tadellos, sogar das „Yoast SEO Plugin“ funktioniert nach der Aktivierung wieder ohne Probleme.

    Denn Error-Log meines Servers habe ich nicht ausgelesen, ich habe es nicht gefunden bzw. einfach keinen Plan davon. Wahrscheinlich hätte ich damit auch nicht sehr viel anfangen können. In der wp-config.php habe ich ( ‚WP_DEBUG‘, true ) wieder auf ( ‚WP_DEBUG‘, false ) zurück gesetzt.

    Meine Server Version ist 5.5.53 bzw. PHP 5.5, deshalb steht ein Umzug auf einen anderen Server der eine höhere PHP-Version unterstützt demnächst ins Haus. Mein jetziger Server unterstützt leider keine höhere PHP-Version. Aus diesem Grund habe ich „The SEO Framework“ noch nicht installiert.

    Danke nochmals für deine schnelle Hilfe und Unterstützung, dies ist nicht überall selbstverständlich. Bei meinem ersten CMS musste man oft tagelang auf eine Hilfe warten.

    Also bis bald hier im Forum

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Admin Bereich – HTTP 500 Internal Server Error“ ist für neue Antworten geschlossen.