Support » Allgemeine Fragen » admin login unmöglich immer redirect

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Poste doch bitte mal den Inhalt der wp-config.php.
    Vielleicht lässt sich dann mehr sagen.

    Wie bzw. über welche URL meldest du dich an?
    Mir wird das Anmeldeformular unter wp-login.php ganz normal angezeigt.

    WordPress 3.7 (Okotober 2013!) ist tatsächlich sehr alt. Ich hoffe sehr, dass zumindest Sicherheitsupdates gemacht wurden?

    Thread-Starter urswenger

    (@urswenger)

    Hier die wp-config

    <?
    define("DB_NAME", "***");
    define("DB_USER", "***");
    define("DB_PASSWORD", "***");
    define("DB_HOST", "localhost");
    define("AUTH_KEY", "***");
    define("SECURE_AUTH_KEY", "***");
    define("LOGGED_IN_KEY", "***");
    $table_prefix  = 'wopr_';
    define ("WPLANG", "");
    define("ABSPATH", dirname(__FILE__)."/");
    require_once(ABSPATH."wp-settings.php");
    define("WP_AUTO_UPDATE_CORE", false);
    define( 'WP_HOME', 'http://www.active-veterans.org' );
    define( 'WP_SITEURL', 'http://www.active-veterans.org' );
    define( 'WP_SAMESITE_COOKIE', 'Strict' );
    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', ''); 
    ?>

    Danke für Eure Hilfe !!!!


    Moderationshinweis: Bitte nie Zugangsdaten öffentlich posten. Ich habe deine Antwort geändert, aber vorsichtshalber solltest du die Zugangsdaten zur Datenbank ändern.

    • Diese Antwort wurde geändert vor 2 Jahren, 4 Monaten von Bego Mario Garde. Grund: Zugangsdaten entfernt

    Eigentlich sollte nach

    define("ABSPATH", dirname(__FILE__)."/");
    require_once(ABSPATH."wp-settings.php");

    gar kein Eintrag mehr in der wp-config.php stehen.

    Der Eintrag define("WP_AUTO_UPDATE_CORE", false); sorgt dafür, dass automatisierte Aktualisierungen nicht ausgeführt werden. Sollte deine Website tatsächlich noch den Code von 2013 enthalten, hast du eine riesige Sicherheitslücke.

    Die Einträge

    define( 'WP_HOME', 'http://www.active-veterans.org' );
    define( 'WP_SITEURL', 'http://www.active-veterans.org'

    überschreiben den Wert in der Datenbank. Das wird fälschlicherweise verwendet, wenn Websites aus der Entwicklung auf einen Server übertragen werden. Hier sollte der Datenbankeintrag geprüft und ggf. korrigiert werden, danach können die beiden Zeilen in der wp-config.php gelöscht werden.

    Die nachfolgenden Zeilen weisen auf Probleme mit dem Anmelde-Cookie hin und könnten Ursache dafür sein, dass die Anmeldung nicht klappt. Ändere die letzten Zeilen doch mal auf

    // define( 'WP_SAMESITE_COOKIE', 'Strict' );
    // define('ADMIN_COOKIE_PATH', '/');
    // define('COOKIE_DOMAIN', '');
    // define('COOKIEPATH', '');
    // define('SITECOOKIEPATH', ''); 

    (also jeweils mit vorangestelltem // zum Auskommentieren der Zeilen)

    … und schau, ob du dich dann anmelden kannst.

    Es gibt wohl auch ein Problem mit den Permalinks. Ggf. hilft auch, die .htaccess vorübergehend in no.htaccess umzubenennen.

    Thread-Starter urswenger

    (@urswenger)

    Hallo Bego Mario

    danke bestens für Deine Infos.

    Habe wp-config die 5 cookie-stmts mit // ergänzt (auskommandiert)
    leider ohne erfolg.

    ich habe ohne Aenderungen aber festgestellt, dass ich mich mit

    active-veterans.org/wp/wp-admin (im browser mit Inkognito-Fenster !!)

    immer einloggen kann.

    es funktioniert FAST alles mit Ausnahme der Edit einer Page !!
    Der Edit einer Page fällt zurück auf das Login-Fenster.

    kann das nicht ein Problem zu wenig Memory liegen ?

    Ich habe wp-config schon ergänzt mit

    define ( ‚WP_MEMORY_LIMIT‘, ‚256M‘ ); leider ohne Erfolg.

    Auch habe ich im htaccess ganz am schluss auf 256m gesetzt auch ohne Erfolg.

    Hier noch die Permalinks

    DEFAULT http://www.active-veterans.org/?p=123
    DAY NAME http://www.active-veterans.org/2022/01/28/sample-post/
    MONTH NAME http://www.active-veterans.org/2022/01/sample-post/
    NUMERIC http://www.active-veterans.org/archives/123
    POST NAME http://www.active-veterans.org/sample-post/
    CUST STRUC http://www.active-veterans.org/%postname%/

    Danke und einen lieben Gruss aus Steffisburg
    ürsu

    Wenn du dich mit dem privaten Browser-Fenster anmelden kannst, mit dem normalen Browser-Fenster nicht, lösch mal die Cookies.

    Hier noch die Permalinks

    DEFAULT http://www.active-veterans.org/?p=123
    DAY NAME http://www.active-veterans.org/2022/01/28/sample-post/
    MONTH NAME http://www.active-veterans.org/2022/01/sample-post/
    NUMERIC http://www.active-veterans.org/archives/123
    POST NAME http://www.active-veterans.org/sample-post/
    CUST STRUC http://www.active-veterans.org/%postname%/

    Das sind deine Auswahlmöglichkeiten – für welche hast du dich denn entschieden? Beitragsname ist wohl das am häufigsten genutzte, weil dann auch Suchmaschinen mit den Links mehr anfangen können.

    Thread-Starter urswenger

    (@urswenger)

    Hallo Bego Mario
    danke für die Antwort.
    Das löschen des Browser-Cache bringt leider auch nichts !!

    Ist der Memory-Bedarf von WP oder PHP nicht vielleicht das Problem ?

    Wenn ich eine Seite editiere oder die Permalinks save erscheint immer das Login-Bild für die Anmeldung !

    Danke
    Gruss
    Urs Wenger

    Ist der Memory-Bedarf von WP oder PHP nicht vielleicht das Problem ?

    Deine Website hat einen Arbeitsspeicher (RAM) von 256MB zugewiesen bekommen, das sollte ausreichen.

    Wenn ich eine Seite editiere oder die Permalinks save erscheint immer das Login-Bild für die Anmeldung !

    Da stimmt etwas mit den Cookies nicht – und da wurde ja auch mit den auskommentierten Zeilen versucht, das Problem zu lösen. Wer hat die Zeilen dort eingefügt?

    Thread-Starter urswenger

    (@urswenger)

    Leider weiss ich nicht, wer diese Zeilen im wp-config eingefügt hat.

    Ich habe das ganze vor 3 Jahren von jemandem übernommen und habe auch noch nicht so grosse WP Kenntnisse.
    Ich habe immer nur gewisse Updats in einer Webseite gemacht. (ein Doku eingestellt zum Downloaden und auf einer anderen Seite einige Fotos eingestellt.)

    Kann man im SP die Cookies nicht ausschalten ?
    Danke Gruss
    Urs Wenger

    Thread-Starter urswenger

    (@urswenger)

    Im WP ist ein Plugin

    Wordpress Statistics Version 3.2 by Mostafa Soufi

    vorhanden.

    Könnte das eventuell ein Problem sein ?

    Thread-Starter urswenger

    (@urswenger)

    Uebrigens ist der Permalink

    Post Name http://www.active-veterans.org/sample-post/

    ausgewählt.

    Hattest du die Zeilen

    define( 'WP_HOME', 'http://www.active-veterans.org' );
    define( 'WP_SITEURL', 'http://www.active-veterans.org' );

    eigentlich auskommentiert? Falls nicht, probier bitte mal

    define( 'WP_HOME', 'http://www.active-veterans.org/wp' );
    define( 'WP_SITEURL', 'http://www.active-veterans.org' );
    Thread-Starter urswenger

    (@urswenger)

    Hallo Bego Mario

    ich danke danke danke Dir. Vermutlich geht alles bin noch am Testen.
    Editieren von Seiten geht !!
    Save von Permalink auch !!

    Das folgende aus aus wp-config entfernt

    define( ‚WP_HOME‘, ‚http://www.active-veterans.org&#8216; );
    define( ‚WP_SITEURL‘, ‚http://www.active-veterans.org&#8216; );
    define( ‚WP_SAMESITE_COOKIE‘, ‚Strict‘ );
    define(‚ADMIN_COOKIE_PATH‘, ‚/‘);
    define(‚COOKIE_DOMAIN‘, “);
    define(‚COOKIEPATH‘, “);
    define(‚SITECOOKIEPATH‘, “);

    Wenns nicht gehen sollte werde ich mich wieder melden !!
    Danke danke danke !!!

    Wir freuen uns mit dir und wenn’s noch Fragen gibt, meldest du dich bitte wieder.

    Thread als „gelöst“ markiert.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „admin login unmöglich immer redirect“ ist für neue Antworten geschlossen.