Support » Plugins » Advanced Custom Fields – Feld-Typ verloren ?

  • kauschm

    (@kauschm)


    Hallo,

    ich lege mit dem ACF-Plugin eine Selectbox an, was bestens funktioniert.
    ABER wenn ich dieses Feld nochmal zum Bearbeiten öffne, um einige Einstellungen anzupassen, steht die Auswahl für den Feldtyp wieder auf dem ersten Eintrag (Text einzeilig) – ist das vielleicht ein BUG im Plugin?
    Die anderen Einstellungen, also z.B. die Auswahl-Einträge, bleiben erhalten.

    Ich hab nichts dazu gefunden,
    mfG, Michael

    • Dieses Thema wurde geändert vor 4 Wochen von  kauschm.
Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ich hab mal rasch die kostenlose Version von Advanced Custom Fields installiert und ein Auswahlfeld angelegt, kann aber den von dir beschriebenen Fehler nicht nachvollziehen.

    Hast du getestet, ob der Fehler besteht, wenn alle anderen Plugins deaktiviert wurden?

    kauschm

    (@kauschm)

    hab ich gemacht, auch ein WP-Standard-Theme festgelegt, der Fehler bleibt.

    Es wird immer seltsamer:
    Ich habe innerhalb der Feldgruppe ein zweites Feld (Text mehrzeilig) angelegt und an die erste Stelle verschoben, so daß die Selectbox an zweiter Stelle steht.
    Jetzt behält die Selectbox ihren Feldtyp, aber beim ersten Feld ist „Text einzeilig“ eingestellt.

    Also will er offenbar an erster Stelle immer nur den ersten der möglichen Typen ???

    Ergänzung:
    Wenn ich die Feldgruppe mit dem falsch eingestellten Feldtyp speichere, bleibt der Typ im Content-Backend doch erhalten.
    Es sieht so aus, als würde das Plugin nur beim Bearbeiten die Aktualisierung des ersten Eintrags nicht schaffen.

    Im Inspector sehe ich:
    <option value="select" selected="selected" data-i="0">
    obwohl in der Auswahlbox oben „Text einzeilig“ steht.

    • Diese Antwort wurde geändert vor 4 Wochen von  kauschm.
Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)