Support » Allgemeine Fragen » Ändern der URL der Hauptwebseite einer Multisite von http in https

  • Gelöst Artan

    (@artankrasniqi1988)


    Ich habe ein ähnliches Thema gefunden, aber es hat mein Problem nicht gelöst. Ich habe eine WordPress Multisite installiert. Ich habe alle Werte manuell geändert, die in endlosen Foren und Tutorials beschrieben sind.

    Meine Websites > Netzwerkverwaltung > Websites > Bearbeiten > Info –> Hier bleibt die Website-URL bei http.

    Meine Websites > Netzwerkverwaltung > Websites > Bearbeiten > Einstellungen –> Hier wurden die „Siteurl“ und „Home“ in https geändert.

    Warum?

    Ich habe meine Änderungen endlos überprüft. Die Änderungen sollten alle korrekt sein und dort durchgeführt worden, wo sie sollten. Trotzdem bleibt die URL der Hauptseite bei http, was ich nicht verstehe. Ich habe die Änderungen in Bezug auf dieses Tutorial und anderer vorgenommen:

    https://wpengine.com/support/how-to-change-a-multi-site-primary-domain/

    Auch ich habe die Werte eingegeben:

    define (‚WP_HOME‘, ‚http://somedomain.com‘); define (‚WP_SITEURL‘, ‚http://somedomain.com‘);

    Nur um sicher zu gehen! Es hat nichts gebracht, also habe ich diesen letzten Teil wieder gelöscht.

    Könnt ihr mir bitte helfen? Das ist so frustrierend.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Workaround:

    1. Backup der Datenbank machen. Kein Backup, kein Mitleid.
    2. in der wp-config.php den Code-Block für Multisite mit vorangestelltem // vor jeder Zeile auskommentieren (nicht löschen). Sinngemäß:
      // define( 'WP_ALLOW_MULTISITE', true );
      // define( 'MULTISITE', true );
      // define( 'SUBDOMAIN_INSTALL', true );
      // $base = '/';
      // define( 'DOMAIN_CURRENT_SITE', 'example.com' );
      // define( 'PATH_CURRENT_SITE', '/' );
      // define( 'SITE_ID_CURRENT_SITE', 1 );
      // define( 'BLOG_ID_CURRENT_SITE', 1 );
    3. neu anmelden und unter Einstellungen > Allgemein die URL auf https://example.com (mit deiner Domain) ändern
    4. in der wp-config.php den Code-Block die Kommentar-Zeichen // für Multisite wieder löschen. Sinngemäß:
      define( 'WP_ALLOW_MULTISITE', true );
      define( 'MULTISITE', true );
      define( 'SUBDOMAIN_INSTALL', true );
      $base = '/';
      define( 'DOMAIN_CURRENT_SITE', 'example.com' );
      define( 'PATH_CURRENT_SITE', '/' );
      define( 'SITE_ID_CURRENT_SITE', 1 );
      define( 'BLOG_ID_CURRENT_SITE', 1 );
    5. weitermachen, wie wenn nichts gewesen wäre.
    Thread-Ersteller Artan

    (@artankrasniqi1988)

    Man! Danke dir vielmals! Ich habe den halben Tag daran gesessen und die Lösung hats jetzt gebracht! Ich danke dir! 🙂

    Aber wie kommt man darauf diesen Schritt zu machen und warum genau muss das sein wenn ich doch schon alle Werte manuell geändert hatte!?

    Da kommt doch normalerweise keiner drauf wenn man nur eben seine URL-Struktur ändern möchte. An dem Punkt war ich kurz davor die Multisite-Option an den Nagel zu hängen, obwohl ich denke das es viele Vorteile bringen kann.

    Danke nochmal!

    Aber wie kommt man darauf diesen Schritt zu machen …

    Die Anleitung, nach der du zuerst vorgegangen bist, sollte eigentlich funktionieren, hat aber viele mögliche Fehlerquellen. Das jetzt alles einzeln abzufragen wäre ein wenig mühsam.

    Die WordPress-Entwickler sind wohl davon ausgegangen, dass sich die Haupt-Website nie ändert, was die Sache tatsächlich recht umständlich macht. Bei einer einzelnen Website ist es hingegen kein Problem. Deshalb die Überlegung, das erst einmal auf eine normale Website zurückzusetzen, die Änderung durchzuführen, dann wieder auf Multisite umzustellen. Die Lösung kam von Stackexchange: https://wordpress.stackexchange.com/a/355888/129212

    Thread-Ersteller Artan

    (@artankrasniqi1988)

    Ja, ok. Das hab ich mir auch schon gedacht, dass irgenwas an der Multisite die Änderungen nicht möchte. Danke, du bist ein Fuchs. Auch wenn es schon in Stackexchange war, findet man das nicht unbedingt immer so schnell. Du hast mir echt Zeit erspart.

    Ich werds teilen damit Leute nicht die selbe Zeit verlieren wie ich. Dann kann man nur hoffen, das eventuell die Einstellungen dafür in Zukunft simpler gestaltet werden.

    Have a nice day!

    Klasse! bei mir hat es auch funktioniert…
    die Welt (wordpress) kann so einfach sein!

    Vielen Dank
    Marko

    Moderator Bego Mario Garde

    (@pixolin)

    In dem Fall gilt vor allem Schritt 5. 😉

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)