Support » Installation » Änderung der PHP Version

  • Gelöst naturenergie

    (@naturenergie)


    Guten Tag,

    vor einiger Zeit hatten wir für unser Unternehmen eine Website erstellen lassen.
    Der Beauftragte IT-Dienstleister steht leider nicht mehr zur Verfügung, deshalb versuchen wir nun selbst eine Lösung für dieses Problem zu finden.

    Wir haben heute die PHP-Version von 7.1 auf 8.0 (empfohlen) gesetzt und nun funktioniert die Website nicht mehr.

    Wir erhalten auf verschiedenen Endgeräten unterschiedliche Ansichten:

    1.) Am Mobiltelefon (IOS) bekommen wir den Fehlercode:
    Fatal error: Array and string offset access syntax with curly braces is no longer supportet in /homepage/11/d336278102/htdocs/naturenergiedach/wp-includes/script-loader.php

    2. Am Windows-PC (sowohl Chrome als auch Firefox getestet)
    Hier erscheint eine Seite, wo man darauf Hingewiesen wird, dass Cookies verwendet werden. Klickt man auf Zustimmen kommt man auf eine Seite vom Provider, aber nicht auf unsere Website.

    Wir haben die PHP Version auch schon wieder zurück gesetzt auf 7.1 und 7.4, aber leider ohne Erfolg.

    Nun hoffen wir hier Hilfestellung zu erlangen und bedanken und im Voraus!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Problem scheint ja erstmal gelöst zu sein, die Seite läuft ja wieder. Du solltest aber auf jeden Fall WordPress selber, Plugins und Themes aktualisieren, WordPress 5.2.15 ist ja schon recht alt. Außerdem solltest du erst einmal bei PHP 7.4 bleiben, da noch nicht alle Plugins mit PHP 8 zurecht kommen.

    Nachtrag: Eine Firmenseite ohne SSL ist auch nicht so der Hit.

    • Diese Antwort wurde geändert vor 1 Monat, 1 Woche von bscu.
    Thread-Starter naturenergie

    (@naturenergie)

    Oh, bei mir läuft sie an zwei Laptops nicht und das, obwohl ich die Cache geleert habe – siehe Screenshots:

    https://imgur.com/mATu0PA
    https://imgur.com/iTFKkSy

    Am Handy geht es

    Hallo,
    ich kann das hier auch nicht nachvollziehen.
    Teste das doch mal in einem privaten Fenster (Firefox) und/oder im Inkognitomodus (Chrome). Die Option findest du oben rechts bei den drei senkrechten Punkten in Chrome.
    Vielleicht ist das ein Problem mit dem Cache des Browsers. Ggfs. auch mal den Browsercache löschen.

    Viele Grüße
    Hans-Gerd

    Thread-Starter naturenergie

    (@naturenergie)

    Hallo Hans-Gerd,

    auch im Inkognitomodus im Chrome erhalte ich gleiches Bild:
    https://imgur.com/v0D0h2T

    Browser-Cache und alle anderen Browserdaten habe ich bereits mehrfach gelöscht

    Versuche es mal mit einem anderen Browser. Ich habe jetzt mit Firefox, Chrome, Opera und Edge getestet, alles ok.

    Thread-Starter naturenergie

    (@naturenergie)

    Es scheint am Heimnetz zu liegen, warum auch immer.

    Ist am Handy (IOS) WLAN an, geht es nicht, ist es aus, und nutze ich mobile Daten, geht die Seite plötzlich.

    Ich bin verwirrt …

    @naturenergie
    Würdest du dann bitte diesen Thread als gelöst markieren? Danke.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)