• Hej zusammen,

    ich bin der Entwickler vom Plugin „WP AMP it up!“ und habe ein Problem, bei dem ich von meiner Seite aus wohl nicht weiter komme.

    Seit einiger Zeit ist es so, wenn man das Plugin installiert, erscheint im WordPress-Back-End unter „Dashboard->Aktualisierung“ die Fehlermeldung:

    Bei folgenden Übersetzungen ist die Aktualisierung fehlgeschlagen:
     * Fehlgeschlagen: Übersetzungen für WP AMP it up!

    Aber nicht nur dort, auch wenn man im Anschluss andere Plugins installiert, oder aktualisiert erhält man stets eine Fehlermeldung wie folgend:
    Installation fehlgeschlagen: Download fehlgeschlagen. Not Found

    Trotz der Fehlermeldung werden die Plugin jedoch installiert/aktualisiert, lassen sich auch aktivieren und funktionieren ganz normal!

    Ich bin daher auf Fehlersuche gegangen und vermutete erstmal Fehler im PHP-Code vom AMP-Plugin, nachdem ich nichts finden konnte, habe ich begonnen Programmzeile für Programmzeile zu entfernen und immerwieder zu testen, bis ich nur noch eine leere PHP-Datei hatte. Dennoch traten die Fehler weiterhin auf, erst als ich die Datei selbst gelöscht habe (nur die Datei, nicht das ganze Plugin-Verzeichnis), sind die Fehler verschwunden.

    Ich habe noch ein zweites Plugin, „AMP+ Plus“, welches sich in wenigen Zeilen unterscheidet, ansonsten aber den selben Programmcode besitzt. Wenn man dieses Plugin installiert erscheinen die Fehler nicht!?

    Ich kann mir nicht erklären, warum die Fehlermeldungen bei „WP AMP it up!“ auftauchen, selbst wenn jeglicher Programmcode gelöscht wird.

    Da aber auch der Fehler „Fehlgeschlagen: Übersetzungen für WP AMP it up!“ erscheint, vermute ich, dass es irgendein Problem mit den Übersetzungsdateien gibt (wie der Fehler es ja selbst auch sagt).

    Die Übersetzungen, sind ebenso wie beim „AMP+ Plus“ Plugin über GlotPress umgesetzt, d.h. im Grunde müssen keine speziellen Übersetzungsdateien (.mo oder .pot) im Plugin selbst abgelegt werden, sondern werden automatisch von WordPress geladen. – Wie es z.B. auch bei „AMP+ Plus“ ganz normal funktioniert.

    Ich konnte feststellen, dass beim Download und Aktivierung eines beliebigen Plugins die Übersetzungsdateien automatisch heruntergeladen und im Verzeichnis „wp-content/languages/plugins/“ gespeichert werden (z.B. /wp-content/languages/plugins/amp-plus.mo und /wp-content/languages/plugins/amp-plus.pot). Aufgefallen ist mir, dass genau das nicht passiert, wenn man „WP AMP it up!“ installiert!?

    Ich schätze aus irgendeinem Grund werden diese Dateien nicht geladen oder gespeichert, was auch zu den Texten der Fehlermeldungen passen würde. – Nun ist es aber so, dass ich als Plugin-Entwickler ja keinen Einfluss darauf habe, wie diese Download-Prozesse organisiert sind und herausfinden kann, warum es nicht funktioniert und hoffe daher hier kann mir jemand weiterhelfen oder hat einen Tipp.

    Hat jemand eine Idee, wie ich das Problem lösen kann? Oder erkennt jemand, dass ich auf dem Holzweg bin und die Ursache für die Fehler an etwas anderem liegt?

    Beste Grüße
    Björn

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 16)
  • Hallo,
    du schreibst:

    Seit einiger Zeitist es so, wenn man das Plugin installiert erscheint im WordPress-Back-End unter „Dashboard->Aktualisierung“ die Fehlermeldung:

    .
    Du hast das aber nicht zufällig mal mit einer älteren Version deines Plugins getestet, mit der das noch funktioniert hat? Dann würde ich den Source der alten und neuen Version miteinander vergleichen. Das geht beispielsweise sehr schön über PsPad ohne viel Aufwand, das ich gerade für solche Zwecke ganz gerne einsetze (sonst nutze ich Atom).

    Außerdem werden in den genannten Ordner die Dateien .po und .mo übertragen, aber nicht die .pot-Datei.
    Viele Grüße
    Hans-Gerd

    Ich hab mal rasch das Plugin installiert und erhalte die gleiche Fehlermeldung, dass der Download der Übersetzung scheitert. Ich vermute, dass der Übersetzungs-Cache noch nicht aktualisiert wurde und die noch relativ neue Übersetzung bisher nicht richtig eingelesen wurde. Vielleicht wartest du nochmal einen Tag?

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @hage
    Danke, Du hast Recht sind die .po Dateien statt .pot, korrigiere ich gleich mal.

    Zu den anderen Anmerkungen: Ja, das habe ich auch schon alles durch. Daher war ich zum Schluss schon so weit Zeile für Zeile zu entfernen, um so eventuelle Code-Fehler zu finden. Aber selbst wenn gar kein Code in der Datei steht kommen die Fehler, alleine das finde ich merkwürdig. – Die einzige Abweichung, die ich feststellen konnte ist das mit den .mo und .po Dateien. – Ich kann mir nicht erklären warum und glaube daher, dass es irgendwie damit zusammenhängt.

    LG Björn

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @pixolin

    Danke, ich hatte so etwas zu Beginn auch schon in Verdacht, aber ich bin mittlerweile schon mehrere Wochen auf der Fehlersuche. Wäre es tatsächliche ein Cache-Thema, würde ich schätzen, dass es sich dann zwischenzeitlich erledigt hätte.

    Kann man das ansonsten irgendwie manuell anstoßen, um diese eventuelle Ursache nochmal direkt auszuschließen?

    LG Björn

    Wenn ich mich richtig erinnere, hilft auch eine Änderung der SVN Repos, etwa wenn du etwas an der Readme-Datei geändert hast.

    Hallo,
    z. Zt. lässt sich leider das Plugin gar nicht installieren.
    Da ich Poedit für die Übersetzung bei meinem Plugins nutze und die (deutschen) Übersetzungen im Ordner languages direkt mitliefere, hatte ich leider noch nie Probleme damit.
    Mit GlotPress habe ich noch nicht gearbeitet.

    Nachtrag:Obwohl bei der Installation die Meldung erscheint, dass die Installation fehlgeschlagen ist, ist das Plugin in der Tat installiert, wie ich gerade zufällig festgestellt habe.
    Vielleicht wäre ja auch ein Ansatz, die Übersetzungen mit Poedit zu erstellen und den language-Ordner mitzuliefern. Im Rahmen eines Betatests hatte ich das Problem, dass die Übersetzungen nicht in aktualisierter Form gezeigt wurden. Vielleicht ist die folgende Antwort vom Autor von Poedit hilfreich: „Yes, this is typical – the wp-content/languages/plugins location is actually better. Poedit’s FTP connectivity options always uploads to there, because files won’t be overwritten by plugin updates, and because it is the highest-priority location where WP looks first.“
    Viele Grüße
    Hans-Gerd

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @pixolin Ok, Danke, das hatte ich im Laufe der Zeit schon öfter getan. D.h. den Cache als Ursache kann man dann wohl ausschließen :\ – Mich irritiert ja auch, dass selbst wenn die Script-Datei „wp-amp-it-up.php“ leere, also kein Programmcode enthalten ist, die Fehler weiterhin kommen, also gar kein Code existiert. Lösche ich die Datei, sind die Fehler weg… Ich kann es mir nicht erklären.

    LG Björn

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @hage Der Nachtrag ist nochmal ein Tipp, dem ich nachgehen kann. Ich werde mal die Übersetzungsdateien im Plugin mitliefern und schauen, ob es damit funktioniert. Auf die Idee bin ich tatsächlich noch gar nicht gekommen! – Ich werde berichten, ob es geholfen hat!

    Nochmal Danke für die für die Anstöße!

    LG Björn

    Ich werde berichten, ob es geholfen hat!

    das wäre super – viel Erfolg 🙂

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @hage Hat leider auch nichts bewirkt 🙁

    @ampcloud Die zip-Datei enthält aber auch keinen Ordner languages und damit auch keine PO- und MO-Dateien.
    Ich sehe da keine grundlegende Änderung zu der vorherigen zip-Datei

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @hage Da es nicht geholfen hatte, habe ich wieder alles zurückgesetzt. Deshalb ist in der jetzigen ZIP auch kein Unterschied mehr zu erkennen.

    @ampcloud sehr seltsam. Dann fällt mir leider auch erst mal nichts mehr ein 🙁
    Vielleicht wirst du hier fündig bzw. du kannst da ja mal die Frage stellen.
    Betrifft zwar eher Entwicklung (also Fragen zu PHP und JS), aber wer weiß …

    Thread-Starter amp-cloud.de

    (@ampcloud)

    @hage Trotzdem Danke, die Ansätze waren ja ganz gut und einen Versuch wert. Ich verstehe auch nicht, was da falsch läuft.

    LG Björn

    Thread-Starter amp-cloud.de

    (@ampcloud)

    Ok konnte es jetzt beheben.

    Ursache:
    Über GlotPress werden normalerweise Language-Packs für jede Plugin-Version angelegt (wie auch hier beschrieben GlotPress Translation). Diese Packs werden normalerweise automatisch heruntergeladen ins Verzeichnis „wp-content/languages/plugins/“

    Warum auch immer wurden diese Language-Packs für die letzten, neuen Versionen nicht von GlotPress erstellt, weshalb WordPress keine zur installierten Version passenden .mo und po. Dateien vorfinden konnte. Somit war kein Download der .mo. und .po Dateien möglich, also Fehler:
    Installation fehlgeschlagen. Nicht gefunden.!
    Bei folgenden Übersetzungen ist die Aktualisierung fehlgeschlagen:

    Ich bin daher auf die alte Methode zurückgekehrt und habe die Languages-Dateien wieder manuell im Plugin-Slug abgelegt, was ja eigentlich laut GlotPress Doku nicht mehr nötig seien sollte.

    Danach musste ich natürlich noch die Header-Daten der Plugin-Dateien anpassen und den „Domain Path:„, sowie die „Text Domain“ angeben wie folgend:

    /*
    Plugin Name: AMP it up!
    Plugin URI: https://www.amp-cloud.de/google-amp-plugins/wordpress/amp-fuer-wordpress.php
    Description: AMP for WordPress automatically add Accelerated Mobile Pages (Google AMP Project) functionality on your Site! Just install, activate it and it´s done! This official AMP WordPress plugin from amp-cloud.de enable automated AMP support to your website for free! It creates without any prior knowledge and completely free Google-compliant AMPHTML versions of your webpages.
    Author: amp-cloud.de | Björn Staven
    Text Domain: wp-amp-it-up
    Domain Path: /languages
    Version: 3.4
    Author URI: https://www.amp-cloud.de
    Update Server: https://www.amp-cloud.de
    License: GPL
    License URI: https://www.gnu.org/licenses/gpl
    */

    Danach hatte ich folgende beispielhafte Ordnerstruktur im Repository:

    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/readme.txt
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/wp-amp-it-up.php
    
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/wp-amp-it-up.pot
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/wp-amp-it-up-de_DE.po
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/wp-amp-it-up-en_DE.mo
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/wp-amp-it-up-en_GB.po
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/wp-amp-it-up-en_GB.mo
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/...
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/languages/...
    
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/assets/...
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/tags/...
    https://plugins.svn.wordpress.org/wp-amp-it-up/trunk/branches/...

    Warum auch immer waren kurz darauf dann auch die Languages-Packs von GlotPress aktualisiert und die Fehlermeldungen waren weg! Und im Verzeichnis „wp-content/languages/plugins/“ wurden nun auch die .mo und .po Dateien heruntergeladen dann.

    Was ich zwar noch immer nicht verstehe:
    1. GlotPress soll ja grade den Vorteil haben keinen extra Language-Oder und Languages-Dateien anlegen und mitliefern zu müssen, warum klappt es jetzt nur wenn ich es trotzdem mache?

    2. Oben erwähnte ich mein anderes Plugin „AMP+ Plus“ das auch mit GlotPress übersetzt wird und dort liefere ich auch keine Languages-Dateien und-Ordner mit und dort erscheinen die Fehler nicht. (Also warum funktioniert es dort ohne die Dateien mitzuliefern bei „AMP it up!“ aber nicht!?)

    3. Für den oben erwähnten Workarround habe ich die Version des Plugins auf 3.4 geändert uns auch als Stable Tag definiert. Die GlotPress Languages-Packs wurden aber nur für die Vorgänger-Version 3.3 erstellt… Trotzdem funktioniert jetzt alles.

    Also auch wenn ich das jetzt noch immer nicht wirklich verstanden habe, hat der beschriebene Workarround geholfen und es läuft wieder alles ohne Fehlermeldungen. Soll mir an dieser Stelle erstmal reichen :0) – Wenn jemand eine genaue Erklärung hat, würde mich die gerne interessieren, möchte ja eigentlich verstehen was das tatsächliche Problem war und wie Dinge zusammenhängen, ansonsten hoffe ich, dass diese Lösung anderen helfen kann, die ähnliche Probleme haben.

    Danke an @hage und @pixolin für eure Hilfe!

    MfG Björn

Ansicht von 15 Antworten – 1 bis 15 (von insgesamt 16)
  • Das Thema „Aktualisierung der Übersetzungen fehlgeschlagen“ ist für neue Antworten geschlossen.