Support » Allgemeine Fragen » Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst mudanz

    (@mudanz)


    Hallo!
    Ich habe jetzt über Stunden versucht, das Problem zu lösen (FAQ lesen, Foren durchsuchen und dortige Vorschläge umsetzen). Ich bin am Ende meiner wenigen Fähigkeiten, deshalb meine Frage an Euch.

    Meine Seite wird bei strato gehostet, die PHP steht auf 7.3, eine Änderung auf 7.4 (empfohlen von WordPress) ergab keine Änderung. Alle Aktualisierungen sind durchgeführt (Software, Plugins, Themes). Der Zustand der Seite ist bis auf PHP gut und der Fehlerbericht erbringt 16 fehlerfreie Meldungen.
    Bei der Bearbeitung meines Beitrags („Unser Covid-Tagebuch“) kommt beim Aktualisieren immer der gleiche Fehler: Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort. Anschließend muss ich „die Seite verlassen“, um wieder zum Dashboad zu kommen.
    Der Versuch, einen einfachen Testbeitrag zu erstellen und zu veröffentlichen, klappte ohne Probleme (https://blog.mudanz.de/test/). Auch anschließende Veröffentlichg funktionierte.
    Die Änderung eines anderen Beitrags klappte auch ohne Probleme.
    Der Versuch, danach auch meinen „alten“ Covid-Beitrag (https://blog.mudanz.de/unser-covid-tagebuch-2020/)zu aktualisieren, lief aber wieder ins Leere. Kann so ein Fehler nur für einen Beitrag gelten?

    Zur Vollständigkeit hier mal der Testbericht:

    
    ### wp-core ###
    
    version: 5.4.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web015/d0/02/53953202/htdocs/WordPress_01
    wordpress_size: loading...
    uploads_path: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content/uploads
    uploads_size: loading...
    themes_path: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content/themes
    themes_size: loading...
    plugins_path: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Balanced Blog (balanced-blog)
    version: 1.0.8
    author: HeadThemes
    author_website: https://headthemes.com/
    parent_theme: none
    theme_features: title-tag, menus, post-thumbnails, custom-background, custom-header, custom-logo, automatic-feed-links, widgets
    theme_path: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content/themes/balanced-blog
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.4, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (3) ###
    
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Page Visit Counter: version: 6.0.4, author: theDotstore
    UpdraftPlus - Backup/Restore: version: 1.16.26, author: UpdraftPlus.Com, DavidAnderson
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-47 Q16 x86_64 2019-05-28 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 512 GB
    	imagick::RESOURCETYPE_DISK: 9.2233720368548E+18
    	imagick::RESOURCETYPE_FILE: 192
    	imagick::RESOURCETYPE_MAP: 512 GB
    	imagick::RESOURCETYPE_MEMORY: 256 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.3.18
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Sat, 04 Jul 2020 11:09:06 GMT
    	server: Apache/2.4.43 (Unix)
    	x-powered-by: PHP/7.3.18
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://blog.mudanz.de/wp-json/>; rel="https://api.w.org/"
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content
    WP_PLUGIN_DIR: /mnt/web015/d0/02/53953202/htdocs/WordPress_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable

    Ich verdiene mit meinem Blog kein Geld, ist nur für Familie, reunde und für mich. Insoweit liegt keine Dringlichkeit vor. Aber über eine Lösung des Problems würde ich mich riesig freuen, da ich das sonst nicht mehr weiterführen kann …

    Mit besten Grüßen aus dem Revier
    Uwe

    • Dieses Thema wurde geändert vor 6 Monaten, 3 Wochen von Bego Mario Garde.
    • Dieses Thema wurde geändert vor 6 Monaten, 3 Wochen von Bego Mario Garde. Grund: Formatierung Website-Bericht korrigiert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Ruf mal das Menü Einstellungen > Permalink auf (mehr brauchst du hier nicht tun) und schau, ob sich dadurch bereits etwas ändert. WordPress liest durch den Aufruf des Menüs die gewünschte Permalink-Einstellung erneut ein, was bereits den Fehler behebeb könnte.

    Falls das nicht ausreicht: Ist im Kundenmenü bei Strato der Punkt „Server Side Security“ deaktiviert?

    Herzlichen Dank!
    Unter den Einstellungen – Permalinks hat sich wohl nichs geändert. Die Einstellungen stehen noch auf „Gebräuchliche Einstellungen – Beitragsname“.

    Die Deaktivierung der Server Side Security habe ich bei Strato in Angriff genommen. Da fehlen mir noch Zugangsdaten zum Server-Login, da ich über die Hilfe in meinem „normalen“ Account auf diesen Login geführt werde.

    Da muss ich abwarten, werde mich aber dann melden, was passiert.
    Schönes Wochenende.

    So, habe gerade Kontakt mit Strato gehabt. Hinter dieser Server Side Security versteckt sich der Gästebuch-Spam-Filter (bekommt man über die Hilfe dort nicht). Den Filter habe ich rausgenommen und alles funzt.

    Ganz lieben Dank für die kompetente Hilfe und noch einen schönen Sonntag.

    Uwe Danz

    Hinter dieser Server Side Security versteckt sich der Gästebuch-Spam-Filter (bekommt man über die Hilfe dort nicht).

    Echt?

    https://www.strato.de/faq/hosting/fehler-503-error-service-unavailable-bei-der-verwendung-von-post-requests/

    Aber Hauptsache, es läuft.

    knallblaumedia

    (@knallblaumedia)

    Das Aufrufen von Einstellungen > Permalink hat bei mir ebenfalls geholfen. Eine Änderung musste ich nicht vornehmen.

    Einmal kurz zur Info. Nutze ebenfalls Strato und hatte dieselbe Fehlermeldung.

    Permalinks habe ich probiert. Hat leider keinen Erfolg gebracht.

    Das Ausschalten des Gästebuchspamfilters wie von mudanz beschrieben, beendete den Fehler sofort.

    Vielen Dank

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)