Support » Allgemeine Fragen » Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst jackspeck

    (@jackspeck)


    Hallo zusammen,
    seit gut zwei Wochen kann ich leider auf der Seite meiner Schule keine Beiträge mehr aktualisieren. Ich erhalte immer die Fehlermeldung:

    „Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.“

    Die gleiche Fehlermeldung bekomme ich auch, wenn ich zum Beispiel nur eine Verlinkung anpassen möchte.

    Wenn ich im Editor ein Bild einfüge, dann erhalte ich folgende Meldung:

    „In Diesem Block ist ein Fehler aufgetreten und eine Vorschau ist nicht möglich.“

    Wenn ich den Website Zustand prüfe bekomme ich folgende Warnungen:

    1. Ein oder mehrere empfohlene Module fehlen

    PHP-Module führen die meisten Aufgaben auf dem Server aus, die deine Website zum Laufen bringen. Alle Änderungen daran müssen von deinem Server-Administrator vorgenommen werden.

    Das WordPress-Hosting-Team führt eine Liste der empfohlenen und erforderlichen Module in dem Teamhandbuch (öffnet in neuem Tab) (engl.).

    Warnung Das optionale Modul imagick ist nicht installiert oder wurde deaktiviert.

    2.
    Ein geplantes Ereignis ist verspätet

    Das geplante Ereignis, inpsyde_phone-home_checkin, wird zu spät ausgeführt. Deine Website funktioniert noch, aber das kann darauf hindeuten, dass die Planung von Beiträgen oder automatisierten Updates nicht wie geplant funktioniert.

    3.
    Die REST-API kam zu einem unerwarteten Ergebnis

    Die REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Ein Beispiel ist der Bildschirm des Block-Editors, der darauf aufbaut, deine Beiträge und Seiten anzuzeigen und zu speichern.

    Der Aufruf der REST-API führte zu folgendem unerwarteten Ergebnis: (403) <!DOCTYPE html> <html style=“height: 100%;“> <head> <meta charset=“UTF-8″> <title>403 Access Forbidden</title> <style> @media screen and (max-width: 800px) { body > div > div > div div { display: block !important; padding-right: 0 !important; } body { text-align: center !important; } } </style> </head> <body style=“height: 90%;“> <div style=“display: flex; align-items: center; justify-content: center; height: 90%;“> <div style=“background-color: #eee; width: 70%; border: solid 3px #ddd; padding: 1.5em 3em 3em 3em; font-family: Arial, Helvetica, sans-serif;“> <div style=“display: table-row;“> <div style=“display: table-cell; font-size: 150px; color: red; vertical-align: top; padding-right: 50px;“> ✋ </div> <div style=“display: table-cell; vertical-align: top;“> <h1 style=“margin-top: 0;“>Es tut uns leid, aber Sie dürfen nicht fortfahren</h1> <p>Your request looks suspiciously similar to automated requests from spam posting software or it has been denied by a security policy configured by the website administrator.</p> <p>If you believe you should be able to perform this request, please let us know.</p> <p style=“margin-top: 2em;“>

    RID: JXW3X7H1US5PW6Y2NULO0KMC

    </p> </div> </div> </div> </div> </body> </html> .

    Was ich bisher unternommen habe:
    Ich habe diesen Artikel zu WP 5.5 Update gelesen und die Tipps ausprobiert.

    Das Plugin Enable jQuery Migrate Helper hat keine Änderungen gebracht.

    Die Fehlermeldungen meines Browsers zeigen:

    Diese Seite verwendet die nicht standardisierte Eigenschaft „zoom“. Stattdessen sollte calc() in den entsprechenden Eigenschaftswerten oder „transform“ zusammen mit „transform-origin: 0 0“ verwendet werden. post.php
    JQMIGRATE: Migrate is installed with logging active, version 1.4.1 jquery-migrate-1.4.1-wp.js:23:17
    Layout-Darstellung wurde erzwungen, bevor die Seite vollständig geladen war. Falls Stylesheet noch nicht geladen sind, kann dies zu einem kurzzeitigen Darstellung des Inhalts ohne Formatierung führen. jquery.js:3:25903
    MouseEvent.mozPressure sollte nicht mehr verwendet werden. Verwenden Sie PointerEvent.pressure stattdessen. tinymce.min.js:2:8856
    Diese Website verwendet anscheinend einen scroll-verknüpften Positionierungseffekt. Dies könnte mit asynchronem Verschieben (Panning) schlecht zusammenspielen; siehe https://developer.mozilla.org/docs/Mozilla/Performance/ScrollLinkedEffects für weitere Details und nehmen Sie an der Diskussion über damit verbundene Werkzeuge und Funktionen teil! post.php

    Ich habe auch schon mit Health Check & Troubleshooting alle Plugins durchgecheckt und festgestellt, dass das Twitter Plugin diesen REST API von einer empfohlenen Verbesserung in eine kritische Warnung verwandelt.

    Noch ein paar Infos: Mein Hoster ist Ionos (1&1) und ich verwende PHP 7.4. Alle meine Themes und Plugins haben die aktuellste Version und mein WP ist Version 5.5.1. Mein Theme ist Tempera.

    So, das war es erstmal, was mir zu den Problemen einfällt. Für eure Hilfe bin ich sehr dankbar. VG

    • Dieses Thema wurde geändert vor 1 Woche, 5 Tage von jackspeck.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Hier ist noch der Auszug aus dieser „Log“Datei, die das Websiteüberwachungstool liefert (Werkzeuge>Websitezustand)

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/17/d230299829/htdocs/wp
    wordpress_size: 865,53 MB (907577488 bytes)
    uploads_path: /homepages/17/d230299829/htdocs/wp/wp-content/uploads
    uploads_size: 3,79 GB (4071136137 bytes)
    themes_path: /homepages/17/d230299829/htdocs/wp/wp-content/themes
    themes_size: 12,04 MB (12622619 bytes)
    plugins_path: /homepages/17/d230299829/htdocs/wp/wp-content/plugins
    plugins_size: 43,45 MB (45560450 bytes)
    database_size: 136,39 MB (143015936 bytes)
    total_size: 4,82 GB (5179912630 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Tempera (tempera)
    version: 1.7.2
    author: Cryout Creations
    author_website: https://www.cryoutcreations.eu
    parent_theme: none
    theme_features: core-block-patterns, editor-style, title-tag, post-thumbnails, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, automatic-feed-links, post-formats, menus, custom-background, custom-header, widgets
    theme_path: /homepages/17/d230299829/htdocs/wp/wp-content/themes/tempera
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (7) ###
    
    Tempera: author: Anonymous, version: (undefined),Automatische Aktualisierungen deaktiviert
    Twenty Fifteen: version: 2.7, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Fourteen: version: 2.9, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 1.7, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    Twenty Thirteen: version: 3.1, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Twelve: version: 3.2, author: the WordPress team,Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.5, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (18) ###
    
    BackWPup: version: 3.7.1, author: Inpsyde GmbH, Automatische Aktualisierung aktiviert
    Contact Form 7: version: 5.2.2, author: Takayuki Miyoshi, Automatische Aktualisierung aktiviert
    Contact Form DB: version: 2.10.28, author: Michael Simpson, Automatische Aktualisierungen deaktiviert
    Cryout Serious Theme Settings: version: 0.5.11, author: Cryout Creations, Automatische Aktualisierung aktiviert
    Enhanced Media Library: version: 2.7.2, author: wpUXsolutions, Automatische Aktualisierung aktiviert
    Fix Image Rotation: version: 2.2.1, author: Gagan Deep Singh, Automatische Aktualisierung aktiviert
    GDPR Cookie Consent Banner: version: 2.3.15, author: termly, Automatische Aktualisierung aktiviert
    Maintenance Mode: version: 5.4, author: Michael Wöhrer, Automatische Aktualisierungen deaktiviert
    Really Simple CAPTCHA: version: 2.0.2, author: Takayuki Miyoshi, Automatische Aktualisierung aktiviert
    SI Captcha Anti-Spam: version: 3.0.3, author: fastsecure, Automatische Aktualisierungen deaktiviert
    Simple Custom CSS: version: 4.0.4, author: John Regan, Danny Van Kooten, Automatische Aktualisierung aktiviert
    Statify: version: 1.8.0, author: pluginkollektiv, Automatische Aktualisierung aktiviert
    TablePress: version: 1.12, author: Tobias Bäthge, Automatische Aktualisierung aktiviert
    TinyMCE Advanced: version: 5.5.0, author: Andrew Ozz, Automatische Aktualisierung aktiviert
    WordPress Importer: version: 0.7, author: wordpressdotorg, Automatische Aktualisierung aktiviert
    WP Cerber Security, Anti-spam & Malware Scan: version: 8.6.7, author: Cerber Tech Inc., Automatische Aktualisierung aktiviert
    WP Statistics: version: 12.6.13, author: VeronaLabs, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.7.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (3) ###
    
    Akismet Anti-Spam: version: 4.1.6, author: Automattic, Automatische Aktualisierung aktiviert
    Health Check & Troubleshooting: version: 1.4.5, author: The WordPress.org community, Automatische Aktualisierungen deaktiviert
    HL Twitter: version: 2014.1.18, author: Luke Lanchester, Automatische Aktualisierung aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.232-icpu-051 x86_64
    httpd_software: Apache
    php_version: 7.4.10 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.30-log
    client_version: mysqlnd 7.4.10
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/17/d230299829/htdocs/wp/wp-content
    WP_PLUGIN_DIR: /homepages/17/d230299829/htdocs/wp/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    • Diese Antwort wurde geändert vor 1 Woche, 4 Tage von Bego Mario Garde. Grund: Codeformatierung korrigiert
    Moderator Bego Mario Garde

    (@pixolin)

    Bitte ruf als erstes mal das Menü Einstellungen > Permalinks auf. Du brauchst hier nichts weiter tun, WordPress liest durch Aufruf des Menüs die Permalinks erneut ein, was öfters bei der Fehlermeldung „keine gültige JSON-Antwort“ hilft.

    Du hast das Health-Check-Plugin bereits installiert und genutzt. Aktivier das doch bitte nochmal, geh in Werkzeuge > Website-Zustand > Problembehandlungsmodus und schau, ob die Fehlermeldung auch erscheint, wenn der Problembehandlungsmodus alle Plugins (nur für dich sichtbar) deaktiviert und ein Standard-Theme aktiviert. Ziel ist, die Fehlerursache einzugrenzen und ein Kompatibilitätsproblem mit einem Plugin oder deinen Theme kommt durchaus als Ursache in Frage.

    Das von dir als Fehlerursache ausgemachte Twitter-Plugin ist deaktiviert – der Fehler besteht aber weiterhin? Dann wird etwas anderes vermutlich die Ursache sein.

    Danke für die schnelle Antwort.

    Leider hat das Aufrufen des Permalinkmenüs nichts verändert.

    Ich habe jetzt Health-Check-Plugin aktiviert und alle Plugins deaktiviert. Jetzt bekomme ich die Meldung,

    „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“

    Wenn ich versuche den Websitezustand einhusehen.

    Das Twitter-Plugin habe ich seit ich den Fehler habe deaktiviert.

    Moderator Bego Mario Garde

    (@pixolin)

    Die Fehlermeldung „Du bist leider nicht berechtigt, auf diese Seite zuzugreifen.“ kann angezeigt werden, wenn du versuchst, auf ein Plugin-Menü zuzugreifen nachdem das Plugin deaktiviert wurde.

    Args, die Fehlermeldung bleibt bestehen, trotz deaktivierter Plugins.

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn du die Plugins mit dem Plugin Health Check deaktiviert hast und Probleme hast, reicht es, entweder den Problembehandlungsmodus über die Admin-Leiste zu deaktivieren oder dich ab- und erneut anzumelden.

    Hello again,

    ich habe es mit Health Check nochmal probiert und das Ergebnis war das Gleiche. Die Fehlermeldung wird auch angezeigt, wenn alle Plugins deaktiviert sind.

    Heute Morgen konnte ich einen Beitrag bearbeiten und erfolgreich speichern. Jetzt, einige Stunden später. kommt wieder die Fehlermeldung:

    Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

    und ich kann keine Beiträge oder Seiten mehr bearbeiten.

    Hallo,
    hilfreich könnte auch eine neue .htaccess sein:

    • verbinde dich mit deinem Server über FTP
    • suche die .htaccess-Datei in deinem Stammordner
    • lade eine Kopie der Datei auf deinen Computer (als Sicherung)
    • lösche die .htaccess-Datei von deinem Server, nachdem du eine Sicherungskopie auf deinem lokalen Computer hast.

    Um WordPress zu zwingen, eine neue, saubere .htaccess-Datei zu erzeugen:

    • gehe zu den Einstellungen > Permalinks in deinem WordPress Dashboard
    • unten auf der Seite klicken: auf Änderungen speichern (du musst keine Änderungen vornehmen – klicke einfach auf die Schaltfläche).

    Viele Grüße,
    Hans-Gerd

    Hallo Hans-Gerd,

    danke für den Tipp. Leider hat sich nichts geändert.

    Viele Grüße
    Johannes

    Hallo Johannes,
    nur mal sicherheitshalber: Wenn du den Problembehandlungsmodus bei Health Check eingeschaltet hast und als Theme wird twenty twenty aktiviert, dann hast du dieses Problem auch?
    Übrigens ist mir gerade aufgefallen, dass das von dir genutzte Theme „Tempera“ seltsamerweise sowohl als aktives wie auch als inaktives Theme gelistet wird. Die inaktiven Themes bis auf Twenty Twenty solltest du schon aus Sicherheitsgründen löschen.
    Viele Grüße,
    Hans-Gerd

    Hallo Hans-Gerd,

    ich glaube der Tipp war heiß.
    Ich habe zwar immernoch die REST-API Fehlermeldung, aber die „Ein geplantes Ereignis ist verspätet“ Meldung ist weg und ich kann Beiträge aktualisieren.

    D.h. wohl mein Theme ist irgendwie beschädigt bzw. nicht mehr supported?
    Hatt zuvor schon bemerkt, dass das Tempera Theme seit mindestens einem Jahr kein Update mehr bekomen hat. Könnte das der Grund sein?
    Wenn ja, was kann man da machen?

    VG Johannes

    Hallo Johannes,
    das hört sich ja einerseits schon mal gut an.
    Vielleicht ist es auch erst mal sinnvoll, den Entwickler im Supportforum zu kontaktieren und das Problem da zu beschreiben. So wie es aussieht, kümmert sich der Entwickler ja.
    Aber wie ich gerade gesehen habe, hast du das Forum ja schon gefunden 😉
    Viele Grüße,
    Hans-Gerd

    Hallo zusammen,

    ich habe das Problem endlich gefunden:
    Mein Sicherheits-Plugin Cerber Security hat die REST-API geblockt.
    Warum auch immer das plötzlich der Fall war, weiß ich nicht. Allerdings habe ich die REST-API in den Einstellungen jetzt für die Admins freigegeben und der JSON Fehler ist passé.

    Vielen Dank für eure Hilfe.
    Hoffentlich nicht bis ganz so bald 😉

    Soviel zu „teste deine Website, wenn alle Plugins deaktiviert und ein Standard-Theme aktiviert sind“ …

    Schön, dass du eine Lösung gefunden hast.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)