Support » Allgemeine Fragen » Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst djamilakotsch

    (@djamilakotsch)


    Ich habe leider meine Webseite teilweise gecrasht, konnte jedoch die Datenbank, Theme, Plugins etc. alles wieder aus Sicherungen herstellen.
    Jedoch werden die Unter-Seiten nicht mehr angezeigt (die Startseite schon) und ich erhalte beim Versuch zu aktualisieren die Fehlermeldung

    „Aktualisierung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.“

    Ich habe mich gerade schon durch die Postings dazu gelesen, aber bin leider nicht weiter gekommen. Plugins habe ich bereits deistalliert.

    Über WERKZEUGE > WEBSITE ZUSTAND habe ich den untenstehenden Bericht bekommen.
    Vielleicht kann mir jemand weiterhelfen, was ich tun muss, um die Seiten wieder angezeigt zu bekommen. Bin nur Laie und habe mich selbst in WP eingearbeitet und daher für jede Hilfe dankbar 🙂

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress
    wordpress_size: 75,17 MB (78825671 bytes)
    uploads_path: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content/uploads
    uploads_size: 197,50 MB (207089538 bytes)
    themes_path: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content/themes
    themes_size: 8,42 MB (8828488 bytes)
    plugins_path: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content/plugins
    plugins_size: 66,31 MB (69528187 bytes)
    database_size: 41,02 MB (43008000 bytes)
    total_size: 388,41 MB (407279884 bytes)
    
    ### wp-active-theme ###
    
    name: Delight Spa Pro (delight-spa-pro)
    version: 1.0
    author: Luzuk
    author_website: http://www.unboxthemes.com/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, custom-logo, custom-header, infinite-scroll, jetpack-responsive-videos, widgets
    theme_path: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content/themes/delight-spa-pro
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.5, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (7) ###
    
    ARPrice - Premium WordPress Pricing Table Plugin: version: 3.5, author: Repute InfoSystems, Automatische Aktualisierungen deaktiviert
    CleverReach® WP: version: 1.5.5, author: CleverReach GmbH & Co. KG (latest version: 1.5.8), Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.1.9, author: Takayuki Miyoshi (latest version: 5.2.2), Automatische Aktualisierungen deaktiviert
    DSGVO All in one PRO for WP: version: 4.7.4, author: Michael Leithold, Automatische Aktualisierungen deaktiviert
    Font Awesome: version: 4.0.0-rc20, author: Font Awesome, Automatische Aktualisierungen deaktiviert
    Master Slider: version: 3.5.8, author: averta (latest version: 3.6.2), Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 2.16.26.1, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1650
    imagemagick_version: ImageMagick 6.7.2-7 2017-03-22 Q16 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 50M
    upload_max_filesize: 50M
    max_effective_size: 50 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 4 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 30 GB
    	imagick::RESOURCETYPE_MEMORY: 15 GB
    	imagick::RESOURCETYPE_THREAD: not available
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.70
    
    ### wp-server ###
    
    server_architecture: Linux 2.6.32 x86_64
    httpd_software: Apache
    php_version: 7.2.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 20000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 50M
    php_post_max_size: 50M
    curl_version: 7.71.0 OpenSSL/1.0.1e-fips
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.55
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/web41.www56.hostkraft.de/httpdocs/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Bego Mario Garde

    (@pixolin)

    Bitte installiere mal folgendes Plugin:

    Enable jQuery Migrate Helper

    Außerdem prüf bitte mal, welche URLs unter Einstellungen > Allgemein eingetragen sind. Beginnen die beide mit https?

    Hallo,
    Enable jQuery Migrate Helper habe ich installiert.
    Bei den URLS unter Einstellungen > Allgemein ist beide Male https://www.of-dance.com eingetragen.

    Hallo,
    auf der Seite gibt es einige Fehler, siehe developer console (F12).
    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Fehler gibt es auch wegen Mixed Content. Mixed Content bedeutet, dass eine Website, die verschlüsselt über HTTPS aufgerufen wird, Inhalte teilweise unverschlüsselt über HTTP ausliefert.
    Das kannst du sehen, wenn du z. B. über Chrome in die developer console schaust (Shortcut für Developer Console: F12 – siehe oben).
    Du kannst deine Seite mal auf der folgenden Webseite prüfen und siehst dann die Fehler.
    Diese Fehler lassen sich z. B. über das Plugin „Better Search and Replace“ korrigieren.
    Vorher aber bitte auf jeden Fall eine Sicherung der Datenbank erstellen.
    Viele Grüße,
    Hans-Gerd

    Die Plugins habe ich wie bereits schon alle deaktiviert, der Fehler tritt auch dann auf, wenn ich als Theme twenty twenty wähle.
    Ich kann weder die Seiten aktualisieren, noch werden sie online angezeigt, es kommt einfach nur

    „Not Found
    The requested document was not found on this server.“

    Health Check habe ich mir durchgelesen, installiert und die Problembehandlung aktiviert. Leider hat auch das nichts gebracht, die Seiten werden nicht angezeigt und lassen sich nicht aktualisieren.
    Der Website Zustand wird als „gut“ eingestuft.
    Als einziger Fehler wird angezeigt:

    Der Aufruf der REST-API führte zu folgendem unerwarteten Ergebnis: (404)

    Not Found
    The requested document was not found on this server.

    Die REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Ein Beispiel ist der Bildschirm des Block-Editors, der darauf aufbaut, deine Beiträge und Seiten anzuzeigen und zu speichern.

    Beim Test über https://www.whynopadlock.com/ wird bei Mixed content nur ein Hard Failure angezeigt:

    „A script with an insecure url of „http://code.jquery.com/jquery.min.js“ was loaded on line: 69 of https://www.of-dance.com/.
    This URL will need to be updated to use a secure URL for your padlock to return.“

    Bin leider wie gesagt nur Laie und leider oft überfordert.
    Fall jemand eine Möglichkeit/Kontakt kennt für einen Support / Fehlerbehebung gegen Bezahlung wäre ich auch dafür dankbar.

    • Diese Antwort wurde geändert vor 1 Woche, 3 Tage von djamilakotsch.

    Nachtrag:
    Nachdem ich unter EINSTELLUNGEN > PERMALINKS auf „Individuelle Struktur“ umgestellt habe, werden alle Seiten und Beiträge wieder angezeigt.

    Halleluja!

    Einige Inhalte muss ich nach dem Einspielen der älteren Sicherungsdateien nochmal aktualisieren, aber immerhin kann ich wieder darauf zugreifen.

    Und die Website wird aktuell noch als „nicht sicher“ angezeigt, das hatte ich schon mal, als ich die Seite erstellt habe und habe es dann aber über ein Plugin gelöst – da muss ich nochmal nachlesen, wie das war.

    Danke an alle für die Hilfe, ich bin sehr dankbar dafür!

    Dennoch, falls jemand eine Möglichkeit/Kontakt kennt für einen Support / Fehlerbehebung gegen Bezahlung wäre ich auch dafür dankbar. Kann ich in Zukunft bestimmt noch öfter gebrauchen.

    Moderator Bego Mario Garde

    (@pixolin)

    Und die Website wird aktuell noch als „nicht sicher“ angezeigt, das hatte ich schon mal, als ich die Seite erstellt habe und habe es dann aber über ein Plugin gelöst – da muss ich nochmal nachlesen, wie das war.

    Das solltest du nicht per Plugin lösen. Mehr dazu: https://pixolin.de/umstellung-auf-https/

    Dennoch, falls jemand eine Möglichkeit/Kontakt kennt für einen Support / Fehlerbehebung gegen Bezahlung wäre ich auch dafür dankbar.

    Das ist eigentlich die Stelle, an der wir Thread direkt schließen: Jobangebote jeder Art sind hier aus mehreren Gründen absolut unerwünscht. Lies bitte nochmal die Forenregeln. Diesmal lassen wir es bei dem Hinweis.

    Vielen Dank für den Hinweis auf die Forenregeln (sorry für diesen Fauxpas) und den Tipp für die https Umstellung, ich bedanke mich für die schnelle Hilfe und werde mir alles in Ruhe durchlesen.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)