Support » Allgemeine Fragen » Aktualisierung von Plugins

  • Gelöst rapidpat

    (@rapidpat)


    Hallo,

    ich habe (plötzlich) ein kleines Problem mit der Aktualisierung von Plugins.
    Früher konnte ich im Backend einzelne oder alle Plugins per Klick (Häkchen) in die Aktualisierung aufnehmen. Leider funktioniert dieser „Klick“ seit einiger Zeit nicht mehr.
    Das Feld bleibt immer leer, kein Häkchen nix. Aktualisiert werden dann auch nur die Übersetzungen.
    Dieses Problem kann ich natürlich umgehen, in dem ich mir die Veränderungen einzelner Plugins anschaue und von dieser Stelle dann aktualisiere. Ist aber recht mühsam, da ich nur die Plugins nacheinander aktualisieren kann.
    Ich hätte es gerne wieder komfortabler. 🙂
    Vielleicht kennt ja jemand schon dieses Problem und hat eine Lösung dafür?
    Bei meiner Suche hier in der Hilfe habe ich nix passendes gefunden.
    Sollte ich es aber übersehen habe, dann bitte ich schon mal vorab um Entschuldigung.

    Viele Grüße
    Pat

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Dazu bräuchten wir mehr Informationen zu deiner Website:
    Werkzeuge > Website-Zustand (gibt es hier Fehlermeldungen? Welche?) > Bericht > per Button in die Zwischenablage kopieren, dann hier unverändert (mit den Akzentzeichen) in eine Antwort einfügen.

    Bitte gib auch eine URL zu deiner Website an.

    Hallo,
    vielen Dank für die Antwort und die Hilfe.

    Meine Seite:

    Und hier der Bericht:

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web413/a3/37/5370137/htdocs/WordPress_01
    wordpress_size: 117,44 MB (123145169 bytes)
    uploads_path: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content/uploads
    uploads_size: 1,38 GB (1477361929 bytes)
    themes_path: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content/themes
    themes_size: 6,03 MB (6321923 bytes)
    plugins_path: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content/plugins
    plugins_size: 31,45 MB (32980312 bytes)
    database_size: 16,25 MB (17039360 bytes)
    total_size: 1,54 GB (1656848693 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: OnePress (onepress)
    version: 2.2.4
    author: FameThemes
    author_website: https://www.famethemes.com/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, woocommerce, custom-logo, recommend-plugins, customize-selective-refresh-widgets, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, editor-styles, align-wide, editor-style, widgets
    theme_path: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content/themes/onepress
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty: version: 1.2, author: WordPress-Team
    
    ### wp-mu-plugins (2) ###
    
    0-ninjafirewall.php: version: 1.0, author: The Ninja Technologies Network
    WP Migrate DB Compatibility: version: 1.2, author: Delicious Brains
    
    ### wp-plugins-active (19) ###
    
    Autoptimize: version: 2.6.2, author: Frank Goossens (futtta)
    Broken Link Checker: version: 1.11.12, author: WPMU DEV
    Cache Enabler: version: 1.3.5, author: KeyCDN
    Classic Editor: version: 1.5, author: WordPress Contributors
    Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream: version: 13.3.1, author: Embed Plus for YouTube Team
    Envira Gallery Lite: version: 1.7.8.7, author: Envira Gallery Team
    Image Widget: version: 4.4.7, author: Modern Tribe, Inc.
    Media Library Assistant: version: 2.83, author: David Lingren
    NinjaFirewall (WP Edition): version: 4.1.1, author: The Ninja Technologies Network
    ShortPixel Image Optimizer: version: 4.17.4, author: ShortPixel
    Social Media Widget: version: 4.0.6, author: Noah Kagan
    SSL Insecure Content Fixer: version: 2.7.2, author: WebAware
    Statify: version: 1.6.3, author: pluginkollektiv
    Two Factor: version: 0.5.1, author: Plugin Contributors
    Ultimate Category Excluder: version: 1.1, author: Marios Alexandrou
    WP-Sweep: version: 1.1.1, author: Lester 'GaMerZ' Chan
    WP Content Copy Protection & No Right Click: version: 2.3, author: wp-buy
    WP Edit: version: 4.0.4, author: Josh Lobe
    WP Tab Widget: version: 1.2.10, author: MyThemeShop
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.3.16
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 120
    memory_limit: 256M
    max_input_time: -1
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content
    WP_PLUGIN_DIR: /mnt/web413/a3/37/5370137/htdocs/WordPress_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Hallo,
    screenshot wäre vielleicht auch nicht schlecht.
    Viele Grüße
    Hans-Gerd

    Hallo Hans-Gerd,

    momentan habe ich leider keine Plugins die aktualisiert werden müssen.
    Screenshot vom Dashboard wird da leider momentan nicht viel weiterhelfen.
    Oder meintest Du etwas anderes?

    Viele Grüße
    Pat

    Wir möchten dein Problem gerne nachvollziehen, sitzen aber nicht an deinem Schreibtisch und sehen nicht, was du siehst. Die Beschreibung „Leider funktioniert dieser „Klick“ seit einiger Zeit nicht mehr.“ ist recht vage.

    Kein Problem.
    Ich werde den Screenshot einstellen. Aber wie bereits geschrieben, kann ich halt erst machen, wenn es wieder Plugins zum aktualisieren gibt.
    Ansonsten kann ich ja das Problem nicht verdeutlichen…..
    Trotzdem schon mal DANKE für die Hilfe! 🙂

    Viele Grüße
    Pat

    Hallo,
    nach längerer Zeit habe ich mich mal wieder mit diesem Thema beschäftigt.

    Anbei ein Screenshot:

    Hier sieht man Checkboxen, aber ich kann sie nicht klicken, besser gesagt visuell werden mir die gewählten Optionen nicht angezeigt (schwarzes Häkchen)!
    Anscheinend übernimmt WP die Aktivierung, zeigt sie aber nicht an.
    (weißes Häkchen und damit unsichtbar???)
    Keine Ahnung wo das Problem liegt.
    Das zieht sich durch das komplette Backend bei allen Plugins und eben auch auf der Seite zur Aktualisierung der Plugins.
    (die Überschrift des Problems ist deshalb nicht ganz glücklich gewählt)
    Es nervt halt, wenn man nicht sieht, welche Optionen man gewählt hat, z.B. nach Aktualisierung von Plugins…..

    Vielleicht hat jemand ein Idee?
    Vielen Dank im Voraus.

    Viele Grüße
    Pat

    • Diese Antwort wurde geändert vor 2 Wochen, 2 Tage von rapidpat.
    • Diese Antwort wurde geändert vor 2 Wochen, 2 Tage von rapidpat.

    So wie ich das verstehe, sind damit die Kontrollkästchen (Checkboxes) auf der Seite Dashboard -> Aktualisierungen oder aber die in der Plugin-Übersicht (Plugins -> Installierte Plugins) gemeint – andere Möglichkeiten sehe ich nicht.

    Und wenn auf eins der Kontrollkästchen geklickt wird, bleibt dieses „Feld“ leer, die Checkboxes können also nicht aktiviert werden.

    @rapidpat:

    1. Hast du es mal mit einem anderen Browser getestet?
    2. Sind Caches gelöscht worden?
    3. Hast du das Standard-Procedere durch (alle Plugins deaktivieren, auf ein Standardtheme wechseln, dann testen?)
    4. Debug-Meldung, Error-Log? Bitte lies hier und führe die relevanten Punkte zum Testen durch (eventuell hilft auch Punkt 4 daraus weiter).

    Hallo Angelika,
    vielen Dank für die Antwort.

    Das Problem bezieht sich ausschließlich auf das Backend.

    So wie ich das verstehe, sind damit die Kontrollkästchen (Checkboxes) auf der Seite Dashboard -> Aktualisierungen oder aber die in der Plugin-Übersicht (Plugins -> Installierte Plugins) gemeint – andere Möglichkeiten sehe ich nicht.

    Nein, es bezieht sich auch auf alle Checkboxes in den WordPress Einstellungen.
    (z.B. unter „Allgemein => Mitgliedschaft => jeder kann sich registrieren“)
    Also eigentlich überall, wo es die Kontrollkästchen gibt.
    Wobei die Auswahlfelder unter „Allgemein => Lesen => …deine Startseite zeigt“ ganz normal funktionieren (ok, sind in dem Sinn keine Boxen). Die Box weiter unten „Sichtbarkeit für Suchmaschinen“ wieder nicht.

    Merkwürdig ist aber…..klicke ich rein, dann wird dieser Punkt von WP übernommen.
    (ohne Anzeige, dass der Punkt gewählt wurde, normalerweise ein Häkchen in der Box)
    Das ist natürlich sehr verwirrend, man weiß letztendlich nicht mehr welche Checkbox man schon gewählt hat oder nicht.
    Vielleicht hat das „gewählt Häkchen“ auch die gleiche Farbe wie mein Hintergrund im Dashboard? 😉

    Cache wurde immer wieder geleert.
    Anderer Browser gleiches Problem.
    Alle Plugins deaktiviert….keine Auswirkung.
    Error Log zeigt mir keine Fehler an.

    Verrückt.

    Viele Grüße
    Pat

    Punkt 4?

    Hallo,

    Punkt 4 / manuelle WP-Installation habe ich jetzt auch durchgeführt.
    Leider keine Änderung.

    Eine Testumgebung gebaut und das Theme gewechselt.
    Auch hier alle Plugins deaktiviert…
    Auch keinen Erfolg.

    Irgend etwas läuft nicht richtig…aber was kann es sein?

    Viele Grüße
    Pat

    rapidpat

    (@rapidpat)

    Guten Morgen,

    hat vielleicht noch jemand eine verrückte Idee?
    Vorschläge werden sehr gerne angenommen. 🙂

    Viele Grüße
    Pat

    Ich habe den Fehler gefunden.

    In untenstehendem Code (.htaccess) ist er versteckt.
    Wo weiß ich natürlich auch nicht…

    <IfModule mod_headers.c>
    Header always set Strict-Transport-Security „max-age=15768000; includeSubDomains; preload“ env=HTTPS
    Header set X-XSS-Protection „1; mode=block“
    Header set X-Content-Type-Options nosniff
    Header set Referrer-Policy: no-referrer-when-downgrade
    Header always append X-Frame-Options SAMEORIGIN
    Header set Content-Security-Policy: „img-src *“
    Header set Feature-Policy: „vibrate ’self‘;“
    </IfModule>

    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    </IfModule>
    <IfModule mod_headers.c>
    Header append Cache-Control „public“
    Header append Vary Accept-Encoding
    Header set Connection keep-alive
    Header unset ETag
    FileETag None
    </IfModule>

    <IfModule mod_expires.c>
    ExpiresActive On
    ExpiresDefault „access 60 seconds“
    ExpiresByType image/jpg „access plus 1 month“
    ExpiresByType image/jpeg „access plus 1 month“
    ExpiresByType image/gif „access plus 1 month“
    ExpiresByType image/png „access plus 1 month“
    ExpiresByType image/ico „access plus 1 month“
    ExpiresByType text/css „access 1 month“
    ExpiresByType text/javascript „access 1 month“
    ExpiresByType application/javascript „access 1 month“
    ExpiresByType application/x-shockwave-flash „access 1 month“
    </IfModule>

    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{REQUEST_FILENAME} \.(jpg|jpeg|png|gif|ico|css|js)$ [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?rapid-dragons\. [NC]
    RewriteCond %{HTTP_REFERER} !^https?://([^.]+\.)?feedly\. [NC]
    RewriteRule \.(jpg|jpeg|png|gif|ico|css|js)$ – [F,NC,L]
    </ifModule>

    Nehme ich diesen Code aus der htaccess raus, funktionieren die Checkboxen wieder.
    Danke an alle, die versucht haben mir zu helfen. 🙂

    Viele Grüße
    Pat

    • Diese Antwort wurde geändert vor 1 Woche, 5 Tage von rapidpat.
Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)