Support » Allgemeine Fragen » Aktualisierungen brechen einfach ohne Fehlermeldung ab

  • Gelöst trm2000

    (@trm2000)


    Hallo,

    seit drei Tagen können keine Updates mehr eingelesen werden. Außerdem ist es nicht möglich per Schalter, WordPress erneut zu installieren (Dashboard -> Aktualisierungen „Version 6.1.1–de_DE erneut installieren“). Auch hier wird keine Fehlermeldung ausgegeben – es passiert einfach nichts.

    Wordpress: 6.1.1
    Folgende Plugins sind installiert:

    1. Contact Form 7
    2. Disable & Remove Google Fonts
    3. FooBox Image Lightbox
    4. Friendly Captcha for WordPress
    5. MetaSlider

    Ich habe ein backup der WordPress-Installation heruntergeladen und lokal untersucht. Gleiches mit der aktuellen Datenbank.

    Es gibt keine gesetzten Einstellungen, welche die Updates verhindern. Ich habe weder in der Datenbank, noch in einer Datei folgende Einträge (oder Teilstücke davon) gefunden:

    add_filter( 'auto_update_plugin', '__return_false' );
    add_filter( 'auto_update_theme', '__return_false' );
    define( 'WP_AUTO_UPDATE_CORE', false ); (oder _dev/_minor/_major)
    define( 'automatic_updater_disabled', false );

    Vielleicht gibt es noch mehr Schalter, die ich nicht kenne. Ich bin mit meinen Ideen am Ende, woran es liegen könnte.

    Gesucht habe ich unter Linux mittels grep.

    Hat jemand bitte eine Idee, wo ich noch fündig werden könnte?

    LG und ein frohes neues Jahr!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Hallo,
    hast du dir mal die error.log beim Hoster angsehen?
    Wie sieht es mit dem Webspace aus? – Vielleicht ist der Webspace ausgereizt.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Viele Grüße
    Hans-Gerd

    Thread-Starter trm2000

    (@trm2000)

    Danke für Deine Antwort.

    Als einzige Fehlermeldung taucht im log auf:

    [02-Jan-2023 21:28:46 UTC] PHP Notice: Undefined index: frc-captcha-solution in /homepages/*****/htdocs/wordpress/wp-content/plugins/friendly-captcha/includes/helpers.php on line 19

    Hier noch der Bericht:

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/23/d32916708/htdocs/wordpress
    wordpress_size: 53,41 MB (56001759 bytes)
    uploads_path: /homepages/23/d32916708/htdocs/wordpress/wp-content/uploads
    uploads_size: 131,35 MB (137735476 bytes)
    themes_path: /homepages/23/d32916708/htdocs/wordpress/wp-content/themes
    themes_size: 9,49 MB (9952146 bytes)
    plugins_path: /homepages/23/d32916708/htdocs/wordpress/wp-content/plugins
    plugins_size: 26,91 MB (28216816 bytes)
    database_size: 9,31 MB (9764864 bytes)
    total_size: 230,48 MB (241671061 bytes)
    
    ### wp-active-theme ###
    
    name: BlueGray (bluegray)
    version: 7.3
    author: Guido
    author_website: https://www.guido.site
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, menus, title-tag, editor-styles, editor-style, custom-header, post-thumbnails, automatic-feed-links, html5, custom-background, post-formats, widgets
    theme_path: /homepages/23/d32916708/htdocs/wordpress/wp-content/themes/bluegray
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-Three: version: 1.0, author: WordPress-Team
    
    ### wp-plugins-active (8) ###
    
    Booking Calendar WpDevArt: version: 3.2.3, author: WpDevArt
    Contact Form 7: version: 5.7.2, author: Takayuki Miyoshi
    Disable & Remove Google Fonts: version: 1.5.2, author: Fonts Plugin
    FooBox Image Lightbox: version: 2.7.17, author: FooPlugins
    Friendly Captcha for WordPress: version: 1.8.0, author: Friendly Captcha GmbH
    MetaSlider: version: 3.28.2, author: MetaSlider
    To Top: version: 2.5.2, author: Catch Plugins
    Yoast Duplicate Post: version: 4.5, author: Enrico Battocchi & Team Yoast
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/23/d32916708/htdocs/wordpress/wp-content
    WP_PLUGIN_DIR: /homepages/23/d32916708/htdocs/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    LG Mathias 🙂

    Hallo,
    deaktiviere doch mal bitte alle Plugins und teste danach noch mal, ob du WordPress erneut über Dashboard > Aktualisierungen updaten kannst.

    Wenn das der Fall ist, hängt das Problem vermutlich mit einem Plugin zusammen. Dann aktivierst du Plugin für Plugin und testest anschließend jedes Mal, ob eine Aktualisierung möglich ist.

    Viele Grüße
    Hans-Gerd

    Ist WP_MAX_MEMORY_LIMIT: -1 so in der wp-config.php definiert?
    Falls ja, nimm das bitte mal raus.

    Das time_limit ist mit 50000 absurd hoch, eine maximale Laufzeit von 300 Sekunden sollte völlig ausreichen.

    Das ein Plugin für die abbrechenden Updates zuständig sein soll, halte ich für eher unwahrscheinlich. Was sagt denn der Error-Log des Servers?

    @pixolin

    Was sagt denn der Error-Log des Servers?

    Das hatte @trm2000 auf meine Frage bereits beantwortet. 😉

    Hm, war wohl noch zu früh für mich. Sorry.

    Thread-Starter trm2000

    (@trm2000)

    Hallo und danke für die Ideen.

    Ist WP_MAX_MEMORY_LIMIT: -1 so in der wp-config.php definiert?

    Nein, nichts dergleichen in der Datei drin. Nur „normale“ Einträge, ich werde die euch morgen noch hinterher reichen, bin gerade zu müde.

    LG.

    Thread-Starter trm2000

    (@trm2000)

    Hallo, hier ist die wp-config.php. Alle * sind natürlich mit Werten hinterlegt, habe ich nur heraus genommen.

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '*');
    
    /** MySQL database username */
    define('DB_USER', '*');
    
    /** MySQL database password */
    define('DB_PASSWORD', '*');
    
    /** MySQL hostname */
    define('DB_HOST', '*');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8mb4');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '*');
    define('SECURE_AUTH_KEY',  '*');
    define('LOGGED_IN_KEY',    '*');
    define('NONCE_KEY',        '*');
    define('AUTH_SALT',        '*');
    define('SECURE_AUTH_SALT', '*');
    define('LOGGED_IN_SALT',   '*');
    define('NONCE_SALT',       '*');
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    

    Anmerkung: die Domain wird von ionos gehostet.

    LG Mathias

    Hallo,
    die wp-config.php sieht „normal“ aus.
    Gibt es irgendwelche Fehler in der developer console (Aufruf mit F12 bei Chrome), wenn du im Dashboard bist?
    Viele Grüße
    Hans-Gerd

    Nachtrag:
    Schau mal bitte in den folgenden Beitrag. Da gibt es einige Lösungsmöglichkeiten für die genannten Probleme.

    Thread-Starter trm2000

    (@trm2000)

    Huhu. Das ging aber schnell.

    Es taucht kein direkter Fehler, nur dieser Hinweis auf:

    Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform
    A page or script is accessing at least one of navigator.userAgent, navigator.appVersion, and navigator.platform. Starting in Chrome 101, the amount of information available in the User Agent string will be reduced.
    To fix this issue, replace the usage of navigator.userAgent, navigator.appVersion, and navigator.platform with feature detection, progressive enhancement, or migrate to navigator.userAgentData.
    Note that for performance reasons, only the first access to one of the properties is shown.
    1 Quelle
    load-scripts.php:1
    Weitere Informationen: Verringerung der User-Agent-Strings

    LG Mathias

    … die Domain wird von ionos gehostet

    Handelt es sich um ein Managed WordPress-Hosting?

    Thread-Starter trm2000

    (@trm2000)

    Handelt es sich um ein Managed WordPress-Hosting?

    Nein, selbst gehostet.

    Ich habe gerade einmal als Test eine komplett neue WordPressinstallation vorgenommen.

    Dort sind die Aktualisierungen machbar, auch die Anzeige der automtischen Einstellung ist hier sichtbar.

    Hier einmal zwei Bilder als Vergleich. (Werden nach 6 Monaten ab jetzt automatisch gelöscht)

    Screenshot-2023-01-04-121207 Screenshot-2023-01-04-121304

    Das macht mich eben auch sehr stutzig.

    LG Mathias

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Screenshots korrigiert
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Screenshots nochmal korrigiert
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Dritter Versuch für die Screenshots
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: LoL
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Ich wed hier noch bekloppt, weil die Links nicht richtig einfügbar sind
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Datei-Uploader gewechselt
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Danke für die Anleitung :-)
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: So, jetzt reicht es mir aber
    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von trm2000. Grund: Anmerkung hinzugefügt
    Thread-Starter trm2000

    (@trm2000)

    Nach meinem Test und auch der Abschaltung der gesamten Plugins auf der fehlerhaften Seite, hat sich nichts an der Situation geändert.

    Auf der Testseite habe ich die identischen Plugins installiert, der Fehler tritt nicht auf.

    Es ist auch erst passiert, nachdem WordPress automatisch auf 6.1.1 aktualisiert wurde, wie ich meine. Und auch nur hier, auf keiner anderen Installation (ich habe 7 im Moment, die ich betreue oder mir gehören).

    LG Mathias

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 24)
  • Das Thema „Aktualisierungen brechen einfach ohne Fehlermeldung ab“ ist für neue Antworten geschlossen.