Support » Allgemeine Fragen » Alle gespeicherten Tags verschwunden

  • Gelöst QUEERmdb

    (@queermdb)


    Ich bin grad sehr verzweifelt. Ich habe in einem Beitrag superviele Tags angelegt, die plötzlich verschwunden waren. Das ist mir nicht das erste Mal passiert und passiert mir ausschließlich, wenn ich den WordPress-Editor verwende.

    Der Kasten mit den Schlagwörtern war plötzlich leer. Ich habe gedacht, sie werden wohl einfach nicht angezeigt und habe ein neues hinzugefügt. Es ist jetzt das einzige Schlagwort zum Beitrag. Wo sind die alle hin???? Wie kann sowas passieren????

    Die Revisionen speichern offensichtlich nur den Inhalt, nicht den Tag. Darüber konnte ich leider nicht wiederherstellen.

    Wie kann ich die Tags des Beitrags wiederherstellen?

    Ich sehe bei Beiträgen > Schlagworte, dass die neuen Schlagworte gespeichert wurden, aber ich kann sie nicht nach Datum ordnen, sonst könnte ich sie einzeln reinkopieren. Aber das würde dann ja auch nur für die neuen Tags gelten.

    Kann mir bitte jemand helfen? Ich will nicht wieder von vorn anfangen. :((((

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Hast du im Backend unter Beiträge > Schlagwörter geschaut?

    Neue Schlagwörter werden erst gespeichert, wenn du einen Beitrag mit diesen Schlagwörtern veröffentlichst oder sie im Menü Beiträge > Schlagwörter anlegst.

    Wenn du einen neuen Beitrag erstellst, werden dir keine Schlagwörter vorgegeben. Erst wenn du ein paar Buchstaben tippst und es ein Schlagwort gibt, das genauso anfängt, wird dir dieses Schlagwort vorgeschlagen:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Das Problem liegt beim Gutenberg Editor, der offensichtlich die komplette Tag-Box ab einer bestimmten Anzahl von Tags löscht. Mit dem Classic-Editor passiert das nicht.

    Neue Schlagwörter werden erst gespeichert, wenn du einen Beitrag mit diesen Schlagwörtern veröffentlichst oder sie im Menü Beiträge > Schlagwörter anlegst.

    Das stimmt nicht. Alle neuen Tags wurden als Schlagwort schon vor der Veröffentlichung gespeichert, sie sind nur leider nun alle mit keinem Beitrag verlinkt. Diese Tags habe ich nun einzeln mit dem Classic-Editor eingefügt.

    Aber wie bekomme ich die Tags heraus, die schon vorher existierten, und die Gutenberg alle gelöscht hat?

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Gibt es ein Plugin, das die zuletzt verwendeten Tags auflisten kann?

    Das stimmt nicht. Alle neuen Tags wurden als Schlagwort schon vor der Veröffentlichung gespeichert, sie sind nur leider nun alle mit keinem Beitrag verlinkt.

    Stimmt, das hatte ich falsch in Erinnerung.

    Das Problem liegt beim Gutenberg Editor, der offensichtlich die komplette Tag-Box ab einer bestimmten Anzahl von Tags löscht.

    Das konnte ich mit einem Beitrag mit über 30 Tags nicht reproduzieren.

    Gibt es ein Plugin, das die zuletzt verwendeten Tags auflisten kann?

    Du meinst sowas wie eine Tag Revision? Eine andere Lösung als die Wiederherstellung eines Backups (die in diesem Fall wohl nicht in Frage kommt) ist mir nicht bekannt.

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Die Tag-Grenze scheint bei Gutenberg 100 zu sein. Ich habe jetzt den Classic Editor installiert, da gibt es das Problem nicht.

    Falls jemand eine Idee hat, wie ich die durch den Gutenberg-Editor gelöschten Tags, die bereits vor dem Beitrag existierten, identifizieren kann, wäre ich sehr dankbar, sie zu hören.

    Hallo,
    wenn das tatsächlich so ist, wäre es sicher hilfreich, wenn du ein entsprechendes Ticket erstellst.
    Ich habe mal kurz bei Tickets den Suchbegriff „tag“ eingegeben (siehe auch meine Verlinkung), konnte aber kein Ticket zu diesem Problem entdecken.
    Viele Grüße
    Hans-Gerd

    Das könnte der Bug sein, der hier geschildert wird:

    https://github.com/WordPress/gutenberg/issues/13282

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Nein, das ist etwas anderes. Es sind ja nicht einzelne Tags verschwunden, sondern alle. Und es ist auch kein einziges danach wieder aufgetaucht.

    Weil mein Thread zwischenzeitlich gelöscht wurde, habe ich das Problem auf einem anderen Forum gepostet. Da wird auch gesagt, es läge am Gutenberg-Editor und das Problem müsste bekannt sein. Ich hab jetzt den Classic-Editor und da funktioniert alles. Ich krieg halt nur die gelöschten Gutenberg-Tags nicht wieder ran.

    Kann man denn in der Datenbank herauskriegen, welche Tags zuletzt verwendet wurden?

    Weil mein Thread zwischenzeitlich gelöscht wurde …

    Der wurde nicht gelöscht – siehe https://de.wordpress.org/support/topic/warum-wurde-mein-thread-geloescht/.

    Thread-Ersteller QUEERmdb

    (@queermdb)

    Ich hab ein Ticket erstellt, der Bug konnte repliziert werden, es folgt ein Patch: https://core.trac.wordpress.org/ticket/52488

    Bringt mir leider meine Tags nicht zurück, aber immerhin.

    Thread als „gelöst“ markiert.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)