Support » Allgemeine Fragen » ALT-Tags bei Bildern

  • Hallo liebe Community,

    folgendes Problem:

    Ich versehe alle Bilder mit Alt-Tags.
    Jedoch werden im Quellcode nicht alle Alt-tags von den Bildern angezeigt.
    Auch verschiedene Crawler sagen es wären nur manche Alt-tags vorhanden, obwohl ich diese in WordPress bei allen Bildern hinzugefügt habe.

    Vielen Dank schon mal für die Lösungsvorschläge!

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator espiat

    (@espiat)

    Hallo,

    schaue hierzu in den Quellcode deines themes, ob es überhaupt die ALT-Tags ausgibt.

    Wenn es aber nur „manche“ sind, dann müsstest du einmal ausfindig machen, wo der Unterscheid ist bei denen, wo es angezeogt wird und bei denen, wo es nicht geht.

    Zuerst ist mir das Dateiformat in den Sinn gekommen an diesem liegt es aber nicht da der alt-tag für .png so wie für .jpeg teilweise angezeigt wird.

    Einen Unterschied habe ich jedoch gefunden:

    Bilder bei denen das alt tag nicht übernommen wird:
    class=“aligncenter wp-image-217 size-full“

    Bilder bei denen das alt tag übernommen wird:
    class=“ls-slide“ data-ls=“

    Also liegt es an irgendwelche Klassen? Gibt es da eine Erklärung dafür?

    Moderator espiat

    (@espiat)

    Sieht so aus als würde dieses Bild ein einfaches Bild im WP Editor sein:
    class=“aligncenter wp-image-217 size-full“

    Und dieses Bild kommt aus einem Slider-Plugin?
    class=“ls-slide“ data-ls=“

    Ein Link zur Website wäre sinnvoll.

    @espiat

    korrekt, einmal normales Bild und die anderen sind in einem SLider

    Eine Idee wie man das beheben kann ode an was es liegt?

    @la-geek
    kann ich leider nicht öffentlich posten, da mein Kunde sehr vertraulich ist.

    kaum zu glauben 🙂 In der Mediathek findest du alle Bilder. Auch die Bilder des Sliders. Dort kannst du jedes Bild anklicken und unter „Alternativer Tex“, den alt-tag Begriff eingeben.
    Die zweite Möglichkeit wäre die, du hast Bilder via Bulk z.B. von extern importiert. Dann legt WordPress bzw. WooCommerce, gemäß seiner Bild-Einstellungen, verschiedene Varianten des Bildes an. Und danach sieht es auch aus. Diese sind nicht in der Mediathek, sondern im Verzeichnis Uploads zu finden. Ich glaube ich täusche mich da nicht, wenn doch, dann nur ein bißchen 🙂

    Moderator espiat

    (@espiat)

    Dann müsste es am theme liegen.

    Alt Tags werden NICHT aus der Mediathek übernommen, wenn du das Bild nicht direkt im Beitrag hochgeladen hast.

    Checke mal in einem Post, ob dort in der „text“ Ansicht auch ALt-Tags vergeben sind.

    Nein, Alt-Tags kannst du in der Mediathek ganz leicht jedem Bild zuweisen. Von automatisch vergeben war nicht die Rede. 🙂 Und wenn im Post ein Bild ist, dann kannst du es dort anklicken und dann siehst du einen Stift. Dann öffnet sich das Eigenschaftenfenster des Bildes und auch dort kanns du Alt-Tags vergeben.

    Moderator espiat

    (@espiat)

    Von automatisch vergeben war nicht die Rede.

    Das meine ich auch nicht.

    Ich habe die Vermutung, dass das Theme die Alt-tags im Frontend nicht mit ausgibt.

    kann ich leider nicht öffentlich posten, da mein Kunde sehr vertraulich ist.

    Die Seite von deinem Kunden ist doch im Internet erreichbar, also verräts du ja keine vertraulichen Dinge. Ansonsten suche dir professionelle Hilfe, dann musst du nur einem die URL verraten. Sollte ja kein Problem sein, kannst du deinem Kundenin Rechnung stellen. 😀

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „ALT-Tags bei Bildern“ ist für neue Antworten geschlossen.