Support » Allgemeine Fragen » „“ – Anführungszeichen

  • Guten Abend zusammen!

    Ich habe eine Frage die vermutlich schon öfters beantwortet wurde, aber ich habe noch nicht den passenden Tipp gefunden.

    Wenn ich auf der Tastatur ein Anführungszeichen eintippe, gibt WordPress ausschließlich die hochgestellten ("") wieder. Ich möchte aber die deutschen „“ – Anführungszeichen, also erst tief. und dann hochgestellt.

    Muss man dafür, zusätzlich zur Sprache der WP-Installation, noch etwas einstellen? Oder liegt das Problem gar nicht an WP, sondern meinem Browser?

    Herzliche Grüße,
    Valentin

    • Dieses Thema wurde geändert vor 3 Monaten, 1 Woche von Bego Mario Garde. Grund: Anführungszeichen als Code formatiert
Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • WordPress kann das nicht, man kann sich aber entweder mit einer Funktion in functions.php helfen oder man gibt diese Zeichen selbst über die Tastatur ein.

    Windows:
    Alt+0132 „
    Alt+0147 “

    Auf einem Mac weiß ich das nicht, müsste aber per google zu finden sein.

    Erweiterung der functions.php (macht aber nur bei einem Child-Theme Sinn)
    Siehe z.B. https://www.flomei.de/blog/2012/04/29/deutsche-anfuhrungszeichen-in-wordpress-ohne-plugin-2/

    Wenn ich auf der Tastatur ein Anführungszeichen eintippe, gibt WordPress ausschließlich die hochgestellten („“) wieder.

    Das stimmt nur für die Eingabe im Backend. Im Frontend rendert WordPress die Anführungszeichen (so, wie in diesem Satz) als so genannte „typografische Anführungszeichen“. Dabei nutzt WordPress die Funktion wptexturize(), die auch weitere typograohische Ersetzungen vornimmt (z.B. Umwandlung von -- in einen Gedankenstrich — ()).

    Im Beitrag 4 Ways to Disable Smart or Curly Quotes in WordPress wird beschrieben, wie du die Funktion deaktivieren kannst.

    Es kann sogar sein, dass das Theme deiner Website diese Funktion absichtlich verwendet.

    Thread-Starter Valentin

    (@vlntn)

    Lieber Bego, stimmt, im Frontend passt es – das hätte ich natürlich auch früher merken können. Vielen Dank.

    Keine Ursache. Danke für deine Rückmeldung.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)