Support » Allgemeine Fragen » Anzeige nur im Adminbereich

  • quescoprojekt

    (@quescoprojekt)


    Ich habe heute meine Webseite aktualisiert und veröffentlicht, speziell den Header auf der Homepage, aber die Änderungen wurden nur im Admin-Bereich angezeigt und können von anderen, öffentlichen Nutzern, nicht gesehen werden.

    Ich habe bereits einige Foren durchforstet in welchen ich herausgefunden habe, dass es womöglich durch das Entleeren des Cache behoben werden könnte – hier bin ich mir aber erstens nicht mal sicher, ob ich es überhaupt richtig gemacht habe (habe mir ein Cache Plugin installiert und dort auf leeren gedrückt), und zweitens ist mein Problem dadurch leider immer noch nicht gelöst. Gibt es hier andere Ansatzpunkte zur Lösung?

    Vielen lieben Dank im Voraus, Zustandsbericht (falls benötigt) hänge ich hier an.

    
    ### wp-core ###
    
    version: 5.8.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /srv/www/w_qic/questions-in-coaching.aau.at/html
    wordpress_size: 46,46 MB (48715194 bytes)
    uploads_path: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/uploads
    uploads_size: 315,90 MB (331240045 bytes)
    themes_path: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/themes
    themes_size: 6,26 MB (6560900 bytes)
    plugins_path: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/plugins
    plugins_size: 56,89 MB (59653563 bytes)
    database_size: 48,61 MB (50970624 bytes)
    total_size: 474,11 MB (497140326 bytes)
    
    ### wp-active-theme ###
    
    name: Blocksy Child (blocksy-child)
    version: undefined
    author: Creative Themes
    author_website: (undefined)
    parent_theme: Blocksy (blocksy)
    theme_features: core-block-patterns, widgets-block-editor, automatic-feed-links, responsive-embeds, html5, title-tag, custom-logo, lifterlms-sidebars, boostify-header-footer, fl-theme-builder-headers, fl-theme-builder-footers, fl-theme-builder-parts, editor-gradient-presets, editor-color-palette, post-thumbnails, menus, align-wide, customize-selective-refresh-widgets, header-footer-elementor, widgets
    theme_path: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/themes/blocksy-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Blocksy (blocksy)
    version: 1.8.6.8
    author: CreativeThemes
    author_website: https://creativethemes.com
    theme_path: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/themes/blocksy
    auto_update: Deaktiviert
    
    ### wp-plugins-active (11) ###
    
    Blocksy Companion: version: 1.8.9.8, author: CreativeThemes, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.5, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Page Builder by SiteOrigin: version: 2.15.0, author: SiteOrigin, Automatische Aktualisierungen deaktiviert
    PublishPress Blocks: version: 2.11.1, author: PublishPress, Automatische Aktualisierungen deaktiviert
    Qubely - Advanced Gutenberg Blocks: version: 1.7.5, author: Themeum.com, Automatische Aktualisierungen deaktiviert
    Sassy Social Share: version: 3.3.33, author: Team Heateor, Automatische Aktualisierungen deaktiviert
    SiteOrigin Widgets Bundle: version: 1.26.0, author: SiteOrigin, Automatische Aktualisierungen deaktiviert
    Smart Post Show: version: 2.4.2, author: ShapedPlugin, Automatische Aktualisierungen deaktiviert
    Timeline Express: version: 1.8.1, author: Code Parrots, Automatische Aktualisierungen deaktiviert
    WPML Media: version: 2.6.5, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML Multilingual CMS: version: 4.4.12, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-162-generic x86_64
    httpd_software: Apache/2.4.29 (Ubuntu)
    php_version: 7.2.24-0ubuntu0.18.04.10 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.1.48-MariaDB-0ubuntu0.18.04.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content
    WP_PLUGIN_DIR: /srv/www/w_qic/questions-in-coaching.aau.at/html/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator Bego Mario Garde

    (@pixolin)

    Deine Frage ist schwer zu beantworten, da ich weder weiß, wie die Website nach der Änderung aussehen soll, noch was du eigentlich geändert hast.

    Ein Cache ist eine Zwischengespeicherte Variante und in WordPress ist der Einsatz eines Cache-Plugins sinnvoll, wenn ein Theme sehr viele Einstellungsoptionen anbietet und vielleicht noch einige Plugins verwendet werden und so für jeden Webseitenaufruf die Daten alle immer wieder neu aus der Datenbank abgerufen und aufbereitet werden müssen. Nachteil eines Cache-Plugins ist, dass unter Umständen nach einer Änderung weiterhin die zwischengespeicherte (und nicht die aktualisierte) Fassung ausgeliefert wird. Hier (und nur hier) empfehlen wir, den Cache des Cache-Plugins zu leeren. Erst ein Cache-Plugin zu installieren, um dann etwas zu Löschen zu haben ist wenig hilfreich.

    Zusätzlich zur Zwischenspeicherung der Website durch ein Cache-Plugin werden Webseiten je nach Einstellungen auch im Cache des Browsers zwischengespeichert, was sich vor allem nach Updates mit einer ungewöhnlichen Anzeige der Webseiten bzw. des Backend bemerkbar macht. Deshalb ist es sinnvoll, nach Änderungen an der Webseite auch den Browser-Cache zu leeren oder die Webseite mit einem „privaten Browserfenster“ (in Chrome heißt das Inkognito-Fenster) anzuschauen.

    In deinem Fall nehme ich aber eher an, dass du zwar eine Anpassung am Header vorgenommen hast, dieser Header aber nicht der Webseite zugewiesen ist, etwa weil du ein anderes Seiten-Template verwendest. Wie gesagt nur eine Vermutung, weil die Änderung schwer nachvollziehbar ist.

    Thread-Ersteller quescoprojekt

    (@quescoprojekt)

    Vielen lieben Dank für die so schnelle Antwort. Gut, dann hat mir die Installation eines Cache Plugins im Nachhinein schon mal wenig geholfen, das habe ich allerdings auch schon befürchtet, dass das nachträglich so gar nichts bringt.
    Das Problem ist: Ich habe gestern noch einige Plugins aktualisiert und seitdem sieht die Webseite minimal anders aus (z. B. gibt es bei den Infoboxen keinen Abstand mehr dazwischen, auch bei unserer Teamseite gibt es zwischen den Fotos keinen Abstand usw.). Ich denke mit „header“ habe ich zusätzlich auch noch das falsche Wort verwendet, konkret geht es nämlich (unter anderem aber vor allem) um das Titelbild auf der Homepage, das ich verändert habe. Es war vor den Updates viel dunkler um die Schrift etwas mehr hervorzuheben, nach den Updates wollte ich es vom Originalzustand (die Originalaufnahme ist genauso, wie es jetzt auf der Homepage abgebildet ist – ursprünglich haben wir es dann aber eben verdunkelt) wieder etwas schattieren bzw. dunkler machen – das zeigt es mir eben nicht an. Ich hoffe das habe ich jetzt nicht allzu kompliziert erklärt und man versteht was ich meine.
    Den Cache des Browsers (benutze Chrome) habe ich ebenfalls bereits geleert und es hat leider nichts geholfen, auch im Inkognito-Modus wird die Webseite „unaktualisiert“ angezeigt.
    Bin mit meinem Latein etwas am Ende muss ich zugeben, bin aber auch alles andere als ein Experte wenn es um Webdesign oder Technik geht.

    Moderator Bego Mario Garde

    (@pixolin)

    … konkret geht es nämlich (unter anderem aber vor allem) um das Titelbild auf der Homepage, das ich verändert habe. Es war vor den Updates viel dunkler …

    Setz doch mal ein ganz anderes Bild ein und schau, ob das übernommen wird. Falls ja, kannst du danach das hellere Bild einfügen, das du ursprünglich haben wolltest.

    Thread-Ersteller quescoprojekt

    (@quescoprojekt)

    Nein, ein anderes Bild wird auch überhaupt nicht übernommen – es wird weiterhin das vorherige Bild angezeigt.

    Moderator Bego Mario Garde

    (@pixolin)

    Das hört sich danach an, dass du etwas „an der falschen Stelle“ änderst – die Änderung wird dann wahrscheinlich übernommen, tritt aber nicht an der Stelle in Erscheinung, an der du das erhoffst.

    Thread-Ersteller quescoprojekt

    (@quescoprojekt)

    Oh, tut mir leid – die Änderung des Bildes habe ich tatsächlich auf der falschen Seite kontrolliert (habe es auf der englischen Übersetzung kontrolliert obwohl ich das neue Bild auf der deutschsprachigen Seite eingefügt habe)! Das Bild ersetzen funktioniert also einwandfrei, Veränderungen am Bild unter den Einstellungen des Blocks (Bild ist als Hintergrund eines Blocks eingestellt) werden aber leider nicht übernommen…

    Moderator Bego Mario Garde

    (@pixolin)

    Veränderungen am Bild unter den Einstellungen des Blocks (Bild ist als Hintergrund eines Blocks eingestellt) werden aber leider nicht übernommen…

    Welche Einstellungen sollen das denn sein?

    Der Block Qubely Row erlaubt zwar, ein Bild als Hintergrund einzufügen (und das wird ja auch dargestellt), aber ich sehe da (abgesehen von der Positionierung) keine Einstellungsmöglichkeiten für das Hintergrundbild.

    Thread-Ersteller quescoprojekt

    (@quescoprojekt)

    Es geht dabei um eine simple overlay-Farbe, die ich auch schon bevor das Problem aufgetreten ist hatte. Um mal grafisch darzustellen, was ich meine, hab ich mal eine eigene Seite erstellt mit einem Bild das beide Versionen vergleicht. Das obere Bild zeigt, wie die Seite auch für alle angezeigt wird, das untere zeigt wie es eigentlich aussehen sollte bzw. wie es bei mir mit dem Admin-Zugang aussieht. Hoffe dadurch kann ich das Problem etwas besser darstellen. Wie man an den Bildern sieht, sind ja auch die Buttons total anders dargestellt und ich verstehe ehrlich gesagt so überhaupt nicht warum…

    https://questions-in-coaching.aau.at/en/demo/

    Moderator Bego Mario Garde

    (@pixolin)

    Es geht dabei um eine simple overlay-Farbe, die ich auch schon bevor das Problem aufgetreten ist hatte.

    Das scheint doch nur eine Frage der richtigen Einstellung in der Sidebar zu sein?

    • Unter Dimension die Höhe und vertikale Ausrichtung des Inhalts festlegen.
    • Unter Background > Background-Image Bild hinzufügen und bei Parallax angeben, ob das Bild im Hintergrund beim Scrollen fixiert werden soll.
    • Unter Enable Overlay den Schieber auf On stellen, Hintergunrdfarbe und Transparenz festlegen:

      Screenshot Einstellungen
      (zum Vergrößern anklicken)

    Für den Block Button-Group gibt es ebenfalls eine Einstellungsmöglichkeit, mit der der Abstand zwischen den Buttons angelegt werden kann.

    Wenn dieses Einstellungen nicht greifen sollten, kann es daran liegen, dass ein Stylesheet eines Plugins die Einstellungen überschreibt.

    Der Theme-Entwickler hat aber auch eine Beschreibung für Fälle, in denen anscheinend Änderungen nicht berücksichtigt werden. Vielleicht hilft das weiter:

    No CSS applied to the page

    Hier scheint das Hinzufügen von define('FS_METHOD', 'direct'); in der wp-config.php eine wichtige Information zu sein. (Bitte einen geeigneten Code-Editor (oder dem Online-Editor https://vscode.dev/) verwenden und den Eintrag oberhalb von oberhalb von /* That's all, stop editing! Happy blogging. */ einfügen!)

    Thread-Ersteller quescoprojekt

    (@quescoprojekt)

    Das umzusetzen hat jetzt leider einige Tage gedauert, das hat das Problem aber leider ebenfalls nicht gelöst. Gäbe es sonst noch irgendwelche Anhaltspunkte bzw. Gründe woran es liegen könnte?

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)