Support » WooCommerce » Artikel von Shopseite verschwinden in unregelmäßigen Abständen

  • Hallo Leute,
    ich bin bei folgendem Problem recht verzweifelt, da ich nicht weiß, wie ich es einkreisen soll:

    Bei meinem Woocommerce-Shop verschwinden auf unerklärliche Weise von Zeit zu Zeit die Artikel von der Shopseite (die Shopseite ist dan komplett leer). Das ist natürlich recht katastrophal, da ich in dem Moment die User bzw. Kunden nichts angezeigt bekommen und somit nichts kaufen können. Es passiert in unregelmäßigen Abständen und scheinbar ohne Zusammenhang. Mal direkt nach einem Tag oder ein paar Stunden, dann wieder Tage oder Wochen lang gar nicht.

    Das verrückte ist: Sobald ich es merke und mich in WP einlogge und dabei lediglich die Shopseite im Backend aufrufe (OHNE zu speichern) sind die Artikel wieder sichtbar. Das Problem ist, dass ich es in einer lokalen Testumgebung nicht nachvollziehen kann. Zum einen passiert es dort nicht und sobald ich die Live-Version in meine lokale Umgebung ziehe, sind die Artikel wieder sichtbar.

    Ein Hinweis vielleicht noch: ich betreibe eine zweisprachige Website via WPML. Das Problem taucht aber lediglich nur bei der Hauptsprache Englisch auf. Die Deutsche Shopseite ist immer sichtbar!

    Folgendes habe ich bereits erfolglos versucht, um das Problem einzukreisen:

    1. Ich habe versucht Plugins auszuschließen, die dafür verantwortlich sein könnten. Da ich das Problem in der lokalen Testumgebung nicht rekonstruieren konnte, müsste ich es in der Liveumgebung machen. Das geht natürlich nur bedingt, da ich dort nicht einfach willkürlich Plugins deaktivieren kann. Aber auch hier ist das Problem, dass die Seite sofort wieder sichtbar wird, sobald ich etwas deaktiviere – egal welches Plugin. Es scheint somit irgend ein Caching-Fehler zu sein. Ich verwende jedoch KEIN Caching-Plugin.

    2. Ich kenne noch das alte „Flush the Cache“ Problem in WP, bei dem man einmal kurz die Permalink-Seite aufruft und sich Caching-Fehler dadurch erledigt haben. Das hilft hier allerdings nicht.

    3. Ich hatte kurzzeitig die Idee, dass es vielleicht einen Konflikt bzgl. der Slugs geben könnte. Meine Shopseite hatte den Slug „/shop“. Ich habe diesen deshalb (analog zur deutschen Seite: „/shop-de“) in „/shop-en“ geändert. Das hat leider nichts geändert.

    4. Vor Kurzem kam mir die Idee, dass es vielleicht damit zusammen hängen könnte, dass ich in Woocommerce unter „Einstellungen -> Produkte -> Allgemein -> Shop-Seite“ die besagte Seite als Basisshopseite angegeben habe. Ich hab das Ganze somit gekappt und die Produkte manuell via Shortlink in die Seite eingebaut. Das Ergebnis ist leider das gleiche.

    5. Kurzzeitig dachte ich, dass vielleicht das bloße antriggern der WP-Updates im Hintergrund diesen Caching-Konflikt auslösen könnten. Deshalb habe ich via eines Plugins alle Update-Anfragen und Autoupdates deaktiviert. Nach ein paar Tagen waren leider wieder alle Artikel verschwunden. Das Phänomen taucht unabhängig von Updatemeldungen auf.

    Hier ein paar Eckdaten zu meiner Installation:

    – Ich verwende die momentan aktuellsten Versionen von WP und Woocommerce. Zudem sind alle Plugins auf dem neusten Stand.

    – Ich verwende das Theme „Atomion“ von MarketPress und habe dieses via Child-Theme nach meinen Wünschen angepasst.

    – Ich verwende folgende Plugins:
    • CookieYes | GDPR Cookie Consent
    • Duplicate Page
    • MailPoet + MailPoet Premium
    • Matomo Analytics
    • WPML Multilingual CMS
    • WPML String Translation
    • WP Migrate
    • Yoast SEO
    Erweiterungen für WooCommerce:
    • WooCommerce
    • PayPal PLUS
    • WooCommerce Multilingual & Multi-Currency
    • Fish and Ships
    • German Market
    Benötigt für das Theme:
    • Atomion WooCommerce Blocks
    • Lightbox mit PhotoSwipe

    Ich würde mich sehr freuen, wenn jemand einen Anhaltspunkt hat, wie und wo ich ansetzen kann.

    Danke und allerbeste Grüße!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)
  • Moderator espiat

    (@espiat)

    hi.

    wenn ich mir das spontan und schnell anschaue, dann fällt mir auf, dass eben die englische Version auf einer anderen domain .com endet.

    Dazu ein paar Ideen:
    1. Prüfe einmal, ob deine Datenbank genug Speicher hat. Auch ob dein File Speicher voll ist.

    2. Gehe ich in eine Produkt, dann lautet der Pfad:
    /shop/produkt…
    Die Schopseite hat aber
    /shop-de/produkt…

    Gehe ich von
    .com/shop-en/
    in ein Produkt, dann wird es mit Deutscher Sprache angezeigt.

    Der Fehler scheint tatsächlich bei WPML zu liegen.

    3. hast du eine cache Datei in wp-content/ liegen?

    4. hast du alle erforderlichenPlugins aktiviert?
    https://wpml.org/documentation/related-projects/woocommerce-multilingual/#required-plugins

    5. Wenn du auf den englischen Shop gehst und die Produkte nicht da sind, was steht dann zu dem Zeitpunkt im Quelltext der Site?

    Thread-Starter brayhalv

    (@brayhalv)

    Hi espiat,
    vielen Dank für deine schnelle Reaktion. Hier meine Antworten:

    1. Prüfe einmal, ob deine Datenbank genug Speicher hat. Auch ob dein File Speicher voll ist.

    Genug Speicher ist ausreichend vorhanden und File-Speicher ist nicht voll!

    2. Gehe ich in eine Produkt, dann lautet der Pfad:
    /shop/produkt…
    Die Schopseite hat aber
    /shop-de/produkt…

    Ja, genau… wie oben beschrieben hatte ich irgendwann den Slug bewusst geändert, da ich vermutete, dass es dort einen Konflikt gäbe. Das hat aber nix geändert. Das Problem besteht auch, wenn der Slug gleich ist (also „shop/produkt“).

    Gehe ich von
    .com/shop-en/
    in ein Produkt, dann wird es mit Deutscher Sprache angezeigt.

    Das ist in diesem Falle kein Fehler. Es handelt sich bei dem Produkt um einen Deutschen Titel (Buch), eine Übersetzung würde an dieser Stelle keinen Sinn machen, da es eine englische Übersetzung des Buches gibt. Ist etwas kompliziert aber so wie im Shop angezeigt, ist es korrekt bzw. wurde der deutsche Text in die englische Übersetzerseite übernommen (ist also von mir so gewollt und kein Fehler).

    3. hast du eine cache Datei in wp-content/ liegen?

    Nein!

    4. hast du alle erforderlichenPlugins aktiviert?

    Jupp, sind drinne …

    5. Wenn du auf den englischen Shop gehst und die Produkte nicht da sind, was steht dann zu dem Zeitpunkt im Quelltext der Site?

    Das kann ich in diesem Moment natürlich nicht live rekonstruieren, ich hatte allerdings in der Vergangenheit mal in den Quellcode geschaut und m. E. war dort einfach das Content-DIV leer… Es ist dann nur die Headline „Shop“ zu sehen und der Block mit den Produkten fehlt!

    Vielen Dank für deine Fragen!

    Moderator espiat

    (@espiat)

    Thread-Starter brayhalv

    (@brayhalv)

    Vielen Dank für deine Hilfe, allerdings treffen die dort beschriebenen Probleme nicht auf mein Problem zu bzw. bieten keine Lösung.

    Moderator espiat

    (@espiat)

    wp debug läuft?

    Die artikel haben in etwa dein Problem und es ist immer ein WPML Problem mit den permalinks. auch da verschwinden die Artikel aus den Übersichten.

    Thread-Starter brayhalv

    (@brayhalv)

    …jupp, debug file läuft. Ich bekomme dort viele Meldungen mit dem gleichen Duktus (die gleiche Meldung mit Refrenz zu verschiedenen Block Types). Z. B.:

    [04-Oct-2022 11:00:56 UTC] PHP Notice: Function WP_Block_Type_Registry::register was called incorrectly. Block type „woocommerce/product-top-rated“ is already registered. Please see Debugging in WordPress for more information. (This message was added in version 5.0.0.) in /XXX/wp-includes/functions.php on line 5831

    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von brayhalv.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Thread-Starter brayhalv

    (@brayhalv)

    ok, here we go (absolute pfade habe ich hier mit „XXX“ zensiert):

    
    ### wp-core ###
    
    version: 6.0.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /XXX
    wordpress_size: loading...
    uploads_path: /XXX/wp-content/uploads
    uploads_size: loading...
    themes_path: /XXX/wp-content/themes
    themes_size: loading...
    plugins_path: /XXX/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: WordPress Child Theme Atomion (wordpress-theme-atomion-child)
    version: 1.0
    author: MarketPress
    author_website: https://marketpress.de
    parent_theme: WordPress Theme Atomion (wordpress-theme-atomion)
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, automatic-feed-links, title-tag, woocommerce, html5, align-wide, align-full, custom-background, customize-selective-refresh-widgets, custom-logo, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, menus, widgets
    theme_path: /XXX/wp-content/themes/wordpress-theme-atomion-child
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: WordPress Theme Atomion (wordpress-theme-atomion)
    version: 1.3.5
    author: marketpress.de
    author_website: https://marketpress.de/
    theme_path: /XXX/wp-content/themes/wordpress-theme-atomion
    auto_update: Deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    WP Migrate DB Pro Compatibility: version: 1.2, author: Delicious Brains
    
    ### wp-plugins-active (15) ###
    
    Atomion WooCommerce Blocks: version: 1.0.7, author: MarketPress, Automatische Aktualisierungen deaktiviert
    CookieYes | GDPR Cookie Consent: version: 3.0.2, author: CookieYes, Automatische Aktualisierungen deaktiviert
    Duplicate Page: version: 4.4.9, author: mndpsingh287, Automatische Aktualisierungen deaktiviert
    Fish and Ships: version: 1.4.2, author: wpcentrics, Automatische Aktualisierungen deaktiviert
    German Market: version: 3.16, author: MarketPress, Automatische Aktualisierungen deaktiviert
    Lightbox with PhotoSwipe: version: 5.0.16, author: Arno Welzel, Automatische Aktualisierungen deaktiviert
    MailPoet: version: 3.100.0, author: MailPoet, Automatische Aktualisierungen deaktiviert
    MailPoet Premium: version: 3.100.0, author: MailPoet, Automatische Aktualisierungen deaktiviert
    Matomo Analytics - Ethical Stats. Powerful Insights.: version: 4.11.0, author: Matomo, Automatische Aktualisierungen deaktiviert
    PayPal PLUS for WooCommerce: version: 2.2.1, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    WooCommerce: version: 6.9.4, author: Automattic, Automatische Aktualisierungen deaktiviert
    WooCommerce Multilingual & Multicurrency: version: 5.0.2, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WP Migrate: version: 2.4.0, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    WPML Multilingual CMS: version: 4.5.8, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    WPML String Translation: version: 3.2.1, author: OnTheGoSystems, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Yoast SEO: version: 19.7.1, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_version: 3.4.4
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 8
    imagemagick_file_formats: 3FR, AAI, AI, ART, ARW, AVI, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GROUP4, GV, H, HALD, HDR, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, JBG, JBIG, JNG, JNX, JPE, JPEG, JPG, JPS, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-192-generic x86_64
    httpd_software: Apache
    php_version: 7.4.30 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.37-nmm1-log
    client_version: mysqlnd 7.4.30
    max_allowed_packet: 67108864
    max_connections: 500
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /XXX/wp-content
    WP_PLUGIN_DIR: /XXX/wp-content/plugins
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: true
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: true
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    Moderator espiat

    (@espiat)

    sieht soweit unverdächtig aus.
    es fehlen aber die

    uploads_size etc.

    lass die mal ordentlich „loaden“

    ich würde zudem darauf tippen, dass du die Datenbank aus lokal in produktiv importiert hast?

    Thread-Starter brayhalv

    (@brayhalv)

    ich würde zudem darauf tippen, dass du die Datenbank aus lokal in produktiv importiert hast?

    Meinst du mit „produktiv“ die Live-Umgebung? Es ist tatsächlich ummekehrt: ich habe die Seite damals vor dem Launch direkt auf dem Webserver im Wartungsmodus aufgebaut und sichere das alle Nase lang lokal. Aber was würde das für einen Unterscheid machen?

    Moderator espiat

    (@espiat)

    ich würde dann nämlich in der live site noch urls vermuten, die zur lokalen installation gehören.

    kannst du bitte einmal dieses vorgehen machen:
    https://wpml.org/forums/topic/store-pages-are-missing/#post-9854417

    Thread-Starter brayhalv

    (@brayhalv)

    Den Artkel hatte ich schon vor einiger Zeit gefunden und teilweise versucht das Problem so einzukreisen. Jedoch beschreibt der Artikel nicht das Probem, welches ich habe. Trotzdem habe ich das (ohne natürlich das Storefront-Theme, welche sich nicht verwende) einmal versucht: leider kein Ergebnis. Bei mir werden keine fehlenden Seiten angezeigt – alle sind korrekt übersetzt! Sowieso werden im Status-Bericht bei WPML keine Fehler angezeigt!

    Moderator espiat

    (@espiat)

    Verwendest du Plesk oder einen anderen Hoster mit dem du da eine One Click Installation von WordPress hast?

    Thread-Starter brayhalv

    (@brayhalv)

    …nein, alles selbst installiert – keine Oneclick-Installation!

    Thread-Starter brayhalv

    (@brayhalv)

    Ich hatte in einem der Beiträge gelesen, dass ein User einen Konflikt zwischen Yoast und WPML hatte. Ich habe Yoast nun einmal deaktiviert udn warte jetzt mal ab, ob der Shop in den nächsten Tagen wieder verschwindet!

    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von brayhalv.
Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)