Support » WooCommerce » Artikel von Shopseite verschwinden in unregelmäßigen Abständen

  • brayhalv

    (@brayhalv)


    Hallo Leute,
    ich bin bei folgendem Problem recht verzweifelt, da ich nicht weiß, wie ich es einkreisen soll:

    Bei meinem Woocommerce-Shop verschwinden auf unerklärliche Weise von Zeit zu Zeit die Artikel von der Shopseite (die Shopseite ist dan komplett leer). Das ist natürlich recht katastrophal, da ich in dem Moment die User bzw. Kunden nichts angezeigt bekommen und somit nichts kaufen können. Es passiert in unregelmäßigen Abständen und scheinbar ohne Zusammenhang. Mal direkt nach einem Tag oder ein paar Stunden, dann wieder Tage oder Wochen lang gar nicht.

    Das verrückte ist: Sobald ich es merke und mich in WP einlogge und dabei lediglich die Shopseite im Backend aufrufe (OHNE zu speichern) sind die Artikel wieder sichtbar. Das Problem ist, dass ich es in einer lokalen Testumgebung nicht nachvollziehen kann. Zum einen passiert es dort nicht und sobald ich die Live-Version in meine lokale Umgebung ziehe, sind die Artikel wieder sichtbar.

    Ein Hinweis vielleicht noch: ich betreibe eine zweisprachige Website via WPML. Das Problem taucht aber lediglich nur bei der Hauptsprache Englisch auf. Die Deutsche Shopseite ist immer sichtbar!

    Folgendes habe ich bereits erfolglos versucht, um das Problem einzukreisen:

    1. Ich habe versucht Plugins auszuschließen, die dafür verantwortlich sein könnten. Da ich das Problem in der lokalen Testumgebung nicht rekonstruieren konnte, müsste ich es in der Liveumgebung machen. Das geht natürlich nur bedingt, da ich dort nicht einfach willkürlich Plugins deaktivieren kann. Aber auch hier ist das Problem, dass die Seite sofort wieder sichtbar wird, sobald ich etwas deaktiviere – egal welches Plugin. Es scheint somit irgend ein Caching-Fehler zu sein. Ich verwende jedoch KEIN Caching-Plugin.

    2. Ich kenne noch das alte „Flush the Cache“ Problem in WP, bei dem man einmal kurz die Permalink-Seite aufruft und sich Caching-Fehler dadurch erledigt haben. Das hilft hier allerdings nicht.

    3. Ich hatte kurzzeitig die Idee, dass es vielleicht einen Konflikt bzgl. der Slugs geben könnte. Meine Shopseite hatte den Slug „/shop“. Ich habe diesen deshalb (analog zur deutschen Seite: „/shop-de“) in „/shop-en“ geändert. Das hat leider nichts geändert.

    4. Vor Kurzem kam mir die Idee, dass es vielleicht damit zusammen hängen könnte, dass ich in Woocommerce unter „Einstellungen -> Produkte -> Allgemein -> Shop-Seite“ die besagte Seite als Basisshopseite angegeben habe. Ich hab das Ganze somit gekappt und die Produkte manuell via Shortlink in die Seite eingebaut. Das Ergebnis ist leider das gleiche.

    5. Kurzzeitig dachte ich, dass vielleicht das bloße antriggern der WP-Updates im Hintergrund diesen Caching-Konflikt auslösen könnten. Deshalb habe ich via eines Plugins alle Update-Anfragen und Autoupdates deaktiviert. Nach ein paar Tagen waren leider wieder alle Artikel verschwunden. Das Phänomen taucht unabhängig von Updatemeldungen auf.

    Hier ein paar Eckdaten zu meiner Installation:

    – Ich verwende die momentan aktuellsten Versionen von WP und Woocommerce. Zudem sind alle Plugins auf dem neusten Stand.

    – Ich verwende das Theme „Atomion“ von MarketPress und habe dieses via Child-Theme nach meinen Wünschen angepasst.

    – Ich verwende folgende Plugins:
    • CookieYes | GDPR Cookie Consent
    • Duplicate Page
    • MailPoet + MailPoet Premium
    • Matomo Analytics
    • WPML Multilingual CMS
    • WPML String Translation
    • WP Migrate
    • Yoast SEO
    Erweiterungen für WooCommerce:
    • WooCommerce
    • PayPal PLUS
    • WooCommerce Multilingual & Multi-Currency
    • Fish and Ships
    • German Market
    Benötigt für das Theme:
    • Atomion WooCommerce Blocks
    • Lightbox mit PhotoSwipe

    Ich würde mich sehr freuen, wenn jemand einen Anhaltspunkt hat, wie und wo ich ansetzen kann.

    Danke und allerbeste Grüße!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 16 bis 20 (von insgesamt 20)
  • Moderator espiat

    (@espiat)

    Okay. Gib mal Rückmeldung.
    Interessiert mich nämlich.

    Thread-Starter brayhalv

    (@brayhalv)

    ok, mach ich! Danke für deine Hilfe so far!

    Hi – hat das Yoast Deaktivieren geholfen? Wir haben das gleiche Problem – Unregelmässiges verschwinden der Produkte (ca. 1 mal im Monat – mit WPML und Yoast im Einsatz, Speicher etc. reichlich, alle unnötigen Plugins, auch Caches deaktiviert, Kein Eintrag im Logfile).
    Was wir festgestellt haben ist:
    Wenn wir die Shopseite im Backend öffnen, erscheinen die Produkte wieder für ca. einen Monat. Es scheint, als ob im Hintergrund das Page-Template von „Shop“ auf „Standard“ gewechselt wird. (page-template-default). Im Quellcode stehen im Body andere Klassen:
    Wenn die Seite funktioniert: <body class=“archive post-type-archive …
    Wenn die Seite nicht funktioniert: <body class=“page-template-default page…

    Hat Jemand weitere Hinweise?
    Danke für jede Hilfe.

    Thread-Starter brayhalv

    (@brayhalv)

    Wenn wir die Shopseite im Backend öffnen, erscheinen die Produkte wieder für ca. einen Monat. Es scheint, als ob im Hintergrund das Page-Template von „Shop“ auf „Standard“ gewechselt wird. (page-template-default).

    Guter Hinweis – hatte ich bisher nicht auf dem Schirm.

    Seit meinem Post von vor zwei Wochen ist meine Seite bisher tatsächlich stabil. Allerdings kann ich deshalb noch nicht sagen, ob es jetzt an Yoast liegt. Ich kann es auch nicht auf „einmal im Monat“ eingrenzen. Sollte die Seite die nächsten zwei Wochen stabil bleiben, liegt es definitiv an Yoast – ich werde dann mal bei den Entwicklern anklopfen.

    Thread-Starter brayhalv

    (@brayhalv)

    Moin Zusammen,
    es liegt definitiv an Yoast – das Problem ist seit der Deaktivierung von vor über zwei Monaten nicht mehr aufgetaucht! Falls jemand das gleiche Problem hat: ich habe im Yoast-Support-Forum mal einen Beitrag dazu eröffnet:

    https://wordpress.org/support/topic/empty-woocommerce-products-page-because-of-yoast-plugin/

    Ich wäre allen Leuten dankbar, die dort die Hand heben und sich in die Diskussion mit einklinken!

    Beste Grüße

Ansicht von 5 Antworten - 16 bis 20 (von insgesamt 20)