Support » Plugins » Asgaros Forum – Problem

  • Moin Jungs!

    ich habe ein Problem, und zwar habe ich mir auf meiner Seite das Plugin „Asgaros Forum“ installiert. Aus mir unerklärlichen gründen ist bei der Ansicht eines Posts das Profilfoto mit Namen nach unten verschoben und somit wird der Text auch nur bis zur hälfte (längst) angezeigt.

    Ich würde mich freuen, wenn mir jemand helfen könnte. Das hier ist die betroffene Seite:

    http://scorpions-club-ev.de/index.php/forum/?view=thread&id=1#postid-1

    Gruß

Ansicht von 13 Antworten - 16 bis 28 (von insgesamt 28)
  • Angelika schrieb:

    Was hat das Standardtheme von WordPress in diesem Fall mit dem Foren-Plug-in zu tun?

    Edi schrieb:

    Das hat Flower33 schon beschrieben.

    Da liegt jetzt aber ein kleines Missverständnis zwischen euch vor, oder? Denn von Standard-Theme war bei mir nicht die Rede 🙂

    Ich schrieb, was sich ja auch als zutreffend herausgestellt hat:

    Das liegt vermutlich an einem Namenskonflikt der CSS-Klassen deines *Themes* mit denen des *Forum-Plugins*. Beide verwenden z.B. die Klassen .post-header und .post-author, aber mit unterschiedlichen Eigenschaften. Ich habe leider grade nicht die nötige Zeit und Muse dafür, mich da tiefer reinzudenken, aber ein möglicher Ansatz wäre vielleicht, durch ein Plugin wie „Simple Custom CSS“ für die betreffenden CSS-Klassen des Forums eine höhere Spezifität zu verwenden (etwa durch Voranstellung der Plugin-ID #af-wrapper).

    @icehs:
    Verstehst du jetzt beser, was ich in meinem Beitrag #2 oben meinte? 😉

    @edi:
    Einfach mal RICHTIG lesen:

    Der Avatar kann also gar nicht neben/vor dem Datum platziert sein. Das ist also von der Forensoftware so beabsichtigt: Links Avatar, rechts Text. Da hilft dir auch kein anderes Theme.

    Und mal über den Unterschied zwischen HTML und CSS nachdenken.

    Oder noch mal mit anderen Worten:

    Meine Aussage (Zitat) bezieht sich auf die Position des Avatars. Der Avatar kann nicht ursprünglich neben dem Datum positioniert gewesen und dann herunter gerutscht sein. Das HTML des Foren-Templates hat den Avatar UNTER das Datum und NEBEN den Text platziert. Und diese Positionierung wird durch kein WordPress-Theme geändert.

    Und dies schrieb ich deshalb, um icehs klarzumachen, dass Avatar neben Datum nicht ad hoc möglich ist.

    Jetzt klar?

    Was Flower33 schrieb, habe ich nie in meine Aussagen einbezogen und diesem auch nicht widersprochen, sondern stillschweigend zum größten Teil (bis auf die Ursache der Avatar-Positionierung) zugestimmt. Den CSS- und HTML-Code analysiert, kundgetan, dass Avatar neben Datum laut HTML nicht vorgesehen ist/war, CSS-Snippets erarbeitet und letztendlich eine Lösung präsentiert, die NICHT den Avatar wieder zurück nach oben schiebt (weil das grundsätzlich falsch ist), sondern sichtbare Fehler ausbügelt.

    @angelika und @edi:
    Ich finde es immer ein bisschen schade, wenn es zwischen den sowieso schon wenigen aber sehr geschätzten Helfern hier wegen Nichtigkeiten oder Missverständnissen zu Spannungen kommt. Also tut mir den Gefallen und lasst das hier jetzt nicht in eine Grundsatzdiskussion ausarten – auf gut Deutsch, haltet bitteschön den Ball flach! ;-))

    @angelika: Hast du vorbildlich gemacht, @icehs kann sich glücklich schätzen, dass du dir die nicht unerhebliche Mühe gemacht hast, um ihm eine perfekt funktionierende Lösung zu präsentieren!

    Rhetorische Ergänzung:
    Nun widerspreche ich einer von mir oben gemachten Aussage. Man könnte auch mit CSS den Avatar aus dem Flow herausnehmen, das Datum nach rechts schieben, den Text auf 100% Breite setzen (zumindest ich könnte das), aber das wäre eine wackelige und abenteuerliche Geschichte. Dafür müsste man den Avatar exakt außerhalb des Flows auf die neue Position setzen. Was also auch kein anderes Theme gewährleisten könnte. Möglich wäre es, aber in meinen Augen nur in Notfällen akzeptabel. Irgendwie quick & dirty Lösung.

    Das nur als als Randbemerkung.

    @flower33:
    Missverständnisse sind dazu da, geklärt zu werden. Sollte in meinem vorletzten Post irgendetwas unsachlich klingen, so möchte ich hinzufügen, dass dies nicht beabsichtigt ist.

    Und wenn das mit dem Avatar und den umschließenden Containern nach meiner wiederholten Ausführung noch nicht klar geworden sein sollte, kann ich es auch aufmalen 😀

    @angelika:

    Was Flower33 schrieb, habe ich nie in meine Aussagen einbezogen und diesem auch nicht widersprochen, sondern stillschweigend zum größten Teil (bis auf die Ursache der Avatar-Positionierung) zugestimmt.

    Wobei ich ja lustigerweise zur Ursache der Avatar-Positionierung gar nichts gesagt hatte 😉 Ich hatte gestern Abend noch was anderes zu tun und hab mir daher nur auf die Schnelle auf Website und Forum von @icehs HTML und CSS angeschaut und dann vergleichend eine Demo des Asgaros-Forums aufgerufen, dort den Code überflogen, die Klassenkonflikte entdeckt und hier kurz eine mögliche Problemlösung angedeutet. Schon dort ist aber der Avatar gar nicht neben dem Datum platziert, weshalb ich dieses Anliegen des Fragestellers ganz ausblendete und in meinem Tipp auch gar keine Aussage dazu machte. Warum mir das jetzt zugeschrieben wird, ist mir irgendwie etwas schleierhaft 😉

    Ist aber auch egal jetzt, du hast ihm vorbildlich geholfen und @icehs kann das Problem hoffentlich als „resolved“ abhaken 😉

    Hey Flower33,
    ich habe dir gar nichts zugeschrieben 🙂

    Sondern nur die Abfolge der Vorgänge gedeutet:
    icehs schrieb Avatar nach unten gerutscht
    und deine direkte Antwort darauf:
    „Das liegt vermutlich an einem Namenskonflikt der CSS-Klassen“

    Was du dir dabei gedacht oder ausgeblendet hast, geht daraus nicht hervor :). Ich konnte nu aber auch nicht schreiben, dass ich deiner Antwort #2 100% zugestimmt habe, daher mein Hinweis auf „(bis auf die Ursache der Avatar-Positionierung)“, da das irgendwie da im Raum schwebte. Aber wir verzetteln uns jetzt tatsächlich. Deswegen hör ich jetzt auf 😀

    Ich konnte nu aber auch nicht schreiben, dass ich deiner Antwort #2 100% zugestimmt habe, daher mein Hinweis auf „(bis auf die Ursache der Avatar-Positionierung)“, da das irgendwie da im Raum schwebte.

    Ah, ich verstehe, alles klar 😉

    Edi

    (@psychosopher)

    Moin Jungs!

    ich habe ein Problem, und zwar habe ich mir auf meiner Seite das Plugin „Asgaros Forum“ installiert. Aus mir unerklärlichen gründen ist bei der Ansicht eines Posts das Profilfoto mit Namen nach unten verschoben und somit wird der Text auch nur bis zur hälfte (längst) angezeigt.

    Ich würde mich freuen, wenn mir jemand helfen könnte. Das hier ist die betroffene Seite:

    http://scorpions-club-ev.de/index.php/forum/?view=thread&id=1#postid-1

    Gruß

    Ich habe da nichts von Avatar vor dem Datum und dergleichen gelesen. Aber ich kann mich natürlich irren.

    Was ich gemacht habe, ist die Website anzuschauen. Und gesehen, dass da einiges verschoben ist. Der Grund dafür ist der CSS-Konflikt, auf den Flower33 bereits vor mir hingewiesen hat.

    Und wenn ich jemandem vorschlage, das Theme zu wechseln, dann deshalb, weil das einfacher und schneller geht, als HTML und CSS zu erklären. Zumal ich davon Deiner Meinung nach sowieso keine Ahnung habe.

    Zudem ist aussdrücklich gefragt worden:

    hat jemand noch eine Idee?

    Aber auch das kann ich völlig missverstanden haben.

    Lieber Edi,
    wenn etwas (Avatar) nach unten rutscht und etwas (Text) dadurch verdrängt wird, muss es vorher oben gewesen sein. Und oben ist das Datum mit einem Container, der viel zu hoch für nur Text, aber passend für einen Avatar war. Avatar alleine über Text macht keinen Sinn.

    Ich habe nie geschrieben oder gedacht oder gemeint, dass du keine Ahnung von HTML und CSS hast. Wir reden nur fortlaufend von etwas anderem scheint mir, der eine von Äpfeln und der andere von Birnen.

    Edi

    (@psychosopher)

    Wahrscheinlich… Jedenfalls hast Du einen guten „Job“ gemacht, 🙂

    Moin!

    Das hat bis jetzt alles super funktioniert, auch mit deiner letzten Hilfe. Danke nochmal.

    Doch ein Frage hätte ich noch. Ich bekomme den bläulichen Hintergrund des Titels im Widget nicht weg. Ich habe vieles probiert. Kannst du mir da weiterhelfen?

    Ebenfalls habe ich leider das Problem, ich würde gerne wenn man einen Beitrag verfasst, dass oben ein Button zum auswählen von Smilies ist, wie man in vielen Foren findet. Nur leider funktioniert das nicht.
    Hat dazu jemand eine Idee?
    Gruß

    @edi
    🙂

    @icehs
    mit .asgarosforum-widget .post-link und background. Wenn du mehr Änderungen an dem Theme deiner Website vornehmen möchtest, beschäftige dich bitte näher mit CSS http://www.w3schools.com/css/ und google mal nach der Handhabung der Entwickler-tools oder beauftrage jemanden 🙂

Ansicht von 13 Antworten - 16 bis 28 (von insgesamt 28)
  • Das Thema „Asgaros Forum – Problem“ ist für neue Antworten geschlossen.