Support » Allgemeine Fragen » Bilder Upload funktioniert nicht mehr -2-

  • Gelöst blacckmamba

    (@blacckmamba)


    Hallöchen, möchte auch meinen Senf dazu abgeben.

    Hab genau das beschriebene Problem und werde noch wahnsinnig. Genau wie caprisonne schreibt, alles dazu gelesen, alles versucht. Lustigerweise wird die betroffene Website auch bei Strato gehostet.

    Hab einen Blogbeitrag gefunden, bei dem geraten wird, auf PHP 7.4 zurückzugehen, weil das Problem wohl diese Verringerung der Bildgröße auf die 2560 Pixel sein soll. Kann ich nur leider nicht, weil das bei Strato nicht mehr möglich ist (nur noch 8.0). Aber vielleicht hilft der Tipp ja jemandem weiter.

    Es scheint zwar absurd, dass mein Computer schuld sein soll, aber ich werde es morgen auch vom Laptop aus probieren.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Thread-Starter blacckmamba

    (@blacckmamba)

    Hab jetzt einfach nochmal wahllos versucht, Bilder hochzuladen.

    Das Ergebnis ist: Die Größe (Dimensionen) spielt keine Rolle. Auch bis 6000 Pixel kein Problem. Wird von WordPress einfach auf die 2560 Pixel verkleinert (und dann mit _scaled angezeigt).

    Aber die Speichergröße ist ausschlaggebend. Bis ca. 500 KB ist alles fein. Alles darüber wird abgelehnt.

    Wie ist das zu erklären?

    (Ich hab bei Strato 75 GB Speicher, davon belegt die Website ca. 7,9 GB. Daran liegt es also nicht).

    Das könnte eine Einstellung von PHP sein, die Konfig-Variable nennt sich upload_max_filesize, auch post_max_size solltest du prüfen.

    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von bscu.

    Moderatorenhinweis: Bitte immer ein neues Thema beginnen und nicht an ein sogar gelöstes Thema anhängen, siehe FAQ und bitte den Link zur Seite oben eintragen. Hier der Link zum vorherigen Thema.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Bei Strato geht die Umstellung der PHP Version (bei einem meiner Kunden) doch, aber nicht direkt im WebAdmin vom Strato Hosting, sondern über die .htaaccess Datei im Webroot (da wo auch die wp-config.php liegt). Die genaue Syntax für die einzufügende Zeile würde ich im Web suchen. Sie startet meine ich mit „AddHandler ..“. Klar wäre die Nutzung von PHP8.0 etwas sicherer, aber evt ist der Fehler in WordPress 6.3.3 einfach behoben.

    Hallo,
    das kann ich nicht bestätigen: Wir haben auch noch einen Kunden bei Strato und da funktionierte das zumindest problemlos über den Kundenbereich.
    Aber warten wir mal den Website-Bericht von @blacckmamba ab.

    Viele Grüße
    Hans-Gerd

    Hallo,
    Strato hat bietet bestimmt auch unterschiedliche Hosting Angebote an. Vor ca. 1/2 Jahr gab es die Möglichkeit der Einstellung PHP 7.4 in meinem Fall nicht. PHP 7.4 konnte in der .htaccess durch die neue Zeile:

    AddType application/x-httpd-php74 .php

    eingestellt werden. Es war nötig weil der Anwender leider so lange keine WordPress Updates gemacht hat das ein Login unter PHP8.x nicht mehr möglich war, Strato aber umgestellt hatte.

    Falls das probiert werden soll erst eine Sicherung der bestehenden .htaccess Datei machen. Dann die Zeile weit oben einfügen (dabei suchen ob nicht bereits so eine Zeil existiert und ggf. entfernen) und dann im Admin>Webseitenzustand nachschauen ob es wirkt.

    Thread-Starter blacckmamba

    (@blacckmamba)

    Hallo zusammen und danke für die vielen Anregungen!

    upload_max_filesize, auch post_max_size  ist okay, hatte ich schon vor Jahren hochgestellt. Alle Plugins ausgeschaltet, Theme auf Standard. Alles schon gemacht gehabt.

    Ich vermute, dass Strato einfach zwischendurch etwas schlapp macht (zumindest auf dem einen Server). Neulich gab es doch sogar mal einen Totalausfall, der über viele Stunden ging und alles lahmgelegt hat („menschliches Versagen“ oder so war die Antwort von Strato).

    Wie schon beschrieben, ist meine Lösung aktuell einfach, dass ich die Größe der Bilder reduziere bzw. komprimiere, bevor ich sie hochlade. Die Dimensionen spielen keine Rolle, da WordPress automatisch skaliert. Wobei meine Bilder sowieso kleiner sind.

    Normalerweise hatte ich immer so 1,2 MB große Bilder, die dann per Plugin beim Upload komprimiert wurden und dann bei 300-400 KB landeten. Nun muss ich diesen Zwischenschritt noch machen.

    Hab aber auch die letzten Tage totale Schwankungen festgestellt. Einmal ist es mir dann doch gelungen, die Bilder unkomprimiert hochzuladen. Am nächsten Tag dann wieder nicht mehr.

    Aber jetzt hab ich erstmal meine Lösung!

    Hoffe, dass das noch weiteren Menschen hilft.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

    Thread-Starter blacckmamba

    (@blacckmamba)

    Klar, das mache ich! Vielen Dank für den Hinweis!

    👍

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)