Support » Allgemeine Fragen » Aus 1 Problem mach 2: Seite nur noch im Text-Format und Admin nicht erreichbar

  • Gelöst purlefurz

    (@purlefurz)


    Hallo ihr alle zusammen!

    Ich bastel seit einigen Tagen an einer Homepage mit WordPress. Ich bin Neuling auf dem Gebiet, habe vorher mit Joomla und Dreamweaver gearbeitet.

    Jetzt mein Problem: ich habe die Seite mit einem Theme erstellt (Divi glaub ich) und dieses nach Anleitung aufgebaut. Als ich halbwegs sicher war, habe ich meine Inhalte selbständig gefüllt. Dabei habe ich keine Beiträge sondern Seiten erstellt.

    Hieraus resultierte mein 1. Problem: wenn ich die URL eingegeben habe, landetet ich immer auf einer Beitragsseite, die nicht gefunden werden konnte, weil ich alle Beiträge gelöscht habe. Eigentlich sollte die Webseite mit der Seite „Home“ starten. Um da hin zu kommen, musste ich aber jedes mal im Menü auf „Home“ klicken. Das wollte ich vermeiden. Also habe ich gegooglet und bin darauf gestoßen, dass ich im Bereich „Einstellungen“ „Allgemein“ die Startseite festlegen kann und habe diese umgewandelt in „Website/home“
    Das erzielte jedoch nicht das gewünschte Ergebnis. Es blieb alles gleich. Also habe ich die Einstellungen wieder zurück gesetzt und gespeichert.

    Und seitdem habe ich nun das 2. Problem:
    Die Homepage wird nur noch als Text angezeigt, ohne graphische Elemente und einfach von oben nach unten runter. Und das Einloggen im Admin-Bereich geht seit dem gar nicht mehr. Fehlermeldung: Seite nicht gefunden!!

    Die htaccess habe ich bereits gelöscht, hat aber auch nichts gebracht!

    HILFEEEE! Ich habe echt keine Lust, noch mal alles von vorne zu erstellen, da ist so wahnsinnig viel Content drin! Kann mir einer helfen?

    URL: http//romi-europa.de

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moderator PraetorIM

    (@praetorim)

    OK, das sind drei Probleme (Admin-Zugang, Darstellung und Startseite), die wir nacheinander angehen sollten.

    Zunächst einmal das Problem mit dem Admin-Zugang. Ich vermute, das Problem liegt hier:

    gegooglet und bin darauf gestoßen, dass ich im Bereich „Einstellungen“ „Allgemein“ die Startseite festlegen kann und habe diese umgewandelt in „Website/home“

    Du bist leider im falschen Menu gelandet und hast die URL für Deine gesamte Site geändert.

    Um das zu ändern musst Du einmal die Datei wp-config.php (liegt im Stammverzeichnis Deiner WordPress-Installation) editieren. Trag dort – oberhalb der Zeile ´/* That’s all, stop editing! Happy blogging.*/)´ eine neue Zeile ein:
    define( 'RELOCATE', true );
    Danach kannst Du dich wieder im Admin-Bereich einloggen.
    Gehe dann dort wieder auf die Seite Einstellungen > Allgemein und ändere die Einträge wieder auf den alten Wert.
    Danach solltest Du in der wp-config.php die Zeile mit dem Relocate wieder löschen.

    Moderator PraetorIM

    (@praetorim)

    Wenn das geklappt hat, dürfte damit vermutlich auch das zweite Problem – die Darstellung als reiner Text – erledigt sein.

    Wenn nicht, kontrolliere bitte zunächst noch einmal unter Design > Themes, ob das richtige Theme ausgewählt ist.

    Moderator PraetorIM

    (@praetorim)

    Und jetzt noch der Auslöser der anderen Probleme:

    Du kannst in WordPress wählen zwischen einer festen Startseite oder einer Seite, auf der Deine neuesten Artikel angezeigt werden. Standardmäßig – und so derzeit auch bei Dir – sind die neuesten Artikel eingestellt. Für Deine Zwecke kannst Du das wie folgt umstellen:

    Wenn Du auf Einstellungen > Lesen (http://romi-europa.de/wp-admin/options-reading.php) gehst, beginnt die Einstellungsseite mit „Startseite zeigt“. Dort wählst Du den zweiten Punkt „eine statische Seite (unten auswählen)“. Danach kannst Du in der Zeile darunter in der Drop-Down-liste bei „Startseite:“ aus den bereits von Dir erstellten Seiten die passende Startseite auswählen. Anschließend noch auf „Änderungen übernehmen“ klicken und voila.

    Thread-Ersteller purlefurz

    (@purlefurz)

    Erst mal vielen Dank für die schnellen Tipps!

    Leider habe ich schon bei Step 1 ein Problem:

    Um das zu ändern musst Du einmal die Datei wp-config.php (liegt im Stammverzeichnis Deiner WordPress-Installation) editieren. Trag dort – oberhalb der Zeile ´/* That’s all, stop editing! Happy blogging.*/)´ eine neue Zeile ein:
    define( ‚RELOCATE‘, true );

    Diese Zeile steht gar nicht in meiner wp-config.php drin.

    Thread-Ersteller purlefurz

    (@purlefurz)

    Aaaaah!! Jetzt hab ich es auch gelesen! Es steht doch drin! *ups*

    Ok, ich probier das gleich mal und meld mich dann

    Thread-Ersteller purlefurz

    (@purlefurz)

    Ok. Ich habe die Datei editiert, aber ich komme trotzdem nicht in den Admin-Bereich rein.

    Wenn ich die Adresse angebe: http://romi-europa.de/wp-admin dann kommt bei mir die Meldung: „Die Webseite wurde nicht gefunden“

    Genauso wenn ich eingebe: http://romi-europa.de/WordPress_01/wp-admin

    Was hab ich falsch gemacht??

    Thread-Ersteller purlefurz

    (@purlefurz)

    Ich sehe gerade, dass STRATO Probleme hat. Möglicherweise liegt es daran. Dann warten wir jetzt mal ab und schauen, ob ich im Laufe des Tages wieder drauf komme

    Thread-Ersteller purlefurz

    (@purlefurz)

    So, nachdem Strato wieder läuft, habe ich alles so gemacht, wie beschrieben.

    Vielen Vielen Dank! Es hat alles geklappt, die Seite ist wieder da, die richtige Startseite ist auch da, PERFEKT!

    Super, dass du mir so schnell helfen konntest!

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Aus 1 Problem mach 2: Seite nur noch im Text-Format und Admin nicht erreichbar“ ist für neue Antworten geschlossen.