Support » Themes » (autom.) Updates – lediglich via FTP oder auch über SFTP möglich!?

  • Gelöst stnabor

    (@stnabor)


    Hallo Community,

    vorweg – vielen Dank für die tollen Supports hier in diesem Forum.

    heute eine Frage die mittelbar auch mit Themes zu tun hat – und ich glaube dass euch hier bestimmt etwas einfällt.

    ich verwende SFTP um WordPress-plugins zu installieren. in dem Plugin-Dialog hab ich aber lediglich FTP für den installationsdialog.

    Klar bekomme ich dann die Fehler;

    Failed to connect to FTP Server http://www.xxxxx.com:21

    Gab es mal die Möglichkeit die Worpress–Upgrade-Einstellungen so zu wählen, dass hier auch ein SFTP-Client damit klar kommt?

    ich hab hier schon mal kursorisch durchgesehen: https://wordpress.org/support/article/editing-wp-config-php/#wordpress-upgrade-constants

    BTW: nur vorweg – hab lediglich diesen SFTP-Client – aber kein SSL-Zugang..

    Freue mich auf einen Tipp.

    Viele Grüße
    STNabor 😉

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • ich verwende SFTP um WordPress-plugins zu installieren.

    Gibt es einen Grund, wieso du Plugins manuell installierst?
    Oder wurde dir das als Option angeboten, weil die Benutzerrechte nicht ausreichen?

    hab lediglich diesen SFTP-Client – aber kein SSL-Zugang.

    Meinst du einen SSH-Zugang? Hast du mal geprüft, ob du dich mit den Zugangsdaten für den FTP-Client per SSH anmelden kannst? Das ist öfter möglich, als man vermutet.

    Unseren angehefteten Beitrag kennst du?

    Bevor du ein neues Thema (Thread) erstellst

    Da steht unter anderem, dass wir dir gerne helfen, wenn wir eine URL zur Website und einen Website-Bericht bekommen. Beides sehe ich hier nicht. Kommt sicher noch? 🙂

    Thread-Ersteller stnabor

    (@stnabor)

    Nabend Bego Mario

    vielen Dank für Deine rasche Antwort. Vorweg: ja also die Seite – sie ist ja in dem Moment ggf. gar nicht so wichtig -/ auf dem Server laufen einige – bei allen ists dasselbe – aber es ist imho tief im System liegende oder wurzelnde Frage. M.a.W. es hat im Grunde dann eher weniger mit dem Frontend zu tun sondern mit Netz-Schnittstellen /(sockets u . Protokollen) anyway;: ist die Seite die du schon kennst. htts://www.job-starter.com ) und ja.
    BTW: Mehr im Nächsten Thread.

    Das hier – also das Problem mit dem Protokoll – das muss ich mal noch näher untersuchen: ich guck hier die Protokoll-Dinge noch einmal genauer durch.
    (hab das hier ja schon mal kursorisch durchgesehen: https://wordpress.org/support/article/editing-wp-config-php/#wordpress-upgrade-constants ) und ferner kläre ich mit meinem Server-Admin ob ich ggf. doch einen SSL Zugang habe – glaub aber nicht.

    Wenn ich hier mehr herausgekriegt hab dann meld ich mich wieder. VG STNabor 😉

    WordPress legt selber zum Beispiel bei der Installation neuer Themes und Plugins Verzeichnisse an. Das funktioniert nicht, wenn die Benutzerrechte nicht stimmen. Ob die Benutzerrechte passen, kannst du im Menü Werkzeuge > Website-Zustand prüfen. Im Tab Bericht wird dir unter Dateisystem-Berechtigungen angezeigt, dass ein oder meherer Verzeichnisse nicht beschreibbar sind:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    In ihrer Weisheit haben die Core-Entwickler auch vorhergesehen, dass Benutzer WordPress auf einen billigen Shared-Hosting-Angebot mit allen möglichen Einschränkungen nutzen möchten. Für den Fall, dass die Benutzerrechte nicht ausreichen, wird versucht, mit einem FTP-Zugang notwendige Vorgänge „durch die Hintertür“ auszuführen. Da das aber nur eine Notlösung ist, solltest du nicht überlegen, wie du den FTP-Zugang optimieren kannst, sondern wie du die Dateiberechtigung korrigierst.

    Thread-Ersteller stnabor

    (@stnabor)

    Hallo Bego Mario,

    vielen Dank – also – wenn ich mich erinnere, dann fällt mir ein dass ich auf dem SERVER schon seit längerem ( und es ist kein Shared Hosting etc. etx. Ding) das Thema hab dass die uploaded Files _/ Ordner einen eingenen User haben (vgl. die bilder)

    Übersicht: Rechte auf Upload_Ordner:

    übersicht: Rechte auf TMP-Ordner1

    übersicht: Lage des Jobify-Demo-contents: JSON-Files

    Übersicht: site-Health-Status:

    Übersicht: site-Health-Status two

    Übersicht: Jobify-Demo-Install: picture 1

    Übersicht: Jobify-Demo-Install: picture 2 with results

    Vielleicht rühren diese Probleme die ich mit Uploads habe ( einem Theme-Demo-Upload ) habe – Dann komme ich hier auch in Probleme. Ich glaub dass das alles irgendwie zusammehängt. Der Upload – eines schlichten Demos scheitert – und läuft in Probleme rein. Will das hier nun nicht noch thematisieren – denn Hand Gerhard hat mir gestern in einem der letzten Threads bereits gesagt dass support nur für Standard Themes geleistet wird – was ja 100 % nachvollziehbar ist. Ich komme hier in diesem Thread und durch deine Antwort nur darauf – weil du mich darauf bringst – dass ich ggf. an meinem Server noch Themen zum Abklären hab..

    hier die Errorrlogs -die sind m.e. sehr interessant.

    
    [Mon Feb 28 15:58:43.286444 2022] [php7:notice] [pid 12347] [client 91.43.234.34:60688] WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my-site.com/wp-admin/themes.php?theme=jobify
    [Mon Feb 28 14:59:48.684255 2022] [php7:notice] [pid 9358] [client 91.43.234.34:60718] WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my-site.com/wp-admin/admin.php?page=jobify-setup
    [Mon Feb 28 15:58:43.286444 2022] [php7:notice] [pid 12347] [client 91.43.234.34:60688] WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my-site.com/wp-admin/themes.php?theme=jobify
    [Mon Feb 28 14:59:48.684255 2022] [php7:notice] [pid 9358] [client 91.43.234.34:60718] WordPress database error Table 'jc.wp_pmxi_imports' doesn't exist for query SELECT options FROM wp_pmxi_imports WHERE id = 0 made by require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), WP_Hook->do_action, WP_Hook->apply_filters, WPAI_WP_Job_Manager_Add_On->init, WPAI_WP_Job_Manager_Add_On_Helper->get_post_type, referer: https://www.my-site.com/wp-admin/admin.php?page=jobify-setup

    und danach:

    [Mon Feb 28 16:25:45.311493 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_files' for query ALTER TABLE wp_pmxi_files CHANGE COLUMN <code>registered_on</code> registered_on DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311558 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_images' for query ALTER TABLE wp_pmxi_images CHANGE COLUMN <code>id</code> id BIGINT(20) UNSIGNED NOT NULL AUTO_INCREMENT made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311623 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_images' for query ALTER TABLE wp_pmxi_images CHANGE COLUMN <code>attachment_id</code> attachment_id BIGINT(20) UNSIGNED NOT NULL made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311688 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_images' for query ALTER TABLE wp_pmxi_images CHANGE COLUMN <code>image_url</code> image_url VARCHAR(900) NOT NULL DEFAULT '' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311748 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_images' for query ALTER TABLE wp_pmxi_images CHANGE COLUMN <code>image_filename</code> image_filename VARCHAR(900) NOT NULL DEFAULT '' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311814 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>id</code> id BIGINT(20) UNSIGNED NOT NULL AUTO_INCREMENT made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311878 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>import_id</code> import_id BIGINT(20) UNSIGNED NOT NULL made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.311974 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>type</code> type ENUM('manual','processing','trigger','continue', 'cli', '') NOT NULL DEFAULT '' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312050 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>time_run</code> time_run TEXT made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312116 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>date</code> date DATETIME NOT NULL DEFAULT '0000-00-00 00:00:00' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312174 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_history' for query ALTER TABLE wp_pmxi_history CHANGE COLUMN <code>summary</code> summary TEXT made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312239 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_hash' for query ALTER TABLE wp_pmxi_hash CHANGE COLUMN <code>hash</code> hash BINARY(16) NOT NULL made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312302 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_hash' for query ALTER TABLE wp_pmxi_hash CHANGE COLUMN <code>post_id</code> post_id BIGINT(20) UNSIGNED NOT NULL made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312360 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_hash' for query ALTER TABLE wp_pmxi_hash CHANGE COLUMN <code>import_id</code> import_id SMALLINT(5) UNSIGNED NOT NULL made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta, referer: https://www.my-site.com/wp-admin/plugins.php
    [Mon Feb 28 16:25:45.312427 2022] [php7:notice] [pid 16791] [client 91.43.234.34:58432] WordPress database error ALTER command denied to user 'jc'@'localhost' for table 'wp_pmxi_hash' for query ALTER TABLE wp_pmxi_hash CHANGE COLUMN <code>post_type</code> post_type VARCHAR(32) NOT NULL DEFAULT '' made by require_once('wp-admin/admin.php'), do_action('admin_init'), WP_Hook->do_action, WP_Hook->apply_filters, PMXI_Plugin->fix_options, PMXI_Plugin->fix_db_schema, dbDelta,
    • Diese Antwort wurde geändert vor 2 Monaten, 3 Wochen von stnabor.

    Schade, du hast den angehefteten Beitrag immer noch nicht gelesen?

    Dabei ist es wirklich ganz einfach:

    • Im Backend anmelden.
    • Im Menü Werkzeuge das Untermenü Website-Zustand aufrufen
    • In den Tab Bericht gehen und abwarten, bis die Zustandsanzeige oben abgeschlossen ist.
    • Per Button den Website-Bericht in die Zwischenablage kopieren.
    • Zwischenablage in eine neue Antwort unverändert einfügen.

    Das geht nicht nur schneller, sonder ist auch viel aussagefähiger als ein Dutzend Screenshots. Ich weiß, man mag das kaum glauben, aber auch unsere Zeit ist kostbar.

    Thread-Ersteller stnabor

    (@stnabor)

    Hi Bego Mario Garde,

    vorweg: vielen Dank für Deine Rückmeldung. Also – du hast durchwegs Recht und deine Ideen leuchten alle ein. Ich liefer die Daten – und nebenbei denke ich dass wir hier auf dem richtigen Pfad sind. Denn mit den DATEN – u. Server-Zustand ist an dieser STELLE m.E. wirklich was nicht ganz Ordnung.

    Und ja Bego Mario: … also ich glaube das die Rechte auf den diversen Ordnern komisch sind.
    1. Was – das ist die große FRAGE – was passiert wenn die Rechte so sind wie sie bei mir sind? Läuft das unweigerlich in Turbulenzen mit Uploads wie bei Themes usw. usf.

    1.b. ist das denn wirklich so: und ja: wenn ja, dann muss ich mal mit dem SERVER-Admin reden, welcher das Backend betreut…Dass ich hier was ändere.

    Site Health Status:
    The site health check shows critical information about your WordPress configuration and items that require your attention.
    1 critical issue
    

    und im Detail:

    issue
    Background updates are not working as expected
    Security:Background updates ensure that WordPress can auto-update if a security update is released for the version you are currently using.
    Passed No version control systems were detected.
    Error Your installation of WordPress prompts for FTP credentials to perform updates. (Your site is performing updates over FTP due to file ownership. Talk to your hosting company.)
    
    ### wp-core ###
    
    version: 5.9.1
    site_language: en_US
    user_language: en_US
    timezone: +00:00
    permalink: /index.php/%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /sites/www.job-starter.com
    wordpress_size: 70.82 MB (74258709 bytes)
    uploads_path: /sites/www.job-starter.com/wp-content/uploads
    uploads_size: 24.17 MB (25346069 bytes)
    themes_path: /sites/www.job-starter.com/wp-content/themes
    themes_size: 13.13 MB (13771020 bytes)
    plugins_path: /sites/www.job-starter.com/wp-content/plugins
    plugins_size: 49.50 MB (51907668 bytes)
    database_size: 6.55 MB (6864896 bytes)
    total_size: 164.17 MB (172148362 bytes)
    
    ### wp-active-theme ###
    
    name: Jobify (jobify)
    version: 4.0.3
    author: Astoundify
    author_website: http://themeforest.net/item/jobify-wordpress-job-board-theme/5247604?ref=Astoundify
    parent_theme: none
    theme_features: core-block-patterns, post-thumbnails, job-manager-templates, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, editor-style, automatic-feed-links, title-tag, custom-background, custom-header, customize-selective-refresh-widgets, menus, widgets
    theme_path: /sites/www.job-starter.com/wp-content/themes/jobify
    auto_update: Disabled
    
    ### wp-themes-inactive (5) ###
    
    JobScout: version: 1.1.3, author: Rara Theme, Auto-updates disabled
    Listify: version: 3.0.6, author: Astoundify, Auto-updates disabled
    Twenty Twenty: version: 1.9, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-One: version: 1.5, author: the WordPress team, Auto-updates disabled
    Twenty Twenty-Two: version: 1.1, author: the WordPress team, Auto-updates disabled
    
    ### wp-plugins-active (20) ###
    
    Appointify: version: 1.0.4, author: Appointify, Auto-updates disabled
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Auto-updates disabled
    CoBlocks: version: 2.21.6, author: GoDaddy (latest version: 2.22.1), Auto-updates disabled
    Contact Listing for WP Job Manager: version: 1.4.1, author: Astoundify, Auto-updates disabled
    Elementify Visual Widgets: version: 1.0.0, author: Astoundify, Auto-updates disabled
    Elementor: version: 3.5.5, author: Elementor.com (latest version: 3.5.6), Auto-updates disabled
    If Menu - Visibility control for menu items: version: 0.16.2, author: Layered, Auto-updates disabled
    Ninja Forms: version: 3.6.7, author: Saturday Drive, Auto-updates disabled
    RARA One Click Demo Import: version: 1.2.9, author: raratheme, Auto-updates disabled
    RaraTheme Companion: version: 1.3.9, author: Rara Theme, Auto-updates disabled
    Regions for WP Job Manager: version: 1.18.0, author: Astoundify, Auto-updates disabled
    Simple Registration for WooCommerce: version: 1.5.3, author: Astoundify, Auto-updates disabled
    TF Random Numbers: version: 1.8, author: Themeflection, Auto-updates disabled
    WooCommerce: version: 6.2.1, author: Automattic, Auto-updates disabled
    WP All Import: version: 3.6.6, author: Soflyy, Auto-updates disabled
    WP All Import - WP Job Manager Add-On: version: 1.2.1, author: Soflyy, Auto-updates disabled
    WPJM Extra Fields: version: 1.3.0, author: Gabriel Maldonado, Auto-updates disabled
    WP Job Manager: version: 1.35.2, author: Automattic, Auto-updates disabled
    WP Job Manager - Company Profiles: version: 1.4, author: Astoundify, Auto-updates disabled
    WP Job Manager - Job Type Colors: version: 1.0.2, author: Astoundify, Auto-updates disabled
    
    ### wp-plugins-inactive (8) ###
    
    Akismet Anti-Spam: version: 4.2.2, author: Automattic, Auto-updates disabled
    Contact Form 7: version: 5.5.5, author: Takayuki Miyoshi (latest version: 5.5.6), Auto-updates disabled
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Auto-updates disabled
    Kadence Blocks – Gutenberg Blocks for Page Builder Features: version: 2.2.7, author: Kadence WP (latest version: 2.2.10), Auto-updates disabled
    Participants Database: version: 2.0.1, author: Roland Barker, xnau webdesign (latest version: 2.0.6), Auto-updates disabled
    Restricted Site Access: version: 7.3.0, author: Jake Goldman, 10up, Oomph, Auto-updates disabled
    TablePress: version: 1.14, author: Tobias Bäthge, Auto-updates disabled
    WP Mail SMTP: version: 3.2.1, author: WPForms (latest version: 3.3.0), Auto-updates disabled
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 16M
    max_effective_size: 8 MB
    max_file_uploads: 32
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, PNG, BMP
    ghostscript_version: unknown
    
    ### wp-server ###
    
    server_architecture: unknown
    httpd_software: Apache
    php_version: 7.4.11 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 16M
    php_post_max_size: 8M
    curl_version: not available
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.33
    client_version: mysqlnd 7.4.11
    max_allowed_packet: 1048576
    max_connections: 64
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /sites/www.job-starter.com/wp-content
    WP_PLUGIN_DIR: /sites/www.job-starter.com/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: not writable
    uploads: writable
    plugins: writable
    themes: writable

    … also ich glaube das die Rechte auf den diversen Ordnern komisch sind.
    1. Was – das ist die große FRAGE – was passiert wenn die Rechte so sind wie sie bei mir sind? Läuft das unweigerlich in Turbulenzen mit Uploads wie bei Themes usw. usf.

    1.b. ist das denn wirklich so: und ja: wenn ja, dann muss ich mal mit dem SERVER-Admin reden, welcher das Backend betreut…Dass ich hier was ändere.

    2. und ggf. in meinem Spezialfall: hätt ich hier bei dem Theme-Demo-Upload ggf. noch ein Child-Theme noetig – ich denke, dass das auch hülfe!?

    Zu Frage 1.

    … was passiert wenn die Rechte so sind wie sie bei mir sind?

    WordPress kann keine Updates ausführen,
    die Installation von Themes und Updates schlägt fehl,
    du wirst gefragt, ob du als Notlösung eine Verbindung per FTP nutzen möchtest.

    (Hatten wir das nicht schon geklärt?)

    Zu Frage 1b

    … dann muss ich mal mit dem SERVER-Admin reden, welcher das Backend betreut…

    Nicht zwingend. Unter Umständen kannst du im Kundenmenü des Webhosters auch über ein Dateiverwaltungsmenü den Benutzer zuweisen.

    Zum Website-Bericht

    Sprache US-Englisch? Ist das so gewünscht?
    (Nichts gegen einzuwenden, nur ungeöhnlich.)

    timezone: +00:00 solltest du auf Berlin ändern, dann klappt’s auch mit der Umstellung auf die Sommerzeit.

    wp-active-theme – name: Jobify (jobify)

    zu gekauften Themes können wir nicht weiterhelfen, weil sie uns für kostenlosen Support nicht zur Verfügung stehen.

    wp-plugins-inactive (8) – solltest du aus Sicherheitsgründen löschen. Auch ein nicht aktiviertes Plugin kann theoretisch eine Sicherheitslücke enthalten. Wieso also ein Risiko eingehen für ein Plugin, das du nicht mal verwendest?

    ### wp-filesystem ###
    wp-content: not writable

    genau hier liegt dein Problem.

    Zu Frage 2

    hätt ich hier bei dem Theme-Demo-Upload ggf. noch ein Child-Theme noetig – ich denke, dass das auch hülfe!?

    Was soll das bewirken?

    Dein Theme-Entwickler hat vermutlich irgendein Tool konstruiert, mit dem du die Einstellungen einer Demo-Seite übernehmen kannst. Das setzt korrekte Dateirechte voraus. Was hat das mit Child-Theme zu tun?

    Bitte sei so nett und beschränke deine Antworten auf wesentliche Inhalte. Wir beantworten hier Fragen in unserer freien Zeit und die ist knapp. Wenn ich dann erst einmal zwischen diversen Screenshots die eigentliche Frage suchen muss, geht zuviel Zeit verloren, in der ich bereits den nächsten Thread beantworten könnte.

    Thread-Ersteller stnabor

    (@stnabor)

    hallo und guten Tag, Danke – vielen Dank!

    Danke für die nochmaligen Hinweise darauf

    ### wp-filesystem ###
    wp-content: not writable

    Danke für alle weiteren Hinweise. auch zum allgem. Handling.
    BTW; ist n rootserver – ich hab also nicht im engen Sinne eine Hoster – sondern es ist ein 1:1 Sache – der ADMIN ders Backend betreut – u. dazwischen gibts keine weitere „Schicht“.

    wp-plugins-inactive (8)– werde ich rausnehmen.

    ich kümmer mcih also um die Befunde – insbes. zu den wp-Filesysteme-Rechte-Turbulenzen.
    Ich glaub dass das auch damit zu tun hat dass da die USER unterschiedlich sind –
    die Daten (files) die ich installiere – haben user x
    die uploads – z.b. auch die Medienfiles etc etx. haben glab ich dann alle(!) user y

    Das bringt m.E. vieles ins Wanken – und ist m.E. nicht überall so – also auf anderen SERVERN ists glaub ich anders. Ich kümmer mich hierum und meld mich dann wieder.

    vielen Dank und viele Grüße – Euer Forum -euer (DEIN) Support hier ist klasse!

    Viele Grüße
    STNabor 😉

    PS – ich versuch meine überbordenden Fragen zu kürzen und alles auf den Punkt zu bringen. Und ja: ich will von Euch keinen Support für fremde Themes – denke aber dass ich hier ein ziemlich grundsätzliches Problem hab…

    Thread-Ersteller stnabor

    (@stnabor)

    hier nochmals Bego Mario Garde, hallo @all,

    nochmals hier eine kleine Rückmeldung: Also der Befund – die fehlenden (auch (!!) automatischen) Uploadmöglichkeiten, die wir oben besprochen haben.
    Diese betreffen ja im Grunde alle möglichen Situationen. Hier gehts also ums Allgemeine – nicht nur um ein Theme – oder gar um ein spezielles Theme.
    Ergo hier nochmals ein Beitrag von mir, um nachzufragen ob ich alles verstanden richtig verstanden habe?!

    Ich hatte in den vergangenen Wochen mich nicht so ausgiebig darum kümmern. Doch nun nehme ich die Arbeit wieder auf und kümmere mich darum. Auch werde ich mit dem Server-Admin reden um die Probleme rasch in den Griff zu bekommen.

    Hier ein kleiner Extra-Beitrag – um das Ganze nochmals kurz zusammenzufassen – und um nachzufragen, ob ich das alles richtig verstanden habe!?

    …vorausgeschickt – ich hab hier eben auch (!!!) ein Serverproblem: Der Server er läuft nicht optimal. Es fehlen diverse Dinge.
    – a. diverse Plugins im Apache: (siehe unten)
    – b. der Basis-Setup: – die Server-ist so eingestellt, dass die automat. Update (eben) nicht(!!) funktioniert.

    vgl hier dieses Bild – mit dem FTP-Upload-Dialog:

    Das Setting-Problem-Symptom: ein automatischer Upload/update ist nicht möglich: das hängt mit dem Setting (und dem FTP-Basiseinstellungen im Backend) zusammen: Anm.: es tritt normalerweise immer dann auf, wenn man sich auf Shared Hosting befindet und wenn WordPress einen Konflikt mit Berechtigungen und Eigentumsrechten (also Owner). Hier erfüllt mein Server also bestimmte Voraussetzungen nicht, gewissermaßen „WordPress-Konventionen“, die eine Support und leichten Betrieb unterstützen – und eben darüber hinaus auch sicherheitsrelevant sind – denn ein aktueller Code in Plugin, Theme usw. bedeutet auch ein Gewinn an Sicherheit.

    …und nochmals hier zum Ganzen:…also wir haben die diversen Probleme festgestellt:

    zu a. diverse Plugins im Apache: (siehe unten) vgl. der Site-Health-Bericht: er hat u. a. folgende Befunde:

    …. maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).
    Warning The optional module, curl, is not installed, or has been disabled.
    Warning The optional module, exif, is not installed, or has been disabled.
    Warning The optional module, imagick, is not installed, or has been disabled.
    Warning The optional module, zip, is not installed, or has been disabled.
    Warning The optional module, intl, is not installed, or has been disabled.

    Dieser Zwischenbefund, dieser Befund fehlender Plugins, der ist ja sicher auch ein Manko:
    Wie bereits oben gesagt: ich verwende einen SFTP-Client (und Protokoll) um WordPress-plugins zu installieren. In dem Plugin-Dialog hab ich aber lediglich FTP für den installationsdialog. Klar bekomme ich dann die Fehler;

    Zitat: Failed to connect to FTP Server http://www.xxxxx.com:21
    Gab es mal die Möglichkeit die Worpress–Upgrade-Einstellungen so zu wählen, dass hier auch ein SFTP-Client damit klar kommt? Ich hab hier schon mal kursorisch durchgesehen: https://wordpress.org/support/article/editing-wp-config-php/#wordpress-upgrade-constants

    …und nun das aktuelle Thema: …ich hab schon geöhrt, dass es in einigen Fällen vorkommt, dass man WordPress und die Plugins nicht auf eine neuere Version aktualisieren/aktualisieren kann, wenn man die FTP -Verbindungsinformationen nicht angibt. Das hiermit verbundene Problem ist jenes, dass das WordPress-System nicht direkt in den /wp-content-Ordner schreiben kann.

    und hier hab ich von mehreren Ansätzen gehört, die diesem Problem abhelfen:

    Workaround 1: man kann als Workaround hier die FTP-Details in der wp-config.php-Datei definieren, damit sich WordPress dann immer daran erinnert.
    Alternativ dazu kann man aber auch WordPress Schreibzugriff auf den /wp-content-Ordner gewähren, indem man auf die FTP-Stammdatei zugreift und die Ordnerdateiberechtigung (CHMOD) auf 775 anstelle der Standardwerte 755 und 644 ändert.

    Workaround 2: ein weiterer Weg, damit umzugehen; man kann alternativ auch die Konstante FS_METHOD in der wp-config.php-Datei definieren.
    Damit umgeht man die wiederkehrenden Eingabeaufforderungen von WordPress und ermöglicht automatische Aktualisierungen der Dateien.
    Und dafür ist im Grunde nur eine einzige Codezeile erforderlich.

    Der Vorgang: Wie man SSH ohne Passwort in den Server einfügt:

    1. Öffne /wp-config.php:
    als erstes die Datei wp-config.php aus dem WordPress-Stammordner öffnen.
    im Installationsordner befindet sich die Datei unter wordpress/wp-config.php

    2. dann kann man die FS_METHOD einbauen bzw. einfügen:
    Also man kann dann den Codeschnippel in die wp-config.php-Datei einbauen, vorzugsweise direkt unter jeder zweiten Codezeile.

    define('FS_METHOD','direct');
    
    FS-Methode

    3. danach kann man alles speichern und hochladen:
    diesen obigen einzeiligen Code – den kann man dann WordPress-Stammordner auf den Server hochladen:
    Dann sollte es praktisch funktionieren. Das Hochladen kann direkt vom Host Control Panel aus erfolgen.

    Fazit: Das FTP-Problem – es tritt normalerweise immer dann auf, wenn man sich auf Shared Hosting befindet und wenn WordPress einen Konflikt mit Berechtigungen und Eigentumsrechten (also Owner-Rechten) hat. Mit dieser „direkten“ Methode kann man WordPress- und Plugin-Installationen auf neuere Versionen aktualisieren oder upgraden, ganz ohne FTP-Details angeben zu müssen.

    Also, hier dieser ein Beitrag – er diente dazu, um das Ganze nochmals kurz zusammenzufassen – und um nachzufragen,
    ob ich das alles richtig verstanden habe!?

    Stimmt es denn tatsächich, dass ich mit diesem Workaround so zurechtkomme und damit ( also mit dem Umstellen auf FS-Method im Config-File ) dieser
    WordPress Anforderung entgegenkommen – und so also dem automatischen Upload von Plugins, Themes auf diese Weise hinbekomme!?#

    Ich werde das dann machen.

    Ferner werden wir hier auch die Module hier noch installieren und den Server entsprechend einrichten

    .... maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).
    Warning The optional module, curl, is not installed, or has been disabled.
    Warning The optional module, exif, is not installed, or has been disabled.
    Warning The optional module, imagick, is not installed, or has been disabled.
    Warning The optional module, zip, is not installed, or has been disabled.
    Warning The optional module, intl, is not installed, or has been disabled. 

    Freue mich, von Euch zu hören.

    Viele Grüße
    STNabor

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von stnabor.

    Hab mir nun nicht die Mühe gemacht alles nochmal zu lesen aber:

    Wenn dein Admin die fehlenden PHP Module nachinstalliert, kann er auch den Datei Besitzer (owner) für alle Dateien und Ordner in deinem www-root Ordner auf den PHP Prozess Owner ändern. Dann kannst du dir irgendwelche workarounds mit ssh und wp-config konstanten sparen…

    Webserver (php) Prozess Owner = File owner und alles ist tutti!

    Thread-Ersteller stnabor

    (@stnabor)

    Hallo und guten Abend, 😉

    der Vollständigkeit halber melde ich mich nochmals: Danke nochmals, Bego Mario Garde und auch Miche91.
    Insbes. die neueste Rückmeldung ist klasse – trifft m.E. auch ins Schwarze: Danke dir @michi91 für die Mühe des Durchlesens und deine Rückmeldung. Denke, dass du in allen Punkten Recht hast: ich kontaktiere, den Serveradmin.

    Hab das nochmals kurz nachvollzogen und z.B. die Logfiles dazu rausgesucht – zum Vorgang, dem Uploadversuch der Files. Ferner hab ich nochmals den Site-Health-Status angeschaut. So kann das wohl nicht funktionieren.

    Die Befunde:

    a. ich hab die unterschiedlichen Owner, wie wir sehen:

    a1. tmp-folder:

    a2. wp-content:

    ferner – was die Plugins anbelangt die mir (entsprechend dem Site-Health-Status) fehlen: die neueren Errorlogs – wenn ich versuche, den Upload des Demo-Pakets (wie ganz oben) vorzunehmen:

    [Mon Apr 04 16:48:49.309590 2022] [php7:notice] [pid 4872] [client meine_IP_Adresse:52370] PHP Notice:  ob_end_flush(): failed to send buffer of zlib output compression (1) in /sites/www.job-starter.com/wp-includes/functions.php on line 5212, referer: https://www.job-starter.com/wp-admin/plugins.php
    [Mon Apr 04 16:48:49.309618 2022] [php7:notice] [pid 4872] [client meine_IP_Adresse:52370] PHP Notice:  ob_end_flush(): failed to send buffer of zlib output compression (1) in /sites/www.job-starter.com/wp-includes/functions.php on line 5212, referer: https://www.job-starter.com/wp-admin/plugins.php

    und das scheint konsistent mit dem Site-Health-Status zu sein, den ich auch schon weiter oben erwähnt hab:

    ,….vgl. zu a. diverse Plugins im Apache: (siehe unten) vgl. der Site-Health-Bericht: er hat u. a. folgende Befunde:

    …. maintains a list of those modules, both recommended and required, in the team handbook (opens in a new tab).
    -Warning The optional module, curl, is not installed, or has been disabled.
    -Warning The optional module, exif, is not installed, or has been disabled.
    -Warning The optional module, imagick, is not installed, or has been disabled.
    -Warning The optional module, zip, is not installed, or has been disabled.
    -Warning The optional module, intl, is not installed, or has been disabled.

    Denke, dass ich also alle o.g. Plugins im PHP-Setup (des Apache) brauche.

    Ferner gibt es noch die Probleme:

    b. die Ownwerships auf files & Folder: Die Ordner die nicht schreibbar sind:
    - wp-content: not writable

    c. auch post_max_size is smaller than upload_max_filesize: The setting for post_max_size is smaller than upload_max_filesize, this could cause some problems when trying to upload files.

    d. last but not least hab ich auch noch SQL-Probleme:- entsprechend dem Site Health-Status- Outdated SQL server :: Performance

    The SQL server is a required piece of software for the database WordPress uses to store all your site’s content and settings.
    For optimal performance and security reasons, you should consider running MySQL version 5.6 or higher. Contact your web hosting company to correct this.

    e. Einer der Workarounds des letzten Monats, um das zu beheben bestand darin.

    e 1. ein XMLFile hochzuladen – ohne Erfolg – wohl aus Gründen a bis d. b. ein zweiter,
    e 2. darin einen DB-Dump einzupflegen – um diese Theme-Settings eben auf diese Weise einzupflegen: Da hatte ich dann Collat-Prolbleme

    Die Datenbank kann z.B. u. a. mit utf8mb4_unicode_520_ci nichts anfangen: Nehme also an, dass jede Version grösser als 10.3 das können müsste: ( vgl. auch https://manjaro-forum.de/viewtopic.php?t=3841 )

    Nebenbei: weil ich zwischendurch mal die Workarounds angesprochen habe: Hierzu noch ein kleiner Zusatz: What security concerns should I have when setting FS_METHOD to „direct“ in wp-config?
    https://wordpress.stackexchange.com/questions/189554/what-security-concerns-should-i-have-when-setting-fs-method-to-direct-in-wp-co

    I have recently had an issue where I have been unable to install the WP Smush Pro plugin because I don’t have the Manual Install or One-Click Installation options available.

    I came across this post ( https://www.narga.net/stop-fix-wordpress-ask-for-ftp-credentials-upgrade-install-delete-themes-plugins/ ) which suggested tweaking the settings in wp-config.php. I added the settings suggested, however the one that seems to be the most important is:

    define('FS_METHOD', 'direct');

    What I would like to know is what real concerns should I have around setting FS_METHOD to direct? Are there any other alternatives to installing the plugin?
    This is what the official documentation has to say:
    FS_METHOD forces the filesystem method. It should only be „direct“, „ssh2“, „ftpext“, or „ftpsockets“. Generally, you should only change this if you are experiencing update problems. If you change it and it doesn’t help, change it back/remove it. Under most circumstances, setting it to ‚ftpsockets‘ will work if the automatically chosen method does not.
    (Primary Preference) „direct“ forces it to use Direct File I/O requests from within PHP, this is fraught with opening up security issues on poorly configured hosts, This is chosen automatically when appropriate.

    This is just, how I understood the idea of the WordPress File API. If it is wrong, please downvote 🙂
    Okay. If you upload a file, this file has an owner. If you upload your file with FTP, you login and the file will be owned by the FTP user. Since you have the credentials, you can alter these files through FTP. The owner can usually execute, delete, alter etc. the file. Of course, you can change this by changing the file permissions.
    If you upload a file using PHP, the linux user, which is executing PHP is owning the file. This user can now edit, delete, execute etc. the file. This is okay as long as only you are the user, who is executing PHP on your system.
    Lets assume, you are on a „poorly“ configured shared host. A lot of people run their PHP websites on this system. Lets say only one linux user is executing PHP for all these people. One of the webmasters on this shared host has bad intentions. He sees your page and he figures out the path to your WordPress installation. For example, WP_DEBUG is set to true and there is an error message like

    [warning] /var/www/vhosts/userxyz/wp-content/plugins/bad-plugin/doesnt-execute-correctly.php on line 1

    „Ha!“ the bad boy says. Lets see, if this guy has set FS_METHOD to direct and he writes a script like

    <?php
    unlink( '/var/www/vhosts/userxyz/wp-content/plugins/bad-plugin/doesnt-execute-correctly.php' );
    ?>

    Since only one user is running PHP and this user is also used by the bad boy he can alter/delete/execute the files on your system if you have uploaded them via PHP and by this attached the PHP user as the owner.

    Or, as it says in the Codex:
    Many hosting systems have the webserver running as a different user than the owner of the WordPress files. When this is the case, a process writing files from the webserver user will have the resulting files owned by the webserver’s user account instead of the actual user’s account. This can lead to a security problem in shared hosting situations, where multiple users are sharing the same webserver for different sites.

    Diesen kl. Thread wollte ich hier nicht vorenthalten: Er ist u. a. auch sehr interessant – hatte ich doch überlegt – nach den ganzen Versuchen – mit diesem SFTP VS. FTP-Workaround noch anzufangen. https://wordpress.stackexchange.com/questions/189554/what-security-concerns-should-i-have-when-setting-fs-method-to-direct-in-wp-co

    Fazit: ich denke, dass die Errors z.T. am momentanten Setup liegen – und dass da schon hillfreich ist wenn die Plugins ins PHP eingebunden werden – und andere Kleinigkeiten noch dazukommen.
    Dann sollte das schon funktionieren.

    Wollte Euch diese zusammengestellten Befunde noch kurz schildern – es ist hier (für mich jedenfalls- hilfreich, das Festgestellte aufzuschreiben – und ggf. hilfts ja auch jemand anderen, der in eine ähnliche Situation kommt. Ich melde mich final – wenn ich nächstens noch mehr sagen kann, und das Problem dann ganz behoben ist – noch einmal kurz.

    Euch allen nochmals vielen Dank für den durchehaltenen Support und Eure Hilfe. Das Forum hier ist einfach eine supertolle Einrichtung.

    Viele Grüße
    STNabor

    Ist denn die ursprüngliche Frage für dich beantwortet?
    Dann wäre es nett, wenn du den Thread als „gelöst“ markierst.
    Falls nicht, schreib bitte, womit wir dir ganz konkret helfen können – wenn’s geht, in zwei, drei Zeilen.

    Thread-Ersteller stnabor

    (@stnabor)

    Hallo und guten Morgen @pixolin

    vielen Dank für deine Rückmeldung. Freue mich. 😉

    Da mein Server-Admin sich gemeldet hat und sich nun an die diversen Änderungen macht wollt ich das aufs „Gelöst-setzen“ noch abwarten.

    Es geht, wie oben beschrieben, um das Nachinstallieren der Module (s.o.) u. um ein paar weitere Dinge wie Dateien mit unterschiedl Besitzer (owner) für alle Dateien und Ordner
    im www-root Ordner bzw dem PHP Prozess Owner ändern.

    ferner – was die Plugins anbelangt die mir (entsprechend dem Site-Health-Status) fehlen: die neueren Errorlogs – wenn ich versuche, den Upload des Demo-Pakets (wie ganz oben) vorzunehmen:

    [Mon Apr 04 16:48:49.309590 2022] [php7:notice] [pid 4872] [client meine_IP_Adresse:52370] PHP Notice:  ob_end_flush(): failed to send buffer of zlib output compression (1) in /sites/www.job-starter.com/wp-includes/functions.php on line 5212, referer: https://www.job-starter.com/wp-admin/plugins.php
    [Mon Apr 04 16:48:49.309618 2022] [php7:notice] [pid 4872] [client meine_IP_Adresse:52370] PHP Notice:  ob_end_flush(): failed to send buffer of zlib output compression (1) in /sites/www.job-starter.com/wp-includes/functions.php on line 5212, referer: https://www.job-starter.com/wp-admin/plugins.php


    und das scheint m.E. auch iwie konsistent mit dem Site-Health-Status zu sein, den ich auch schon weiter oben erwähnt hab und der folgende Module
    als fehlend moniert; curl, exif, imagick, zip, intl,

    Ferner gibt es noch die Probleme: c. auch post_max_size is smaller than upload_max_filesize: The setting for post_max_size is smaller than upload_max_filesize, this could cause some problems when trying to upload files.

    d. last but not least hab ich auch noch SQL-Probleme:- entsprechend dem Site Health-Status- Outdated SQL server :: Performance

    The SQL server is a required piece of software for the database WordPress uses to store all your site’s content and settings.
    For optimal performance and security reasons, you should consider running MySQL version 5.6 or higher. Contact your web hosting company to correct this.

    Will diese Änderungen gern noch abwarten – und dann gegen Wochenende hier final Resultate posten.

    Euch nochmals vielen Dank für dieses tolle Forum und euren unermüdlichen und tollen Einsatz. Bin sicher dass das Forum hier auch vielen vielen anderen hilft,
    denn es stecken in den vielen Threads superviele Lösungen drinne für viele Themen rund um WP.

    ich melde mich also gegen Wochenende wieder.

    Danke @ all für Eure tolle Arbeit 😉

    Thread-Ersteller stnabor

    (@stnabor)

    Hallo @pixolin, hallo @michi91

    nochmals vielen vielen Dank für Euren nachhaltigen Support.

    entscheident ist dieser Eintrag in die Konfigurationsdatei:

    define('FS_METHOD','direct');

    vgl.

    nun geht nicht nur der Upload der Theme-Demos –

    nebenbei – mit einer ganzen Menge an Daten-
    Anm.; dass das ein oder andere nicht hochgeladen wurde – scheiterte, das liegt lediglich daran, dass für ein paar Einträge Dublikate entdeckt wurden – bzw. dass eben in manchen Kategrien bereits schon Einträge vorhanden waren

    Das gleich ich am Wochenende noch aus – in dem ich hier alles zurücksetze und alles frisch mache.

    Mein Server-Admin hat die max_execution_time moch etwas ausgebaut –

    Alles läuft nun problemlos und ja: ich kann auch jetzt Updates von Plugins usw. usf durchführen.
    alles problemlos . Das konnte ich früher auch nicht..

    Vielen Dank für Euren tollen Support, Eure Geduld und alles was ihr hier tut.
    Macht bitte weiter so! Euer Forum hier ist einfach superklasse!!

    Ich markiere den Thread als geloest 😉

    Dank meines Server-Admins – und auch dank Euch.

    viele Grüße
    STNabor 😉

    ps:die max_execution_time wurde auch noch etwas hochgesetzt;)`

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)