Support » Allgemeine Fragen » Automatisches Aktualisieren von internen Verlinkungen?

  • Sehr geehrte Damen und Herren,

    ich habe sehr viele interne verlinkungen auf meinen Seiten, wenn ich den Namen der verlinkten Seite ändere, dann wird aber die Verlinkung nicht geändert, also der Link bleibt gleich und bei einem Klick auf den Link öffnet sich eine 404 Seite, daher stellt sich mir die Frage, ob es eine Möglichkeit gibt, dass die internen Verlinkungen automatisch aktualisiert werden, wenn sich die URL der verlinkten Seite ändert?

    Ich hoffe ich konnte meine Frage verständlich übermitteln, über eure Hilfe würde ich mich sehr freuen.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • ob es eine Möglichkeit gibt, dass die internen Verlinkungen automatisch aktualisiert werden

    wüsste ich jetzt mal nicht.

    Aber du kannst mit https://wordpress.org/plugins/better-search-replace/ versuchen, alle, nun falschen Links zu finden und mit den korrekten zu ersetzen.

    Vorher sicherheitshalber ein Backup, zumindest der Datenbank, machen!

    Hallo,
    ich habe das gerade mal auf einer lokalen WordPress-Instanz getestet: Tatsächlich scheint es so zu sein, dass man die internen Links nicht anpassen muss. Das scheint automatisch zu erfolgen (im Grunde wie ein Redirect).

    Ich habe auf einer Seite einen internen Link zu einer Seite der gleichen Domain erstellt, dann habe ich den Permalink dieser verlinkten Seite geändert. Der Link funktionierte trotzdem. Warum das bei dir nicht funktioniert, kann ich nicht sagen oder habe ich das Problem nicht richtig verstanden?

    Hilfreich für eine weitere Analyse wäre der Website-Bericht:
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):
    Website-Bericht

    Und mit z. B. STRG V in die Antwort bei diesem Thema einfügen.`

    Viele Grüße
    Hans-Gerd

    Tatsächlich scheint es so zu sein, dass man die internen Links nicht anpassen muss.

    Vllt. kommt das auf die Art darauf an, wie die Linkstruktur ist?
    Also was man in Einstellungen › Permalinks eingestellt hat.
    Wenn man mit IDs fährt (Option „Einfach“), wird das ändern eines Namens einer Zielseite/beitrag nichts machen, andernfalls … hmm muss ich auch mal testen …

    @kurapika
    FYI: ich habe mir das gerade noch mal angesehen. Das hat bei gleicher Einstellung für die Permalink-Struktur (Beitragsname) auf einer lokalen Website mit dem Theme TT4 funktioniert. Auf einer anderen WordPress-Instanz mit vielen Plugins, die ich da teste (34 aktiv, 34 inaktiv) und GeneratePress als Theme funktioniert das nicht. Ich bin mir allerdings nicht sicher, ob es mit einem Plugin zusammenhängt.

    Wenn ich Zeit habe, werde ich mir das noch mal genauer ansehen.

    Insofern könnte der Website-Bericht von @bavc98 interessant sein. Ich gehe davon aus, dass @bavc98 ein Backup vor den folgenden Maßnahmen erstellt hat, das auf jeden Fall wiederhergestellt werden kann.

    Dann könnte man dem Problem auf die Spur kommen, wenn zunächst alle Plugins deaktiviert werden und dann Plugin für Plugin aktiviert wird. Danach muss jeweils getestet werden, ob das Problem behoben ist. Sobald es dann nach Aktivierung eines Plugins das beschriebene Problem gibt, ist klar, welches Plugin das Problem verursacht.

    Viele Grüße
    Hans-Gerd

    Bei mir funktioniert das alles mit jedem Permalink Schema, mit jedem Theme, jeder Menge Plugins (47 inst. /testweise alle aktiviert), mit Seiten und Beiträgen.
    WP aktualisiert die Menüs stets brav, findet alles immer, egal wie viel man umbenennt.

    Aber ohne Bericht kann man halt nur rätseln, wer oder was diese automatische Anpassung der Menüs verhindert, bzw. beeinflusst …

    Thread-Starter bavc98

    (@bavc98)

    @hage

    Ich habe mir das Ganze noch einmal angesehen, nun habe ich herausgefunden, dass die Hyperlinks im Frontend doch angepasst werden.
    Komischerweise wird im Backend jedoch der alte Link angezeigt, ist das bei dir auch so?

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von bavc98.

    @bavc98

    Komischerweise wird im Backend jedoch der alte Link angezeigt, ist das bei dir auch so?

    ja, soweit ich mich erinnere war das auch der Fall. Wenn ich Zeit habe, schau ich mir das in den nächsten Tagen auch noch mal in Ruhe an. Sieht fast auch, als würde das wie ein Redirect behandelt.

    Thread-Starter bavc98

    (@bavc98)

    @hage

    Ja, ist auch sinnvoll, sonst hätte man bei Linkänderungen ständig Probleme. 🙂

    • Diese Antwort wurde geändert vor 2 Monaten, 2 Wochen von bavc98.

    @bavc98

    Ja, ist auch sinnvoll, sonst hätte man bei Linkänderungen ständig Probleme.

    Ständig eher nicht, denn sowohl bei @kurapika als auch bei mir taucht das Problem nur in bestimmten Fällen auf. Insofern stellt sich die Frage, ob nicht irgendein Sachbestand (Plugin, Einstellung, Theme, etc.) das Problem verursachen.
    Insofern wäre der Website-Bericht von dir interessant.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)