Support » Allgemeine Fragen » Automatisches Backup eines Beitrags

  • Hi,

    ich schreibe einen neuen Artikel für meine WordPress-Seite, speichere ihn und wieder über den „Speichern“-Button ab und trotzdem erscheint andauernd oberhalb des Beitrages die Hinweisbox:

    Das Backup dieses Beitrags in deinem Browser unterscheidet sich von der unten stehenden Version. Das Backup wiederherstellen

    Es nervt mich mittlerweile so sehr, dass ich diesen Thread eröffne. Ich SPEICHERE den Beitrag bewusst ab, ich habe seit Beginn des Schreibens des Artikels keinen Tab gewechselt, nichts sonst gemacht, nur hin und wieder manuell gespeichert. Klicke ich (einfach nur testweise) mal auf „Das Backup wiederherstellen“, so handelt es sich beim „automatisch gesicherten“ Beitrag stets um einen Beitrag in einem früheren Zustand – also NICHT aktueller als der Beitrag, den ich gerade eben noch manuell selbst gespeichert habe. Nochmal: Der Beitrag ist NUR in diesem einen meinem Tab geöffnet, nirgendwo sonst. Es gibt auch keine weiteren Nutzer in meinem WordPress.

    Wozu soll diese Funktion denn dienen? Sollte das Backup nicht eher schauen, ob MEIN aktuell bearbeiteter Beitrag AKTUELLER ist als der automatisch gesicherte und sich höchstens DANN melden, wenn es wirklich ein Problem gibt?

    Bei mir tritt es automatisch auf. Neuer Artikel, ich schreibe was, speichere ab, schwupp: Hinweisbox, das Backup dieses Beitrags in meinem Browser unterscheide sich von meiner unten stehenden Version.

    Es nervt so sehr. Deaktivieren möchte ich es dennoch nicht, einfach für den Fall eines Absturzes – aber es sollte doch möglich sein, dass nicht nur geschaut wird, ob sich die automatisch gesicherte Version „unterscheidet“ (das tut sie ja wohl zwangsläufig, sobald ich auch nur einen einzigen neuen Buchstaben schreibe???), sondern welche Version offenbar die aktuellere ist?!

    Any ideas?

    Gruß

    PS: WIESO werden meine harmlosen Beiträge immer erst mal als „SPAM“ markiert und müssen freigeschaltet werden!?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)
  • Hallo,
    ohne entsprechende Infos bezogen auf deine Website können wir dir wohl kaum helfen. Ich habe das Problem bei unseren Projekten nicht.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    PS: WIESO werden meine harmlosen Beiträge immer erst mal als „SPAM“ markiert und müssen freigeschaltet werden!?

    Das kann ich dir nicht sagen – Akismet hält diesen Beitrag zurück und im Dashboard des Forums konnte ich nicht feststellen, dass deine Beiträge „immer“ erst als Spam markiert werden.

    Viele Grüße
    Hans-Gerd

    Thread-Starter dajanas

    (@dajanas)

    Hi, ja, die Seite „Website-Zustand“ kenne ich und dort ist alles in Ordnung. Nur Hinweis auf WP 6.0 und der übliche Hinweis, inaktive Plugins sollten entfernt werden, erscheint.

    
    ### wp-core ###
    
    version: 5.8.4
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 3 (nutze nur ich selbst)
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /is/htdocs/doesnotmatter
    wordpress_size: doesnotmatter
    uploads_path: /is/htdocs/doesnotmatter
    uploads_size: doesnotmatter
    themes_path: /is/htdocs/doesnotmatter
    themes_size: doesnotmatter
    plugins_path: /is/htdocs/doesnotmatter
    plugins_size: doesnotmatter
    database_size: doesnotmatter
    total_size: doesnotmatter
    
    ### wp-dropins (3) ###
    
    advanced-cache.php: true
    db.php: true
    object-cache.php: true
    
    ### wp-active-theme ###
    
    name: DOESNOTMATTER (doesnotmatter)
    version: 20.1
    author: DOESNOTMATTER
    author_website: doesnotmatter
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, post-thumbnails, menus, widgets, widgets-block-editor
    theme_path: /is/htdocs/doesnotmatter
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (1) ###
    
    Twenty Twenty-One: version: 1.6, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (9) ###
    
    410 for WordPress: version: 0.8.7, Automatische Aktualisierungen deaktiviert
    ACF Content Analysis for Yoast SEO: version: 3.0.1, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6.2, Automatische Aktualisierungen deaktiviert
    Classic Widgets: version: 0.3, Automatische Aktualisierungen deaktiviert
    jQuery Updater: version: 3.6.0.2, Automatische Aktualisierungen deaktiviert
    Ninja Forms: version: 3.6.11, Automatische Aktualisierungen deaktiviert
    W3 Total Cache: version: 2.2.1, Automatische Aktualisierungen deaktiviert
    WP Crontrol: version: 1.12.1, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 19.1, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Contextual Related Posts: version: 3.2.3, Automatische Aktualisierungen deaktiviert
    
    ### wp-server ###
    
    server_architecture: Linux 4.14.132-xenu-he x86_64
    httpd_software: Apache
    php_version: 7.4.30-he.0 64bit
    php_sapi: apache2handler
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-41-log
    client_version: mysqlnd 7.4.30-he.0
    
    ### wp-constants ###
    
    WP_HOME: doesnotmatter
    WP_SITEURL: doesnotmatter
    WP_CONTENT_DIR: /is/htdocs/doesnotmatter
    WP_PLUGIN_DIR: /is/htdocs/doesnotmatter
    WP_MEMORY_LIMIT: 256M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: false
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Hast du das Problem auch wenn du einen anderen Browser nutzt?!

    Hallo,
    das Theme „DOESNOTMATTER“ kenne ich nicht 😉
    Warum du das nicht nennen willst, ist mir schleierhaft. Nun gut …

    W3 Total Cache macht schon mal Probleme. Ich nutze das Plugin nicht, sondern als kostenpflichtiges Plugin WP Rocket bei einigen Projekten und ansonsten als kostenfreie Plugins Comet Cache oder WP Fastest Cache.

    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Anschließend kannst du unter Werkzeuge > Website Zustand unter Problembehandlung auf den Button „Problembehandlungsmodus aktivieren“ klicken. Dann werden alle Plugins deaktiviert und als Standardtheme z. B. Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme von dir und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und Plugins sieht, während nur für dich alle Plugins deaktiviert sind.

    Hast du auch mal getestet, ob das Problem auftaucht, wenn du statt des Classic Editors den Block Editor verwendest?
    Außerdem würde ich auf WordPress 6.0 updaten – aber das weißt du sicher selbst und wirst Gründe dafür haben, warum du bisher nicht upgedatet hast.

    Viele Grüße
    Hans-Gerd

    Thread-Starter dajanas

    (@dajanas)

    @hage Überall, wo ich „doesnotmatter“ geschrieben habe, möchte ich Details privat halten. Das Theme, was ich nutze, ist mein eigenes Theme, das gibt es offiziell nirgendwo so. Meine Webseite ist seit vielen Jahren online, das Problem mit den Backups ist mir erst kürzlich aufgefallen – vielleicht durch irgendein WordPress-Update? Wobei ich noch nicht auf 6.0 umgestiegen bin.

    Einen anderen Browser als Chrome habe ich bislang dahingehend noch nicht ausprobiert, werde ich mal testen.

    Mit W3 Total Cache habe ich gute Erfahrungen gemacht, nutze ich seit mittlerweile fast 10 Jahren (natürlich mit Updates). Funktioniert einwandfrei.

    Den Block Editor verwende ich nicht, weil mein Backend so aufgebaut ist, wie ich es ursprünglich haben wollte (redaktionell organisiert). Mit dem Block Editor kann ich da nichts anfangen, auch weil ich manche ACF (Advanced Custom Fields) nutze, Seitenleisten usw. Den Block Editor finde ich dahingehend schrecklich 😉 Es ist nicht nur ein „einfacher“ Blog, sondern schon im Bezug auf den redaktionellen Aspekt in einem bestimmten Bereich anspruchsvoll, was die Struktur angeht und das schlussendliche Frontend. Das kann mir der Block Editor aktuell so nicht bieten, es sei denn, ich investiere Monate, um die gesamte Seite umzubauen.

    Die einzelnen Plugins hatte ich sogar so schon deaktiviert/aktiviert und es ausprobiert. Keine Änderung. Ich weiß nicht, warum „der Browser“ da Backups generiert. Von mir aus könnte man die Funktion auch vollständig deaktivieren – die „Revisionen“ habe ich schon lange per wpconfig.php abgestellt. Die automatischen Backups brauche ich auch nicht, da ich regelmäßig Beiträge speichere – wenn nicht und der PC abstürzt: Pech gehabt. Aber diese ständige Meldung bei jedem Speichern, dass die beiden Versionen sich unterscheiden, nervt sehr 🙂

    @dajanas

    Den Block Editor finde ich dahingehend schrecklich 😉

    das fand ich am Anfang auch – mittlerweile finde ich den Block Editor richtig gut und setze den Block Editor fast ausschließlich ein.
    Es ging mir auch nicht darum, Überzeugungsarbeit zu leisten, sondern ich wollte nur anregen, einen Beitrag mit dem Block Editor zu erstellen, um zu testen, ob das Problem auch beim Block Editor auftaucht.

    Es ist nicht nur ein „einfacher“ Blog, sondern schon im Bezug auf den redaktionellen Aspekt in einem bestimmten Bereich anspruchsvoll, was die Struktur angeht und das schlussendliche Frontend.

    Also: wir betreiben ebenfalls zwei Projekte, die anspruchsvoll gestaltet sind. Das funktioniert mit dem Block Editor wunderbar.

    Aber diese ständige Meldung bei jedem Speichern, dass die beiden Versionen sich unterscheiden, nervt sehr 🙂

    Verstehe ich, aber ich wüsste nicht, wie wir dir hier weiterhelfen sollten, zumal uns nicht alle Daten des Berichts vorliegen, weil du der Meinung bist, dass diese Infos keine Rolle spielen. Das mag auch tatsächlich der Fall sein, kann ich allerdings nicht beurteilen.
    Auch die URL möchtest du wohl nicht nennen: Warum ein Link zu deiner Website wichtig ist.

    Hast du das Problem auch wenn du einen anderen Browser nutzt?

    Bevor du den Browser wechselst, gerne vorher schon jQuery Updater deaktivieren.

    Wenn das Problem dann auch im anderen Browser auftaucht, bitte mal in die developer tools / Konsole schauen ob dort Fehlermeldungen stehen.

    Überall, wo ich „doesnotmatter“ geschrieben habe, möchte ich Details privat halten.

    Widerspricht sich das nicht bei einer öffentlichen Internetseite?

    Thread-Starter dajanas

    (@dajanas)

    @bscu Nein, das ist kein Widerspruch. Ich will hier im Forum die Adresse meiner Seite nicht nennen.

    @dajanas … und was ist mit den anderen Vorschlägen ?

    Thread-Starter dajanas

    (@dajanas)

    @hage Haben nichts gebracht, am Theme liegt es auch nicht und es tritt ja auch erst seit ein paar Wochen auf. Ich kann nicht nachvollziehen, woran es liegt.

    Kann man diese automatischen Backups komplett deaktivieren? Ich brauche die nicht.

    An dieser Stelle ein freundlicher Hinweis:

    Da wir dir bei der Arbeit an deiner Website nicht über die Schulter schauen können, sind wir auf freiwillige Informationen angewiesen. Obwohl wir im angehefteten Beitrag Bevor du ein neues Thema (Thread) erstellst sehr genau beschrieben haben, welche Informationen wir benögtigen, hast du den Website-Bericht willkürlich gekürzt. Dass dir der Website-Zustand als „gut“ angezeigt wird, ist schön für dich – liefert uns aber überhaupt keine Anhaltspunkte, um dem Fehler nachzugehen. Dass du auch sonst erst auf weitere Rückfrage ein äußerst knappes Feedback („Haben nichts gebracht …“) gibst, ist auch nicht gerade hilfreich.

    In unseren FAQ haben wir beschrieben, wieso wie eine URL zur Website möchten (nicht aus Langeweile, sondern um bestimmte Dinge auslesen zu können), wie du Screenshots teilen kannst und welche Informationen wir benötigen. Die Informationen sind in Zusammenarbeit mit WordPress‘ internationalen Support-Team entwickelt worden, um notwendige Informationen zusammenzutragen und mehrfache Rückfragen zu vermeiden. Der Website-Bericht enthält keine kritischen oder persönlichen Informationen. Wir respektieren natürlich deine Entscheidung, keine Informationen zu teilen, können dir dann aber auch nur sehr begrenzt weiterhelfen.

    Wenn du nach Fehler suchst, solltest du als erstes alle Cache- und Optimierungs-Plugins deaktivieren, weil sie sonst bei Änderungen an der Website weiterhin einen zwischengespeicherten Stand zeigen können. Ob du das Cache-Plugin seit Jahren benutzt und keine Probleme damit hast, hat damit nichts zu tun.

    Updates liefern nicht nur neue Features, sondern dienen auch der Fehlerbehebung. Wenn du – trotz ausdrücklichem Hinweis auf eine neue Version – keine Aktualisierung vornimmst, können bereits bekannte und gefixte Fehler für deine Website auch nicht behoben werden.

    Du hast ein Problem mit deiner Website und niemand hier hat sich in irgendeiner Form verpflichtet dir zu helfen. Wenn du nur sehr eingeschränkt Informationen liefern möchtest, ist das OK. Wenn dir aber damit keiner helfen kann, ist das auch OK.

    Ohne weitere Informationen werden wir dir nicht weiterhelfen können.

    Vielleicht hilft der Hinweis auf Advanced Custom Fields Blocks weiter:

    https://wordpress.org/support/topic/the-backup-of-this-post-in-your-browser-is-different-from-the-version-below-9/

    Mit

    add_action('in_admin_footer', function(){
      remove_action('admin_footer', '_local_storage_notice');
    });

    sollte der Hinweis zumindest zu deaktivieren sein.

    Thread-Starter dajanas

    (@dajanas)

    @pixolin Okay, kein Problem. Es ist nun einmal so, dass der Bericht die komplette URL (und mehr) beinhaltet, die ich nicht mitteilen möchte, da ich meine Webseite schlichtweg nicht nennen möchte. Das wäre haargenau so wie wenn ich jedem hier sofort meinen Wohnort nennen würde. Es gilt Impressumspflicht. Und hier im Forum möchte ich anonym bleiben – das ist auch vollkommen in Ordnung so.

    Thread-Starter dajanas

    (@dajanas)

    PS: Vielen Dank für den Filter, den werde ich ausprobieren 🙂

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 15)