Support » Allgemeine Fragen » Backend: Menüeinträge hinzufügen wird nicht angezeigt

  • Hallo zusammen

    Ich habe zwei Administratoren angelegt im Backend. Beim einen wird im Menü „Design/Menüs“ alle möglichen Menüeinträge angezeigt, beim anderen fehlen alle WooCommerce Einträge. Der Administrator, unter welchem alle Menüpunkte angezeigt werden, ist der „Ur-Administrator“. Ich habe auch schon weitere Administratoren angelegt, die Menupunkte kommen aber auch dort nicht. Ich verzweifle 🙂 Hat allenfalls jemand eine Idee, woran das liegen könnte?

    Danke & LG
    Christof

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Mehr Infos – Mehr Ideen (bitte FAQ beachten)

    Hast du ein Plugin installiert/aktiv, welches die Rechte der Nutzer manipulieren kann?
    Z.B. „User Role Editor“?
    Wenn ja, dann könnte dort die Ursache oder eine Abhilfe zu finden sein.

    Andererseits kann auch WooCommerce Einstellungen haben, welche irgendwelche Nutzer von bestimmten Aktionen ausnimmt, weil … ja keine Ahnung.
    Admin = Admin sollte man meinen, aber vllt. wurde der 2. Admin erst angelegt, als WooCommerce schon (vom ersten, dem „Ur“-Admin) installiert war und nur diesem alle Rechte zubilligt.

    Aber was fehlt denn dem 2. Admin noch? Oder geht es nur um WooCommerce Einträge?

    PS: Ich habe das Shop-Plugin nicht und kenne es leider auch nicht mal ansatzweise.

    Hallo,
    lies doch bitte mal: Bevor du ein neues Thema (Thread) erstellst.

    Wenn du dann noch die URL oben einträgst, dann hilft uns das evtl. ebenfalls bei der Analyse.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 6 Monaten, 3 Wochen von Hans-Gerd Gerhards. Grund: Änderung und Ergänzung
    Thread-Starter christof1978

    (@christof1978)

    Betrifft das Backend der Website https://zumbasteltor.ch. Den Bericht möchte ich aus Sicherheitsgründen nicht öffentlich Posten.

    es fehlen nur woocommerce-einträge so wie ich das einschätze. es ist so, der neue admin wurde erst erstellt wurde, nachdem woocommerce installiert wurde.

    Plugin, welches was mit rechten zu tun haben könnte, kommt mir nur wordfence in den sinn, das ich installiert habe.

    Screenshot 1: Komplettes Menü / Screenshot 2 inkomplettes menü

    Den Bericht möchte ich aus Sicherheitsgründen nicht öffentlich Posten.

    Die Entwickler haben sich schon etwas dabei gedacht, den Website-Bericht zur Unterstützung von Fragen nicht nur hier im Forum mit einzubinden.
    Die Informationen in dem Website-Bericht sind unproblematisch, helfen uns aber sehr, Probleme bei einer Website wie in deinem Fall zu analysieren.

    Thread-Starter christof1978

    (@christof1978)

    da gehe ich nicht mit dir einig – wenn ich mir den bericht so anschaue, da sehe ich z.b. jedes plugin mit versionen, diverse user-mail-adressen, infos über das system und versionen – alles informationen, welche ausgenutzt werden können. ich gehe absolut mit dir einig, dass die informationen hilfreich sind, sollten aber in einen separaten container geladen werden können und bei bedarf freigeschaltet.

    Tja, dann scheinen wir an diesem Punkt angekommen zu sein:

    Kein Website-Bericht => keine Hilfe

    Aber vielleicht hast du ja Glück und es errät jemand eine Lösung, viel Erfolg.

    Sorry, aber dann werden wir Dir wohl nicht helfen können. Wir wissen ja noch nicht mal, welches Theme du verwendest und ob nicht irgendwelche Einstellungen dafür sorgen, dass das nicht angezeigt wird.

    Wenn das Woocommerce betrifft, dann solltest du dich in dem Fall direkt an den Supportbereich der Entwickler wenden. Möglichweise können die dir ohne Website-Bereicht helfen.

    Thread-Starter christof1978

    (@christof1978)

    Yep, mit denen bin ich parallel dran.
    Bitte nicht falsch verstehen – ich verstehe euren Standpunkt absolut, dass dies für die Analyse notwendig und wichtig ist. Ich bin aber auch der Meinung, dass die Security-Awareness höher zu gewichten ist – diese Informationen sind der erste Schritt für eine gezielte Attacke und ich wundere mich oft, wie leichtfertig mit Systeminformationen umgegangen wird.

    Yep, mit denen bin ich parallel dran.

    Auch das ist keine tolle Sache. Wenn du dort deine Frage postest, solltest du uns zumindest informieren (Crossposting).

    • Diese Antwort wurde geändert vor 6 Monaten, 3 Wochen von Hans-Gerd Gerhards. Grund: Tippfehler
    Thread-Starter christof1978

    (@christof1978)

    ich werde euch informieren, sobald ich eine lösung habe. es hätte ja durchaus sein können, dass ein leser dasselbe phänomen auch bereits hatte und dies schon mal beheben konnte.

    nichtsdestotrotz danke ich euch.

    Ähem, @christof1978 du kannst das ruhig hier hereinstellen und die (für dich heiklen) Passagen, die du gefunden hast, einfach löschen oder verändern.
    Wobei ich noch keine Mailadressen, Benutzernamen oder gar Passwörter da drin sah.

    Und: Wer sich wirklich für die Innereien deiner Site interessiert um Schaden anzurichten, der oder die kennen da unglaubliche Trick, um die Infos zu bekommen.
    Versionsinfos zu Plugins usw. sind da nur eine Kleinigkeit.

    Aber Vorsicht ist immer gut und ich bin der letzte der solche Infos leichtfertig herausgeben mag. Zumal es manche Verträge mit „meinen“ Betreibern verbieten. Manche wollen nicht mal, dass die URL öffentlich gepostet wird. Nonsens, aber was soll man machen?

    Ergo: Poste diesen Bericht, es passiert nix außer das vllt. eine Lösung bei rauskommt …

    @christof1978

    Unsererseits kann dir nicht geholfen werden, da wir die benötigten Informationen von dir nicht erhalten werden. Daher schließe ich den Thread.

    Du kannst einmal in unser FAQ schauen, dort findest du eine Art Troubleshooting-Guide. Teste die für dein Problem relevanten Punkte nacheinander durch. Wie erwähnt, mehr können wir leider nicht für dich tun.

    Ich bin aber auch der Meinung, dass die Security-Awareness höher zu gewichten ist – diese Informationen sind der erste Schritt für eine gezielte Attacke

    @bscu hatte bereits darauf hingewiesen, aber weil schnell ein falscher Eindruck entsteht, möchte ich nochmal darauf hinweisen, dass der Website-Zustandsbericht vom internationalen WordPress-Support-Team erstellt und erst nach einer weiteren, sehr sorgfältigen Prüfung in den WordPress-Core übernommen wurde. Die Daten, die in diesem Bericht zusammengestellt werden, sind nicht sicherheitsrelevant.

    Unsere Hilfe im Supportforum ist keine individuelle Dienstleistung, die wir nur nicht abrechnen, sondern soll möglichst vielen in der WordPress-Community bei ähnlichen Problemen helfen. Im Idealfall lernen Anwender/-innen anhand der geschilderten Probeme, sich selbst zu helfen.
    Dabei macht der Wunsch, Basis-Informationen zur Website (die sich oft mit erheblich mehr Aufwand auch in anderer Form abrufen lassen) in einem separaten, nur bedingt einsehbaren Container zu liefern, keinen Sinn.

    Wenn du einen persönlichen Support möchtest, bei dem nur ein kleiner Personenkreis Einblick in (nicht sicherheitsrelevante) Daten zu deiner Website erhält und sich mit einem NDA zu Verschwiegenheit verpflichtet, solltest du bitte einen Dienstleister ansprechen, aber nicht mehr hier im Forum fragen.

    Danke @la-geek für das Schließen dieses Threads.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Backend: Menüeinträge hinzufügen wird nicht angezeigt“ ist für neue Antworten geschlossen.