Support » Installation » Backend nicht mehr erreichbar/funktionierend

  • Liebes Forum,

    seit neuestem kann ich mein Backend nicht mehr richtig erreichen. Ich habe aus dem Augenwinkel einen Hinweis zum upgrade oder ähnliches gesehen, aber ich muss gestehen, daß ich nicht genau den Auslöser kenne. Die Websitefunktionalität scheint unberührt, aber wenn ich mich unter /wp-admin einloggen will, wird mir nur eine weisse seite mit den Menü-items auf der linken Seite angezeigt, die aber allesamt non-responsive sind.

    Ich kann leider nicht nachvollziehen, was sich verändert hat. Aber das Erscheinungsbild ist unabhängig von Browser (chrome, edge) oder Betriebssystem (iOS, WIN).

    Habt Ihr einen Tipp für mich?

    Ganz herzlichen Dank im voraus für jede Hilfe!

    Viele Grüße, Peter

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)
  • Um die Fehlerursache herauszufinden, solltest du zuerst den Debug-Modus aktivieren. Dazu änderst du per FTP in der Datei wp-config.php die Zeile define( 'WP_DEBUG', false ); auf define( 'WP_DEBUG', true );. Bekommst du nun bei Aufruf des Backend eine Fehlermeldung angezeigt? Welche? – Wenn die Fehlermeldung notiert wurde, solltest du die Zeile wieder in define( 'WP_DEBUG', false ); ändern, um Angreifern nicht unnötig Informationen über eine mögliche Schwachstelle deiner Installation zu liefern.

    Während der WordPress-Core von sehr vielen Benutzern täglich genutzt wird und Fehler dabei sehr schnell auffallen, werden Themes und Plugins weniger intensiv geprüft. Die Wahrscheinlichkeit ist hoch, dass der Fehler durch ein Plugin verursacht wurde. Um alle Plugins zunächst zu deaktivieren, kannst du per FTP das Verzeichnis wp-content/pluginsz.B. in wp-content/no.plugins umbenennen. Kannst du danach auf das Backend zugreifen? Falls ja, benennst du das Verzeichnis wieder in wp-content/plugins um, führst soweit angeboten Updates durch und aktivierst dann erst die Plugins einzeln. Fällt das Backend wieder aus, brauchst du nur das Unterverzeichnis des zuletzt aktivierten Plugins umbenennen, um es wieder zu deaktivieren.

    Thread-Starter pdelling

    (@pdelling)

    Herzlichen Dank für die rasche Antwort, phänomenal!
    Und entschuldigt bitte, ich habe mich glaube ich falsch ausgedrückt: das Backend ist/war erreichbar, ich kann mich einloggen, aber das Erscheinungsbild ist dann komplett ungewohnt und nicht nutzbar.

    Ich habe beide Hinweise befolgt.

    1. Debug-Mode

    Das hat leider keine Veränderung zur Folge. Im Backend wird mir weiterhin eine weisse Seite angezeigt mit Links angezeigt. Das sieht wie folgt aus — und ich sehe keine Fehlermeldung (aber vielleicht schaue ich auch nicht an der richtigen Stelle?):

    Wenn ich weiter nach unten scrolle, dann überlagern sich Inhalte:

    Das Erscheinungsbild der Seite für die Besucher bleibt unverändert.

    2. Umbenennen des Plugins-Ordners

    Ok, dann verändert sich natürlich das Erscheinungsbild der website für Besucher. Am Backend aber keine Veränderung ggü. den obigen screenshots.

    Ich habe jetzt erstmal wieder den Debug-Modus ausgeschaltet.

    Kann ich denn irgendwelche Analysechecks laufen lassen, die helfen, das Problem einzugrenzen?

    Erneut: Riesendank im voraus für jede Hilfe!

    Lg, peter

    Probier mal, ob du den Link Dashboard > Update anklicken kannst:

    Screenshot

    Dort dann auf „WordPress erneut installieren“ klicken. Damit können wir dann zumindest ausschließen, dass beim letzten Update etwas nicht vollständig übertragen wurde.

    Sollte das nicht helfen, öffne bitte währen du im Backend bist die Entwickler-Tools deines Browser (Rechtsklick auf die Seite > Untersuchen) und schau, ob im Tab Konsole Fehlermeldungen angezeigt werden.

    Thread-Starter pdelling

    (@pdelling)

    Vielen Dank!

    Hm, „Updates 8“ liess sich zwar anklicken, aber dann passiert nichts.

    In fer Fehlerkonsole wird mir angezeigt

    Failed to load resource: the server responded with a status of 503 ()

    Ist die Website bei Strato?

    Wenn ja, ist der Gästebuch-Spamfilter aktiviert? Dann den bitte deaktivieren und prüfen, was sich ändert.

    Thread-Starter pdelling

    (@pdelling)

    Nein, die liegt bei alfahosting.

    Gästebuch-Spamfilter. Hm, das sagt mir nichts. Ich suche mal

    Thread-Starter pdelling

    (@pdelling)

    Also ich kann da nichts finden — aber bei alfahosting ist auch wirklich nur hosting. Habe keinen Homepage-Baukasten o.ä. von denen benutzt.

    Nein, das war speziell für Strato und trifft dann nicht auf dich zu.

    Welche PHP-Version ist denn im Kundenmenü eingestellt?

    Hallo,
    das sieht fast so aus, als wenn der Ordner ...\wp-admin\css fehlt.

    Evtl. kommst du mit den Hinweisen aus unserer FAQ weiter: Probleme nach dem Update/Upgrade: Fehlerhafte oder fehlende Core-Dateien.

    Vorher aber bitte auf jeden Fall dafür sorgen, dass du eine Sicherung z. B. auf deinen lokalen Rechner kopiert hast. Wenn du das aber so wie im Beitrag beschrieben durchführst und die Hinweise beachtest, sollte das kein Problem sein.

    Viele Grüße
    Hans-Gerd

    Thread-Starter pdelling

    (@pdelling)

    Hallo,

    vielen lieben Dank für Eure Geduld und Hinweise. Sorry, ich habe etwas gebraucht, Eure Hinweise umzusetzen. Habe die hier

    Evtl. kommst du mit den Hinweisen aus unserer FAQ weiter: Probleme nach dem Update/Upgrade: Fehlerhafte oder fehlende Core-Dateien.

    beschriebenen Schritte umgesetzt, also die word-Press-Core Dateien bis auf den content-ordner und die wp-config.php via ftp gelöscht/mit aktueller 6.3.1 Version überspielt. Allerdings erhalte ich nun die folgende Fehlermeldung, und auch die zuvor noch funktionierende website ist für Besucher nun nicht mehr erreichbar / gleiche Fehlermeldung:

    Ich habe mich auch durch den Rest der verlinkten Artikel geclickt, aber konnte nichts passendes finden.

    Thread-Starter pdelling

    (@pdelling)

    Welche PHP-Version ist denn im Kundenmenü eingestellt?

    Ich sehe im Datenbank-Menü von alfahosting „MySQL 5.7“. Habe keinen Hinweis erhalten, daß da etwas verändert wurde

    Hallo,
    dann gibt es vermutlich ein Problem mit einem Plugin.
    Auch das kann man lösen: Wie deaktiviert man alle Plugins ohne Adminzugang?.

    Am einfachsten geht das über den im Link beschriebenen Punkt 2.:

    2.) Oder setze das Plugins-Verzeichnis per FTP-Programm oder mit einem vom Hoster zur Verfügung gestellten Dateimanager zurück.

    Viele Grüße
    Hans-Gerd

    Es geht um die PHP-Version, nicht um MySQL.
    Über das Kundenmenü beim Hoster solltest du das sehen können. Ansonsten setze dich am besten mit dem Hoster in Kontakt und frage da nach.

    Hier noch ein paar Links als Hilfe:

    Thread-Starter pdelling

    (@pdelling)

    Plugins: ok, habe wp-content/plugins in …/plugins.old umbenannt. Aber danach bleibt der versuch, mich auf die Seite einzuloggen weiterhin erfolglos / gleiche Fehlermeldung wie oben.
    Wg. PHP frage ich nach

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 20)
  • Das Thema „Backend nicht mehr erreichbar/funktionierend“ ist für neue Antworten geschlossen.