Support » Allgemeine Fragen » Backup ruft Installation auf.

  • Gelöst misterairbrush

    (@misterairbrush)


    Habe ein Serverbackup von WP auf neuen Server via SFTP zurückgespielt. Alles identisch wie vorher.
    Benutzer, Besitzer, Berechtigungen, Datenbankaufbau, Passwörter usw.
    Dennoch ruft WP das Installationsprogramm auf anstatt einfach zu laufen.
    Kennt jemand die Ursache oder hat eine Idee?

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Datenbank auch auf den neuen Server importiert?

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    ich habe das gerade mal bei einer lokalen Testinstanz geprüft: in der Regel taucht das Problem auf, wenn die wp-config.php fehlt.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    … oder wenn zwar die Datenbank vorhanden ist, die Datenbank-Tabellen aber fehlen oder leer sind.

    Thread-Ersteller misterairbrush

    (@misterairbrush)

    die wp-config.php ist vorhanden.
    Datenbank ist vorhanden und voll mit den Daten.
    Zuerst dachte ich das es daran liegt das die wp-config dem user root gehört. Das habe ich geändert aber das war es auch nicht.

    Stimmt denn das Datenbanktabellen-Präfix in der wp-config.php?

    alter Server <-> neuer Server
    Datenbank ist auf beiden mit localhost adressiert?

    Womit wurde das Backup erstellt? Du schriebst „Serverbackup“, also vermutlich serverseitig? Steckt darin vielleicht eine Installations-Routine?

    Zuerst dachte ich das es daran liegt das die wp-config dem user root gehört.

    Also Besitzerrechte doch nicht identisch? Vielleicht dort ftp-user und auf dem anderen www-run? Das würde dann alle Dateien betreffen, nicht nur die wp-config.php.

    Thread-Ersteller misterairbrush

    (@misterairbrush)

    keine istallationsroutine.
    Alle Daten auf dem server gepackt, runtergeladen, auf neuen hoch und entpackt.
    Hat bisher immer so funktioniert. Die Daten der Datenbank ebenso. aus var/lib/mysql/datenbankname/
    Die neue Datenbank angelegt und alles reinkopiert.
    Hat seit Jahren immer zu 100% problemlos funktioniert. Alles via SFTP mit Rootrechten.
    Viel einfacher und sicherer als ein export via mysql. Bei großen datenmengen bricht das gerne mal ab.

    Die neue Datenbank angelegt und alles reinkopiert.

    Das kann durchaus Probleme bereiten und ist absolut nicht zu empfehlen. Und nur weil es Jahre lang geklappt hat, muss das heute nicht mehr funktionieren. Das kann an unterschiedlichen MySQL/MariaDB Versionen liegen.

    Viel einfacher und sicherer als ein export via mysql. Bei großen datenmengen bricht das gerne mal ab.

    Wenn ich root-Rechte habe, ist mir das in all den Jahren noch nie passiert. Selbst Dump-Files über 10 GB Größe habe ich problemlos ex- und importieren können.

    Thread-Ersteller misterairbrush

    (@misterairbrush)

    könnte es an einem fehlenden htaccess liegen?
    Die Logfiles geben nix her.

    könnte es an einem fehlenden htaccess liegen?

    Eigentlich nicht

    Thread-Ersteller misterairbrush

    (@misterairbrush)

    Fehler eingegrenzt. Datenbank steht auf Bearbeitung. (Locked). Engineinkompatibilität.
    https://mariadb.com/kb/de/mariadb-vs-mysql-compatibility/#inkompatibilit%C3%A4ten-zwischen-mariadb-51-und-mysql-51
    Somit nicht ganz einfach zu lösen. Neu bedeutet nicht immer besser.

    Tja, mit einem Export und Import wäre das besser gewesen. Wie schon erwähnt, einfach kopieren ist keine gute Idee.

    Thread-Ersteller misterairbrush

    (@misterairbrush)

    Warum einfach wenn es auch umständlich geht. Klar kann man es auch mit extra Software machen wie z.B. via mysqldump usw. Bisher war dabei zumindest bei mir die Fehlerquote viel höher. Habe ja backup. Wird alter Server wieder eingerichtet und dann ein mysqldump gemacht.

    Das Problem scheint damit ja gelöst zu sein:
    hier mySQL dort MariaDB.

    Ich setze das Thema daher mal auf gelöst.

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)