Support » Installation » „Bad Request“ Your browser sent a…

  • Hallo zusammen,
    ich habe das Problem, dass sobald ich in einem Beitrag ein Bild hinzufüge, die Fehlermeldung

    „Bad Request
    Your browser sent a request that this server could not understand.“ Kommt.
    Der Titel ist zwar sichtbar, genau wie der Text, jedoch sind die Bilder verschwunden.

    WordPress Version; 5.3.2–de_DE
    Theme: Hestia

    Server: Strato
    MySQL: 5.6.42
    PHP: 7.3

    Die Bilder werden als .jpg hochgeladen. Es ist „egal“ ob ich ein einzelnes Bild hochlade, oder ob ich eine Galerie einfüge.

    Über eine Antwort würde ich mich freuen, hab jetzt schon einiges ausprobiert, bin aber inzwischen mit meinem Latein am Ende 🙁

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Wahrscheinlich war die Bild-Datei zu groß.
    Geh mal auf Werkzeuge > Website-Zustand > Bericht und klick auf den Button „Bericht in die Zwischenablage kopieren“ – das kannst du dann unverändert (mit den Apostroph-Zeichen) hier einfügen, damit wir ein paar Informationen über deine Website erhalten.

    Cookies und Cache hattest du im Browser mal gelöscht?
    Im Kundenmenü von Strato ist unter Security die „Server Side Security“ deaktiviert?

    Hallo @pixolin,

    danke für die schnelle Antwort.

    Cookies und Cache habe ich gelöscht, Server Side Security ist aktiviert, das hatte ich auch schon als Fehlerquelle in betracht gezogen, hab aber bisher immer nur einen Verweis auf Fehler 503 entdeckt, kann ich gleich mal ausprobieren.

    Hier der Unveränderte Bericht

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%?post_type=tribe_events%
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01
    wordpress_size: loading...
    uploads_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/uploads
    uploads_size: loading...
    themes_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/themes
    themes_size: loading...
    plugins_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Hestia (hestia)
    version: 2.5.6
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, custom-header, customize-selective-refresh-widgets, custom-background, starter-content, themeisle-demo-import, align-wide, header-footer-elementor, editor-color-palette, menus, editor-style, jetpack-portfolio, widgets
    theme_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/themes/hestia
    
    ### wp-plugins-active (4) ###
    
    Jetpack by WordPress.com: version: 8.0, author: Automattic
    Orbit Fox Companion: version: 2.8.14, author: Themeisle
    TablePress: version: 1.10, author: Tobias Bäthge
    The Events Calendar: version: 4.9.13, author: Modern Tribe, Inc.
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.3.12
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content
    WP_PLUGIN_DIR: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### jetpack ###
    
    site_id: 148079687
    ssl_cert: No
    time_diff: undefined
    version_option: 8.0:1575388211
    old_version: 7.9.1:1574222184
    public: Public
    master_user: #1 MegaAdmin [E-Mail-Adresse gelöscht]
    current_user: #1 MegaAdmin [E-Mail-Adresse gelöscht]
    tokens_set: Blog User
    blog_token: *** [Wert unkenntlich gemacht]
    user_token: *** [Wert unkenntlich gemacht]
    version: 8.0
    jp_plugin_dir: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/plugins/jetpack/
    plan: free
    HTTP_HOST: schuetzenverein-suelzbach.de
    SERVER_PORT: 80
    REMOTE_ADDR: 77.182.49.78
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Wed, 05 Sep 2018 03:53:57 +0000","queue_finished":"Wed, 05 Sep 2018 03:53:57 +0000","send_started":"Wed, 05 Sep 2018 03:53:59 +0000","finished":"Wed, 05 Sep 2018 03:53:59 +0000","sent":{"constants":1,"functions":1,"options":1},"sent_total":[],"queue":{"constants":1,"functions":1,"options":1},"config":{"options":true,"functions":true,"constants":true,"users":[0]},"total":{"constants":1,"functions":1,"options":1}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"http:\/\/schuetzenverein-suelzbach.de","siteurl":"http:\/\/schuetzenverein-suelzbach.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: All Pass.
    
    
    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von fantadrad.
    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von Bego Mario Garde. Grund: E-Mail-Adresse gelöscht
    fantadrad

    (@fantadrad)

    Hab noch mal alles angeschaut, jedoch leider nach wie vor keine Lösung.
    Auchfinde ich den Menüpunkt „side-Guard“ nicht mehr bei Strato.

    Hat noch jemand einen Tipp?

    Hallo,
    @pixolin hatte geschrieben: Im Kundenmenü von Strato ist unter Security die „Server Side Security“ deaktiviert?
    Du hast aber angegeben, dass „Server Side Security“ aktiviert ist.
    Der Abschnitt ### wp-paths-sizes ### ist unvollständig. Es ist keine Größe sichtbar, weil du wahrscheinlich schon kopiert hattest, bevor der Bericht komplett war.

    Auchfinde ich den Menüpunkt „side-Guard“ nicht mehr bei Strato.

    Ich weiß zwar nicht, wie du darauf kommst, aber da würde ich mich an den Support von Strato wenden. Hier die Infos zu STRATO SiteGuard.
    Die Frage ist auch, ob Jetpack wirklich installiert sein muss, weil Jetpack schon aus Datenschutzgründen problematisch ist, siehe hier.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Zusätzlich ist als theme (falls vorhanden) twenty nineteen aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembenhandlungsmodus und schaue anschließend, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise das Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.

    Viele Grüße
    Hans-Gerd

    Nochmal hallo zusammen,

    ich habe jetzt endlich Zeit gefunden noch mal drauf zu schauen.
    Den SiteGuard hab ich gefunden und deaktiviert – keine Besserung.

    Auch habe ich hier den kompletten Bericht noch einmal ausführlich geladen und eingefügt.

    Das mit Health Check habe ich ausgeführt, es scheint nur ein Problem beim thema PHP zu geben, kann es daran liegen?

    Vielen Dank vorab

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    permalink: /%?post_type=tribe_events%
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01
    wordpress_size: 102,69 MB (107679879 bytes)
    uploads_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/uploads
    uploads_size: 716,74 MB (751553509 bytes)
    themes_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/themes
    themes_size: 10,09 MB (10584500 bytes)
    plugins_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/plugins
    plugins_size: 49,44 MB (51846725 bytes)
    database_size: 6,75 MB (7077888 bytes)
    total_size: 885,72 MB (928742501 bytes)
    
    ### wp-active-theme ###
    
    name: Hestia (hestia)
    version: 2.5.6
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, custom-header, customize-selective-refresh-widgets, custom-background, starter-content, themeisle-demo-import, align-wide, header-footer-elementor, editor-color-palette, menus, editor-style, widgets
    theme_path: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/themes/hestia
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    
    ### wp-plugins-active (4) ###
    
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    Orbit Fox Companion: version: 2.9.2, author: Themeisle
    TablePress: version: 1.10, author: Tobias Bäthge
    The Events Calendar: version: 5.0.2.1, author: Modern Tribe, Inc.
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.3.14
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    server-headers: 
    	date: Sun, 01 Mar 2020 13:36:02 GMT
    	server: Apache/2.4.41 (Unix)
    	x-powered-by: PHP/7.3.14
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <http://schuetzenverein-suelzbach.de/wp-json/>; rel="https://api.w.org/"
    	x-tec-api-version: v1
    	x-tec-api-root: http://schuetzenverein-suelzbach.de/wp-json/tribe/events/v1/
    	x-tec-api-origin: http://schuetzenverein-suelzbach.de
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content
    WP_PLUGIN_DIR: /mnt/web307/c3/23/59287523/htdocs/WordPress_SecureMode_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    • Diese Antwort wurde geändert vor 4 Monaten, 1 Woche von fantadrad.
    • Diese Antwort wurde geändert vor 4 Monaten, 1 Woche von Hans-Gerd Gerhards.
    • Diese Antwort wurde geändert vor 4 Monaten, 1 Woche von Hans-Gerd Gerhards.
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)