Support » Installation » Beiträge speichern geht nicht nach Umstellung des Permalinks

  • Gelöst towi

    (@towi)


    Servus Community,

    nach der Umstellung des Standard Permalinks ‚Einfach‘ zB auf ‚Beitragsname‘ kann ich keine Beiträge mehr abspeichern. Die Fehlermeldung lautet:

    Veröffentlichung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

    Einen bereits zuvor veröffentlichen Beitrag kann ich nicht mehr öffnen, was aber nach allem, was ich bislang über das Verhalten von WordPress bzgl. Änderungen der URL gelesen habe, noch Sinn ergibt.

    Ich bin mir nicht sicher, ob da eine RewriteCondition in der .htaccess mit einer bereits vorhandenen in der Virtual Host Konfiguration des Apache Webserver einen Konflikt erzeugt. Ich habe damit die HTTP Anfragen permanent auf die HTTPS Seite weitergeleitet.

    Hier zur Analyse die drei involvierten Konfigurationsdateien:

    # cat prontosystems.de/test/wordpress/.htaccess 
    
    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    

    —snip—

    # cat /etc/apache2/sites-available/test.prontosystems.conf 
    <VirtualHost *:80> 
      Serveradmin dev0@nodomain.de
      ServerName test.prontosystems.de
      DocumentRoot /var/www/prontosystems.de/test/wordpress
    
    	ErrorLog ${APACHE_LOG_DIR}/test.prontosystems.de_error.log
         	CustomLog ${APACHE_LOG_DIR}/test.prontosystems.de_access.log combined
    
      RewriteEngine on
      RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </VirtualHost>

    —snip—

    # cat /etc/apache2/sites-available/test.prontosystems-le-ssl.conf 
    <IfModule mod_ssl.c>
    <VirtualHost *:443>
         ServerAdmin dev0@nodomain.de
          DocumentRoot /var/www/prontosystems.de/test/wordpress
         ServerName test.prontosystems.de
    
         ErrorLog ${APACHE_LOG_DIR}/test.prontosystems.de_error.log
         CustomLog ${APACHE_LOG_DIR}/test.prontosystems.de_access.log combined
    
    SSLCertificateFile /etc/letsencrypt/live/test.prontosystems.de/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/test.prontosystems.de/privkey.pem
    Include /etc/letsencrypt/options-ssl-apache.conf
    </VirtualHost>
    </IfModule>

    Allerdings bin ich mir nicht sicher, ob das Problem an dieser Stelle zu suchen ist. Für Unterstützung bei der Suche nach dem Fehler dankend…

    Bye Tom

    • Dieses Thema wurde geändert vor 2 Wochen, 5 Tage von towi.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Ich glaube ich habe den Fehler gefunden. In der apache2.conf war die AllowOverride-Direktive auf None gesetzt. Nachdem ich sie auf All gesetzt habe funktioniert das jetzt. Laut FAQ respektiert der Apache Webserver durch diese Direktive (All) erst eine ggf. vorhandene .htaccess Datei:

    
    # /etc/apache2/apache2.conf
    <Directory /var/www/>
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted
    </Directory>

    Erst die Suche nach Apache 2 und .htaccess hat mich dann auf die richtige Spur gebracht. Das ganze hat demnach nichts mit WordPress zu tun.

    Sorry & Bye Tom

    • Diese Antwort wurde geändert vor 2 Wochen, 5 Tage von towi.

    Hallo,
    danke für die Info. Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren. Das habe ich jetzt schon gemacht.
    Viele Grüße
    Hans-Gerd

    Servus Hans-Gerd,

    das wollte ich noch machen aber auf einmal stand der Thread unter Spamverdacht, nachdem ich ein paar Grammatikfehler korrigiert hatte und musste zuerst von einem Moderator freigegeben werden.

    Aber ich denke beim nächsten mal gleich daran 😉

    Thx & Bye Tom

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)