Support » Allgemeine Fragen » „Beitrag bearbeiten“ führt zu 404 im Frontend

  • Gelöst Ravana

    (@depape01)


    Guten Morgen zusammen,

    ich hab gestern WordPress von 6.1 auf 6.2 upgedatet und kann seitdem keine Beiträge (Posts) mehr bearbeiten. Statt dass sich der Editor öffnet, werd ich auf meine 404-Seite im Frontend weitergeleitet.

    Neuen Beitrag erstellen geht, Seite (Page) editieren auch.

    Ich hab das hier immer wieder empfohlene Health Check-Plugin installiert und bin in den Debug-Modus gegangen, das ändert aber nichts am Problem und ich kann noch immer keine Beiträge bearbeiten.

    Ich würd mich über Ideen dazu freuen!

    Viele Grüße, Ravana

    Hier die Infos aus Website-Zustand. Da sind einige deaktivierte Plugins drin, weil ich jetzt zum Testen ziemlich viele deaktiviert habe. Evtl sind einige davon auch gar nicht mehr nötig, wenn der Umstieg auf Twenty-Twentythree klappt, da muss ich dann noch aussortieren.

    `
    ### wp-core ###
    
    version: 6.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%category%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium
    wordpress_size: loading...
    uploads_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/uploads
    uploads_size: loading...
    themes_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/themes
    themes_size: loading...
    plugins_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-active-theme ###
    
    name: Fluida Plejadium (fluida-plejadium)
    version: 0.5
    author: Debora Pape / Cryout Creations
    author_website: https://www.plejadium.de
    parent_theme: Fluida Plus (fluida-plus)
    theme_features: core-block-patterns, editor-style, widgets-block-editor, title-tag, automatic-feed-links, html5, post-formats, custom-background, custom-logo, menus, post-thumbnails, custom-header, responsive-embeds, editor-color-palette, editor-font-sizes, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/themes/fluida-plejadium
    auto_update: Deaktiviert
    
    ### wp-parent-theme ###
    
    name: Fluida Plus (fluida-plus)
    version: 1.6.0.2 (latest version: 1.8.8)
    author: Cryout Creations
    author_website: http://www.cryoutcreations.eu
    theme_path: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/themes/fluida-plus
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Twenty-Three: version: 1.1, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.3, author: Das WordPress-Team (latest version: 1.4), Automatische Aktualisierungen deaktiviert
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.9.0
    
    ### wp-plugins-active (12) ###
    
    Antispam Bee: version: 2.11.3, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Borlabs Cookie - Cookie Opt-in: version: 2.2.31, author: Benjamin A. Bornschein, Borlabs (latest version: 2.2.63), Automatische Aktualisierungen deaktiviert
    Contact Form 7: version: 5.7.6, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Cryout Featured Content: version: 1.1, author: Cryout Creations, Automatische Aktualisierungen deaktiviert
    Easy FancyBox: version: 1.9.5, author: RavanH, Automatische Aktualisierungen deaktiviert
    FooGallery: version: 2.2.41, author: FooPlugins, Automatische Aktualisierungen deaktiviert
    Health Check & Troubleshooting: version: 1.6.0, author: The WordPress.org community, Automatische Aktualisierungen deaktiviert
    Per page head: version: 1.4.4, author: Erik von Asmuth, Automatische Aktualisierungen deaktiviert
    Redirection: version: 5.3.10, author: John Godley, Automatische Aktualisierungen deaktiviert
    Table of Contents Plus: version: 2302, author: Michael Tran, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.23.3, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 20.6, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (13) ###
    
    Autoptimize: version: 3.1.7, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Enable Media Replace: version: 4.1.2, author: ShortPixel, Automatische Aktualisierungen deaktiviert
    Fixed Widget: version: 6.2.3, author: Thomas Maier, Max Bond, Automatische Aktualisierungen deaktiviert
    Kadence Blocks – Gutenberg Blocks for Page Builder Features: version: 3.0.34, author: Kadence WP (latest version: 3.0.35), Automatische Aktualisierungen deaktiviert
    miniOrange Broken Link Checker/Finder: version: 2.4.2, author: miniOrange, Automatische Aktualisierungen deaktiviert
    Optimize Database after Deleting Revisions: version: 5.0.110, author: CAGE Web Design | Rolf van Gelder, Eindhoven, The Netherlands, Automatische Aktualisierungen deaktiviert
    Popup Maker: version: 1.18.1, author: Popup Maker, Automatische Aktualisierungen deaktiviert
    Scripts-To-Footer: version: 0.7.1, author: Joshua David Nelson, Automatische Aktualisierungen deaktiviert
    Search & Replace: version: 3.2.1, author: Inpsyde GmbH, Automatische Aktualisierungen deaktiviert
    Shariff Wrapper: version: 4.6.9, author: Jan-Peter Lambeck & 3UU, Automatische Aktualisierungen deaktiviert
    ThirstyAffiliates: version: 3.10.17, author: Caseproof, Automatische Aktualisierungen deaktiviert
    Widget Options: version: 3.8.10, author: Widget Options Team, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.9.4, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: FooGallery_Thumb_Image_Editor_Imagick
    imagick_module_version: 1692
    imagemagick_version: ImageMagick 6.9.12-60 Q16 x86_64 17403 https://legacy.imagemagick.org
    imagick_version: 3.5.1
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP Linux localhost 3.10.0-1160.83.1.el7.x86_64 #1 SMP
    httpd_software: Apache/2.4.56 (Unix)
    php_version: 8.0.28 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 240
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.88.1 OpenSSL/1.1.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 8.0.28
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: https://www.lucyda.de
    WP_SITEURL: https://www.lucyda.de
    WP_CONTENT_DIR: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content
    WP_PLUGIN_DIR: /mnt/web115/c1/27/51974527/htdocs/_plejadium/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    `

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Du hast mit dem Bericht nicht lange genug gewartet:

    wordpress_size: loading…

    Hast du mal in den Log-Files des Servers nachgesehen, ob dort ein Fehler zu finden ist?
    Du könntest die Plugins deaktivieren und dann testen, ob der Fehler immer noch auftritt. Wenn nicht, aktivierst du nach und nach die Plugins, bis der Fehler wieder auftritt, dann hast du den Schuldigen.

    ### wp-plugins-inactive (13) ###

    Da solltest du einmal aufräumen, was du nicht brauchst solltest du löschen. Ist unnötiger Ballast und kann auch zu Problemen führen.

    Ich gehe den Website-Bericht mal von oben nach unten durch, weil mir da einige Dinge auffallen:

    • total_size: loading… – ist nicht so richtig aussagefähig, demnächst einfach abwarten, bis der Website-Zustand oben angezeigt wird. Hier aber wahrscheinlich sowieso irrelevant.
    • (Parent) Theme Fluida Plus – wir können bei gekauften Themes nicht weiterhelfen, weil sie uns für kostenlosen Support nicht zur Verfügung stehen. Aber … auch egal.
    • Plugin Redirection – würde ich deaktivieren, wenn es anscheinend sowieso Probleme mit einer Weiterleitung gibt. Die anderen Plugins scheinen für die Behebung des Fehlers weniger interessant zu sein, aber vorsichtshalber kannst du auch hier mal ausprobieren, was passiert, wenn du sie alle deaktivierst. Sorry, du hast das ja schon per Health-Check-Plugin geprüft.
    • Du hast WP Super Cache deaktiviert. Leider nistet sich dieses Plugin weiter in WordPress ein als üblich und ist nur mit mehreren Schritten komplett zu entfernen. Das wäre aber während der Fehlersuche sinnvoll. Anleitung findest du auf der Plugin-Seite https://de.wordpress.org/plugins/wp-super-cache/#installation unter How to uninstall WP Super Cache.
    • Du hast in der wp-config.php die Konstanten WP_HOME und WP_SITEURL gesetzt. Wenn du nicht laufend zwischen einer Staging- und produktiven Umgebung wechselst, rate ich davon ab, weil unter Einstellungen > Allgemein das Eingabefeld für die URL deaktiviert wird. Besser auskommentieren, ggf. in der Datenbanktabelle wp_options prüfen, ob die URL richtig (und vor allem mit https) eingetragen ist, sonst korrigieren – wieder zwei unnötige Zeilen in der wp-config.php weniger.

    Wenn das alles nichts bringt, öffne bitte im Browser die Entwickler-Tools (Taste F12), geh in den Tab „Netzwerk“, öffne dann den Editor und schau, welche Dateien dort aufgerufen werden. Wo leitet die Umleitung hin?

    @bscu

    ### wp-plugins-inactive (13)
    Da solltest du einmal aufräumen, was du nicht brauchst solltest du löschen. Ist unnötiger Ballast und kann auch zu Problemen führen.

    Dazu hat sie ja geschrieben
    „Da sind einige deaktivierte Plugins drin, weil ich jetzt zum Testen ziemlich viele deaktiviert habe. Evtl sind einige davon auch gar nicht mehr nötig, wenn der Umstieg auf Twenty-Twentythree klappt, da muss ich dann noch aussortieren.“

    Thread-Starter Ravana

    (@depape01)

    Vielen Dank euch beiden für die schnelle, geduldigen und informativen Antworten!

    @pixolin

    total_size: loading… – ist nicht so richtig aussagefähig, demnächst einfach abwarten, bis der Website-Zustand oben angezeigt wird. Hier aber wahrscheinlich sowieso irrelevant.

    Das hat schon die ganze Nacht durch geladen und ist einfach nicht fertig geworden. Heute Morgen konnte ich aber immerhin den Log kopieren, gestern Abend konnte ich nach dem 6.2-Update irgendwie gar nichts bekommen.

    Super Cache hab ich nach deiner Anleitung nun deaktiviert. Vielleicht sowieso nicht mehr nötig mit den neueren PHP-Versionen..

    WP-HOME und WP-SITE-URL hab ich auch rausgenommen jetzt.

    Auf dem Server-Log kann ich erstmal keine Fehler erkennen.

    Aber ich hab jetzt erst ins Weiterleitungsziel geschaut. Das Problem war ja, dass ich keine Beiträge mehr editieren konnte. Jetzt wird es ganz komisch: Jetzt geht es bei allen, die ich getestet habe, nur nicht beim letzten Beitrag.

    Beim letzten Beitrag wird auf eine ganz andere Adresse weitergeleitet: https://www.lucyda.de/virtual-life/blender-3d/blender-anfaenger-guide/wp-admin/post.php?post=39359&action=edit

    Ich hab vorgestern erst eine neue Subdomain eingerichtet, die auf eben diese URL weiterleiten soll (natürlich ohne /wp-admin/post.php… etc) hinten dran. Das hat auch funktioniert – ich hab das jetzt wieder rausgenommen. Der Fehler besteht noch weiterhin. Vielleicht Browser-Cache, das probier ich dann auf einem anderen Browser noch aus.

    Warum aber diese URL irgendwie in den Post-Edit nur meines letzten Beitrags reinkommt, kann ich nicht verstehen. Da ist auch nirgends eine 301-Weiterleitung von woanders drin.

    Aber ich bin sicher, das Problem sitzt vor dem Monitor. Vermutlich hat das irgendwas mit der Subdomain zu tun, denn genau an der URL hatte ich ja schon rumgefummelt.

    Thread-Starter Ravana

    (@depape01)

    Ja, mit einem anderen Browser gehts nun – was auch immer diese merkwürdige Weiterleitung verursacht hat. Bitte entschuldigt die Nachfrage hier, ich bin gar nicht drauf gekommen zu schauen, warum es einen 404 geben könnte und hab sofort irgendwas am Backend vermutet (nach dem Update auf 6.2 haben verschiedene Plugins mehrere Probleme verursacht).

    Schönes Wochenende!

    Danke für die Rückmeldung. Dir auch ein schönes Wochenende.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „„Beitrag bearbeiten“ führt zu 404 im Frontend“ ist für neue Antworten geschlossen.