Support » Allgemeine Fragen » Beitrag bearbeiten

  • Gelöst ritzel19

    (@ritzel19)


    Seit 2 Jahren nutze ich über Strato bei WordPress einen Blog, der quasi wie ein Tagebuch meine Aktivitäten mit einem kleinen motorisiertem Zweirad auflistet.
    Funktionierte soweit sehr gut. Kann aber seit dem letzten Beitrag vom 24.11.19 keine Veränderungen an veröffentlichten Blogbeiträgen abspeichern. Der Button „Aktualisieren“ ist nicht aktiv.
    Was ist zu tun?
    Grüße – Andreas G.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Moderator Bego Mario Garde

    (@pixolin)

    Ruf bitte mal Werkzeuge > Website-Zustand auf. Werden dort Fehlerhinweise angezeigt? Welche? Falls keine angezeigt werden, kannst du im Tab „Bericht“ die relevanten Informationen deiner Website per Button kopieren und hier einfügen, damit mal jemand einen Blick darauf wirft.

    Vielleicht ist auch einfach die Datenbank voll?

    ritzel19

    (@ritzel19)

    Herzlichen Dank schon mal!
    *
    Der Status gibt >5 empfohlene Verbesserungen< und >11 Elemente, bei denen keine Probleme erkannt wurden<. Ohne Fehler.
    *
    Hier der Bericht:
    *

    
    ### wp-core ###
    
    version: 5.3
    site_language: de_DE
    user_language: de_DE
    timezone: +01:00
    permalink: undefined
    https_status: false
    user_registration: 0
    default_comment_status: closed
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01
    wordpress_size: 95,46 MB (100096597 bytes)
    uploads_path: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content/uploads
    uploads_size: 381,93 MB (400480769 bytes)
    themes_path: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content/themes
    themes_size: 5,78 MB (6062684 bytes)
    plugins_path: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content/plugins
    plugins_size: 230,39 KB (235921 bytes)
    database_size: 2,67 MB (2801664 bytes)
    total_size: 486,07 MB (509677635 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Sixteen (twentysixteen)
    version: 2.0
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, title-tag, custom-logo, post-thumbnails, menus, html5, post-formats, editor-style, editor-styles, wp-block-styles, responsive-embeds, editor-color-palette, customize-selective-refresh-widgets, custom-background, custom-header, widgets
    theme_path: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content/themes/twentysixteen
    
    ### wp-themes-inactive (4) ###
    
    Twenty Fifteen: version: 2.5, author: WordPress-Team
    Twenty Fourteen: version: 2.7, author: WordPress-Team
    Twenty Nineteen: version: 1.4, author: WordPress-Team
    Twenty Twenty: version: 1.0, author: WordPress-Team
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 4.1.3, author: Automattic
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc SunOS localhost 5.10 Generic_150401-49 i86pc
    httpd_software: Apache/2.4.41 (Unix)
    php_version: 7.2.24
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 120
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 64M
    php_post_max_size: 76M
    curl_version: 7.54.0 OpenSSL/1.0.2k
    suhosin: false
    imagick_availability: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.6.42-log
    client_version: 5.5.54
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content
    WP_PLUGIN_DIR: /mnt/web017/d0/91/57626891/htdocs/WordPress_SecureMode_01/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    *
    Andreas G.

    ritzel19

    (@ritzel19)

    Datenbank = Speicherplatz bei Strato?
    Da sind 23,9 GB (98%) frei.

    Hallo,
    schau doch mal in die error.log, ob da irgendein Hinweis zu finden ist.
    Viele Grüße
    Hans-Gerd

    In den Informationen zur Website finde ich nichts, was auch nur annähernd einen Hinweis zur Lösung des geschilderten Problems liefern könnte. Häufig spielen fehlerhaft programmierte Plugins oder ein fehlerhaftes Themes eine Rolle; beides können wir hier mit Sicherheit ausschließen.

    Bei Strato gibt es vor allem die Besonderheit des „Server Side Security“-Filters, der für eine einwandfreie Funktion von WordPress im Kundenmenü dekativiert werden muss. Allerdings taucht hier üblicherweise eine Fehlermeldung 503 auf, die hier ebenfalls keine Rolle spielt.

    Im Moment fällt mir nur ein, dass WordPress vielleicht Probleme mit der (nicht ausgewählten) Permalink-Struktur und der REST API haben könnte, was sich durch Aufruf des Menüs Einstellungen > Permalinks schnell überprüfen lässt. In diesem Menü brauchst du auch keine Änderungen vornehmen, WordPress liest die Struktur bereits bei Aufruf des Menüs neu ein.

    Eine andere mögliche Ursache wäre ein Problem mit der Datenbank, wobei dann aber erst beim Abspeichern von Änderungen eine Fehlermeldung erscheint. Hier ist aber bereits der Button zum Aktualisieren ausgegraut, weshalb die Datenbank wohl wahrscheinlich auch keine Rolle spielt.

    Was du auch nochmal probieren kannst, ist WordPress über Dashboard > Aktualisierungen > Erneut aktualisieren nochmal frisch zu laden.

    Ansonsten bin ich hier im Moment etwas ratlos.

    Hallo Herr Gerhards,
    wo genau kann ich bei error.log nachschauen.
    Sorry kenne mich damit nicht aus.

    Hallo Herr Garde,
    „Server Side Security“ steht bei Strato auf „Filter nicht aktiv“.
    Permalinks hab ich aufgerufen, es gibt danach aber keine Veränderung beim ausgegrauten Aktualisieren.
    Dashboard > Aktualisieren > Erneut installieren, bringt keine Änderung.
    *
    Aufgefallen ist mir, dass bei Änderungen in der Überschrift (mit Permalink) eines schon veröffentlichten Blogbeitrages, der Button Aktualisieren auf aktiv geht und auch die Änderung abspeichert, mit der Angabe im grauen Feld: >Beitrag aktualisiert<, >Beitrag ansehen<.
    Gleichzeitige Änderung in einem dazugehörigen Block, werden aber ignoriert.
    Das heißt, ich kann momentan nur die Überschrift korrigieren, verändern, oder optimieren.
    *
    Ich hoffe sie kommen der Sache auf den Grund.
    Andreas G.
    *

    Ich habe heute Abend einen neuen Blogbeitrag veröffentlicht:
    http://sepplsgrom.de/?p=1414
    *
    Den kompletten vorbereiteten Wordtext für den Beitrag, habe ich in einen Block kopiert, die Überschrift händisch gesetzt, ein Foto eingefügt und die Worte „Ende Gelände“ aus dem Anfang des Blocks entfernt.
    Ich bin ziemlich sicher, dass diese Änderung beim Veröffentlichen nicht ausgeführt wurde.
    Die Worte „Ende Gelände“ stehen weiterhin am Anfang des Blocks.
    *
    Ich kann meine Beiträge so nicht sicher veröffentlichen!
    Andreas G.
    *

    Hallo,
    installiere doch mal (erst mal nur zum Testen) den classic editor und teste mal, ob es damit funktioniert. Der Editor ersetzt Gutenberg (sozusagen der neue Block-Editor seit 5.x).
    Erstelle danach einen Beitrag mit dem Classic Editor und schau mal, ob es damit funktioniert.
    Noch etwas: Übrigens verwenden wir hier, wie in Open-Source-Communities üblich, das respektvoll gemeinte „du“.
    Viele Grüße
    Hans-Gerd

    Ich bin begeistert!
    Hey, mit dem Classic Editor lässt sich arbeiten.
    Funktioniert einwandfrei. Mehr brauch ich nicht.
    *
    Herzlichen Dank für die Hilfe und gute Zeit, wünscht Andreas G.
    *

    Hey, mit dem Classic Editor lässt sich arbeiten.

    … das freut mich zwar, aber das ist natürlich auf Dauer keine endgültige Lösung, weil Gutenberg (der Block-Editor) wird eine immer zentralere Rolle spielen, d. h. irgendwann würde die Lösung nicht mehr reichen. Das solltest Du im Auge behalten. Der Classic Editor wird nach meinen Informationen noch auf jeden Fall bis zum 31.12.2021 unterstützt.

    Meine Anforderungen beim Blogschreiben sind ja minimalistisch.
    Ein paar Zeilen vom erlebten Tag, ein Foto dazu und gut ist. Am Folgetag noch mal reingehen und den Text punktuell geschmeidiger machen.
    *
    Aber klar, Wenn Gutenberg mit dem Block Editor das hinbekommt, bin ich dabei!
    Keine Frage – Andreas G.
    *

    Eigentlich hat der Block-Editor im letzten Jahr qualitativ ganz ordentlich dazugewonnen. Wieso der hier geschilderte Fehler auftritt, ist mir immer noch schleierhaft. Aber für „schau’n wir mal“ sollte die Lösung mit dem Classic Editor eine Weile halten.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)