Support » Installation » bekomme Multisite nicht aktiviert

  • Gelöst Fibmyefriblot_Doj

    (@fibmyefriblot_doj)


    Liebe Multisite-Experten,

    leider erscheint bei mir der Punkt „Network Setup“ unter Tools nicht.

    Frische WP-Installation bei all-inkl.com unter https://11r.de/wp/
    wp-config mit der Zeile »define( ‚WP_ALLOW_MULTISITE‘, true );« ergänzt.
    Permalink-Umstellung funktioniert (also scheint ‚rewrite‘ zu funktionieren).

    Habe das ganze auch vorher unter MAMP und Bitnami WordPress versucht: ohne Erfolg.
    Dann dachte ich, es geht vielleicht mit lokalen Installationen nicht (obwohl es das sollte, oder?) und habe es deshalb auf meiner Testdomain 11r.de versucht.

    Ich vermute, ich mache bereits einen grundlegenden Fehler, für den ich aber blind bin. »Sie anderen schaffen es doch auch« 😉
    Habe das Forum 1 Jahr rückwärts durchsucht, jedoch dazu nichts gefunden.

    Hat jemand eine Idee? Bestimmt machen viele den selben Fehler.

    Herzlichen Dank an alle Hilfswilligen.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Poste doch mal den Inhalt deiner wp-config.php (bitte Zugangsdaten unkenntlich machen und mit den [code]-Button formatieren).

    Fibmyefriblot_Doj

    (@fibmyefriblot_doj)

    <?php
    /**
    * The base configuration for WordPress
    *
    * The wp-config.php creation script uses this file during the
    * installation. You don’t have to use the web site, you can
    * copy this file to „wp-config.php“ and fill in the values.
    *
    * This file contains the following configurations:
    *
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    *
    * @link https://codex.wordpress.org/Editing_wp-config.php
    *
    * @package WordPress
    */
    
    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‚DB_NAME‘, ‚dbname‘);
    
    /** MySQL database username */
    define(‚DB_USER‘, ‚username‘);
    
    /** MySQL database password */
    define(‚DB_PASSWORD‘, ‚password‘);
    
    /** MySQL hostname */
    define(‚DB_HOST‘, ‚localhost‘);
    
    /** Database Charset to use in creating database tables. */
    define(‚DB_CHARSET‘, ‚utf8‘);
    
    /** The Database Collate type. Don’t change this if in doubt. */
    define(‚DB_COLLATE‘, “);
    
    /**#@+
    * Authentication Unique Keys and Salts.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define(‚AUTH_KEY‘, ‚authkey‘);
    define(‚SECURE_AUTH_KEY‘, ’secauthkey‘);
    define(‚LOGGED_IN_KEY‘, ‚loggedinkey‘);
    define(‚NONCE_KEY‘, ‚oncekey‘);
    define(‚AUTH_SALT‘, ‚authsalt‘);
    define(‚SECURE_AUTH_SALT‘, ’secauthsalt‘);
    define(‚LOGGED_IN_SALT‘, ‚loggedinsalt‘);
    define(‚NONCE_SALT‘, ’noncesalt‘);
    
    /**#@-*/
    
    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‚preficks_‘;
    define( ‚WP_POST_REVISIONS‘, 10 );
    
    /**
    * For developers: WordPress debugging mode.
    *
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    *
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    *
    * @link https://codex.wordpress.org/Debugging_in_WordPress
    */
    define(‚WP_DEBUG‘, false);
    
    /* Multisite */
    define(‘WP_ALLOW_MULTISITE’, true);
    
    /* That’s all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined(‚ABSPATH‘) )
    define(‚ABSPATH‘, dirname(__FILE__) . ‚/‘);
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‚wp-settings.php‘);
    • Diese Antwort wurde geändert vor 6 Monate von  Bego Mario Garde. Grund: Code-Auszeichnung korrigiert
    Fibmyefriblot_Doj

    (@fibmyefriblot_doj)

    Herzlichen Dank für das Angebot, die wp-config zu prüfen.
    Die Salts sind auch nicht original.

    Moderator Bego Mario Garde

    (@pixolin)

    Das mit der Code-Auszeichnung müssen wir aber noch üben? 😉

    Prüf bitte mal, on die Hochkommas (keine typographischen Anführungszeichen) bei der eingefügten Zeile stimmen:

    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);

    (Es kann sein, dass das hier im Blog nur falsch dargestellt wird.)

    Fibmyefriblot_Doj

    (@fibmyefriblot_doj)

    Ich habe copy & paste gemacht, alles markiert und auf „code“ geklickt.

    Die Hochkommas prüfe ich mal – hatte die Zeilen aus der wp.org-Doku kopiert.

    Fibmyefriblot_Doj

    (@fibmyefriblot_doj)

    Hurra! Das wars: falsche Hochkommata.

    Wieso sind die per Copy & Paste aus der offiziellen Dokumentation in meine wp-config gekommen? Stehen inder Doku schon die falschen Hochkommata?

    Herzlichen Dank!

    Moderator Bego Mario Garde

    (@pixolin)

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „bekomme Multisite nicht aktiviert“ ist für neue Antworten geschlossen.