Support » Allgemeine Fragen » Bekomme wordpress unter xampp nicht zum laufen…

  • Gelöst Jeancx

    (@jeancx)


    Hallo,
    ich habe xampp auf meinen Imac geladen und installiert. Unter dem Application Manager sind MySQL Database und Apache Server auf grün.
    Habe dann phpMyAdmin aufgerufen und eine Datenbank mit dem Namen „wordpress“ angelegt.
    Wordpress habe ich runtergeladen, entpackt und in den Ordner htdocs im Xampp-Ordner abgelegt.
    Die wp-config-sample.php Datei habe ich folgende Einträge gemacht und als wp-config.php abgespeichert:

    /**  MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster. */
    /**  Ersetze database_name_here mit dem Namen der Datenbank, die du verwenden möchtest. */
    define('DB_NAME', ‚wordpress‘);
    
    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', ‚root‘);
    
    /** Ersetze password_here mit deinem MySQL-Passwort */
    define('DB_PASSWORD', '');
    
    /** Ersetze localhost mit der MySQL-Serveradresse */
    define('DB_HOST', 'localhost');
    
    /** Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8');
    
    /** Der collate type sollte nicht geändert werden */
    define('DB_COLLATE', '');

    Dann habe ich in meinem Browser den Link:
    http://localhost/wordpress/wp-admin/install.php
    aufgerufen und bekam folgende Meldung:
    Datenbank kann nicht ausgewählt werden

    Die Verbindung zum Datenbankserver konnte hergestellt werden (Benutzername und Passwort sind also korrekt), die Datenbank ‚wordpress‘ konnte jedoch nicht ausgewählt werden.

    Bist du sicher, dass die Datenbank existiert?
    Hat der Benutzer ‚root‘ die notwendigen Rechte, um die Datenbank ‚wordpress‘ zu verwenden?
    Auf einigen Systemen wird dem Datenbanknamen der Benutzername vorangestellt, so dass dieser die Form username_‚wordpress‘ hat. Könnte dies das Problem sein?

    Ich hab schon kräftig gegoogelt, aber keine Lösung gefunden.
    Bin für jeden Tipp dankbar.

    Gruß vom verzweifelten Jeancx

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Moderator Torsten Landsiedel

    (@zodiac1978)

    define('DB_NAME', ‚wordpress‘);
    
    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', ‚root‘);

    Hast Du das exakt so geschrieben? Dann ersetze einfach das geschwungene einfache Anführungszeichen mit einem normalen über Shift+# geschriebenen Minutenzeichen.

    Gruß, Torsten

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Müsste dann so aussehen:

    define('DB_NAME', 'wordpress');
    
    /** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', 'root');

    Gruß, Torsten

    Super Torsten,
    vielen Dank, das war’s. Da wäre ich nie drauf gekommen.
    Das richtige Zeichen einzufügen hat übrigens nicht gefunzt. Es ist dann immer wieder das falsche reingesprungen.
    Ich musste dann über Copy&Paste das Richtige einfügen.
    (Textedit aufm Imac)

    Schöne Grüße vom erleichterten Jean

    Moderator espiat

    (@espiat)

    Gelöst.

Ansicht von 4 Antworten - 1 bis 4 (von insgesamt 4)
  • Das Thema „Bekomme wordpress unter xampp nicht zum laufen…“ ist für neue Antworten geschlossen.