Support » Allgemeine Fragen » Benutzer Neu Anlegen nicht möglich

  • andreasia

    (@andreasia)


    Hallo,

    ich bin verzweifelt, denn trotz aller Tipps in den Foren komme ich nicht weiter.
    Ich kann als angemeldeter ADMIN keine neuen Benutzer anlegen.

    Weder funktioniert der beschriebene Trick mit dem Überschrieben des generierten Passworts in der fehlenden zweiten Passwortzeile, so lange Java-Script aktiviert ist, der refreshing Trick in derselben Konstellation, der auch beschrieben ist in den Foren.

    Dann habe ich es mit Deaktivierung von Java-Script im Browser versucht. Das bringt mich weiter, PW und PW Wiederholung können eingetragen werden und die Anlage kann abgeschlossen werden, aber der neu angelegte Benutzer Benutzer erscheint nicht in der Benutzerliste und wird auch nicht gefunden.

    WP Version 5.9

    Bitte um Unterstützung, Danke

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    die Infos reichen leider nicht, um dazu etwas sagen zu können.
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.

    Es könnte evtl. auch sein, dass das Problem durch einen Konflikt zwischen Plugins verursacht wird.
    Du kannst ja mal nach einer Sicherung das Plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle Plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass Besucher deine Webseite mit allen Infos und Plugins sehen, während nur für dich alle Plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.

    Eine weitere Möglichkeit könnte ein Problem mit der Datenbank sein.
    Mögliche Lösungen für eine Reparatur – aber bitte auf jeden Fall erst mal zumindest die DB sichern:

    Viele Grüße
    Hans-Gerd

    Thread-Starter andreasia

    (@andreasia)

    Hallo Hans-Gerd,

    danke für die ausführliche Antwort. Einige Deiner Ideen hab ich umgesetzt, leider ohne Erfolg.Am liebsten, bzw. zuerst hätte ich natürlich gern Deinen ersten Rat = „Webseitenbericht“ gesendet, aber unter Tools befindet sich leider kein Tool namens Websitezustand. Gibt es dieses Tool eventuell als extra Plugin und wenn ja, wie heisst es?
    Gern würde ich den Bericht hochladen, vielleicht könnt Ihr mir dann direkt helfen.

    Ich bin eher der Content und SEO Kenner und weniger bzw. nahezu gar nicht der Programmierer.

    Die installietrten Themes der Seite sind twenty-ninteen – twenty-twenty – twenty twentyone – twenty twentytwo

    Ich habe nicht genutzte Plugins deinstalliert und auch einen Kompatibilitätscheck mit der PHP Version gemacht.
    Die Lösung über den PHP Hoster und dem Editor wäre für mich der letzte Ausweg, da bin ich am wenigsten Profi.

    Bevor ich das Health Check Plugin probiere, eine Frage noch. Kann das Plugin Woo Commerce das Problem sein?

    Und eine grundsätzliche Frage bleibt ja ungeachtet aller Vorschläge von Dir: Warum ist das zweite Passwortfeld bei der Neuanlage eines Benutzers immer nur sichtbar, wenn Javascript für Webseiten deaktiviert ist.

    Hoffe auf weitere Hilfe

    danke

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,

    aber unter Tools befindet sich leider kein Tool namens Websitezustand.

    das habe ich auch nicht geschrieben. Ich hatte geschrieben: „Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website.“

    Bevor ich das Health Check Plugin probiere, eine Frage noch. Kann das Plugin Woo Commerce das Problem sein?

    Das genau kannst du bei Installation und Aktivierung des Plugins „Health Check & Troubleshooting“ wahrscheinlich herausfinden.
    Schau doch bitte auch noch mal in den folgenden Thread. Wenn ich das richtig sehe, ging es da um das gleiche Thema.
    Viele Grüße
    Hans-Gerd

    Thread-Starter andreasia

    (@andreasia)

    Hallo Hans-Gerd,

    leider passt das nicht. Denn das was Du schreibst und was sich z.B. in diesem Artikel wiederfindet: https://elbnetz.com/website-zustand-alles-ueber-die-neue-wordpress-funktion/

    ist in der Theorie ganz schön, nur passt es nicht für den konkreten Fall, da auf der WordPress Installation der Seite eben genau diese Funktion nicht existiert.
    Wie kann das sein, wenn es doch eine „neue“ Standardfunktion ist?
    Das macht es unglaublich schwierig, Lösungen zu finden, wenn es offenbar überall andere Voraussetzungen gibt.

    Das macht es auch für Dich nicht einfach, kannst Du mir sagen, wie ich diese Funktion in mein WP bekomme?

    danke schon mal

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    warum diese Option bei dir nicht zu finden ist, kann ich dir leider nicht sagen, weil ich bei den von mit angelegten WordPress-Instanzen das Problem noch nicht hatte und mich auch nicht erinnern kann, dass das Problem hier im Forum schon mal angesprochen worden ist.
    Vermutlich musst du dir einen Dienstleister suchen, der sich die Sache mal im Dashboard genauer ansehen kann.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Vielleicht stimmen auch einfach die Benutzerrechte nicht?

    Ich gehe davon aus, dass du per FTP auf den Webserver zugreifen kannst.
    Du kannst dann folgenden Code in der functions.php deines aktiven Themes am Ende anhängen, um einen neuen Administrator anzulegen:

    add_action( 'init', function () {
      
    	$username = 'notfall';
    	$password = 'alleswirdgut';
    	$email_address = 'deine@email.de';
    
    	if ( ! username_exists( $username ) ) {
    		$user_id = wp_create_user( $username, $password, $email_address );
    		$user = new WP_User( $user_id );
    		$user->set_role( 'administrator' );
    	}
    	
    } );

    Danach rufst du eine beliebige Webseite deiner WordPress-Installation im Browser auf.

    Du solltest dich jetzt mit dem Benutzernamen notfall und dem Passwort alleswirdgut im Backend anmelden und als Administrator/-in arbeiten können. Das setzt allerdings voraus, dass keine zusätzlichen Maßnahmen ergriffen wurden, um die Benutzerrechte einzuschränken – etwa durch Installation eines Plugins oder eine andere Funktion in der functions.php des verwendeten Themes.

    Anschließend solltest du unbedingt die eingefügten Zeilen in der functions.php wieder entfernen.

    Es handelt sich hier um eine reine Notlösung.

    Moderator Hans-Gerd Gerhards

    (@hage)

    @pixolin
    oh ja, das wäre natürlich eine Erklärung für das Problem, an die ich blöderweise noch nicht gedacht habe. Wenn @andreasia keine Administratorrechte hat, dann fehlen je nach Benutzerrolle natürlich entsprechende Optionen im Dashboard, wobei mich irritiert hatte, dass @andreasia ja nach Deaktivierung von JavaScript Benutzer anlegen kann.

    Moderator Bego Mario Garde

    (@pixolin)

    Ich bin mir da auch nicht sicher. Deswegen das „vielleicht“ im ersten Satz. Einen Versuch wäre es doch wert?

    Ich habe …

    PW und PW Wiederholung können eingetragen werden und die Anlage kann abgeschlossen werden, aber der neu angelegte Benutzer Benutzer erscheint nicht in der Benutzerliste und wird auch nicht gefunden.

    … so interpretiert, dass der Benutzer doch nicht angelegt wird.

    Thread-Starter andreasia

    (@andreasia)

    Hallo Leute,

    riesen dank erst einmal.
    Ich logge mich als Admin ein, kann auch alle Rechte zuweisen usw.

    Ich werde als nächstes erst einmal WOO Commerce abschalten, mit dem Health Tool, das Hans empfohlen hat, werde ich die Plugins prüfen und dann mal sehen.

    Das was Bego empfohlen hat, klingt nach Profi und ist sicher eine Lösung, aber da traue ich mich nicht ran, insbesondere, weil ich den FTP Zugang des Hosters nicht habe, denn die Seite gehört nicht mir, ich soll sie nur betreuen, content füllen, gestalten . . .
    Wenn irgendwann gar nichts hilft, brauch ich dafür vielleicht mal einen Profi, denn Begos Lösung klingt für mich als Nicht Profi fehleranfälltig.

    VG Andre

    Moderationshinweis: Jobangebote sind hier im Forum ausdrücklich unerwünscht. Lies dir bitte nochmal die Forenregeln durch.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    mit Hinweis auf die FAQ habe ich den letzten Satz gelöscht. Suche dir am besten einen Dienstleister, der das für dich analysieren kann.
    Viele Grüße
    Hans-Gerd

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Benutzer Neu Anlegen nicht möglich“ ist für neue Antworten geschlossen.