Support » Allgemeine Fragen » Benutzerdefinierte Permalinks funktionieren nicht

  • Gelöst leon1912

    (@leon1912)


    Hallo,

    ich habe heute eine neue WordPress-Seite eingerichtet.

    Nun möchte ich für die Datenschutzerklärung folgenden Link haben:
    https://example.com/datenschutz

    Für den Rest sollen die Standard Permalinks wie https://example.com/?p=1 verwendet werden.

    Ich habe bereits einige Plugins dazu ausprobiert, aber entweder bekomme ich einen 404, oder die Seite wird gar nicht erst angezeigt.

    Wie kann ich das realisieren, dass das so funktioniert?

    Ich würde mich um eine Antwort freuen und wünsche einen schönen Tag.

    Mit freundlichen Grüßen
    Leon

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Hallo,
    so ganz erschließt sich mir nicht, wozu das gut sein soll.
    Aber ok: Ich gehe mal davon aus, dass du bei Einstellungen > Permalink „Einfach“ gewählt hast.
    So weit ich das festgestellt habe, kann man in dem Fall bei einem Beitrag oder einer Seite den Permalink rechts in den Einstellungen bei der Bearbeitung in dem Fall nicht ändern.
    Getestet habe ich mal das Plugin Permalink Manager Lite.
    Damit kann man auch in dem Fall den Permalink ändern. Allerdings wird die Seite danach nicht gefunden. Man müsste also dann offenbar entweder einen Redirect in der .htaccess einrichten oder ein weiteres Plugin wie z. B.
    Simple 301 Redirects installieren.
    Aber vielleicht schreibst du hier mal, warum du das machen willst und welche Plugins du bereits getestet hast.
    Plugin-Empfehlungen sind grundsätzlich schwierig, weil bei der Auswahl zu viele subjektive Kriterien eine Rolle spielen. Oft werden auch nachträglich zusätzliche Wünsche geäußert, die das gerade vorgeschlagene Plugin nicht erfüllt. Deshalb ist es besser, wenn du verschiedene Plugins testest und selber entscheidest, was am besten zu deinen Vorstellungen passt.
    Da es sich bei deiner Frage um kein Anwendungsproblem handelt, habe ich den Status auf „Keine Support-Frage“ geändert.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    „Ein bisschen Permalinks“ (also Permalinks nur für eine einzelne Webseite) geht leider nicht. Wenn du Permalinks aktivierst, wird in der .htaccess eine allgemeine Weiterleitungsregel eingerichtet, mit der alle Seiteaufrufe an die index.php weitergeleitet werden. Anschließend prüft WordPress, ob es zu dem Teil der URL hinter der Domain (dem „Slug“) einen passenden Eintrag in der Datenbank gibt und gibt dann den zugehörigen Beitrag oder Seite aus. Dein Wunsch würde sich nur mit mehreren WordPress-Instanzen umsetzen lassen und das ist wohl ein wenig übertrieben.

    @hage ich verstehe die Frage „lassen sich Permalinks nur für einzelne Seiten aktivieren“ durchaus als Supportfrage, auch wenn es dafür höchstens einen Workaround (mehrere WordPress-Instanzen) gibt. Der Status sollte bei „nicht gelöst“ bleiben, bis wir eine Rückmeldung von @leon1912 erhalten.

    @pixolin
    kein Problem – können wir so lassen 😊

    Thread-Ersteller leon1912

    (@leon1912)

    Hallo,

    Vielen Dank für eure Antworten.
    Permalinks Manager Lite habe ich bereits ausprobiert. Dort kam ich nicht auf eine 404-Seite, aber der Text, den ich auf der Seite geschrieben habe, wird nicht angezeigt.
    https://imgur.com/a/4dmQ8Wo

    Ich möchte dies machen, da ich die Datenschutzerklärung über /datenschutz erreichbar haben möchte, das Impressum unter /Impressum, die Beiträge aber über /?p=1

    Ich habe bereits einige Plugin ausprobiert.
    Bis auf bei Permalinks Manager Lite kam ich am Ende nur auf die 404-Seite.

    Ich hatte Custom Permalinks, Custom Post Type Permalinks oder auch Permalinks Customizer.

    • Diese Antwort wurde geändert vor 8 Monaten von leon1912.
    Moderator Bego Mario Garde

    (@pixolin)

    Ich möchte dies machen, da ich die Datenschutzerklärung über /datenschutz erreichbar haben möchte, das Impressum unter /Impressum, die Beiträge aber über /?p=1

    Ich versuche es nochmal in einfacher Sprache:

    Das geht so nicht.
    Du kannst Permalinks nicht auf einzelne Seiten beschränken.

    Thread-Ersteller leon1912

    (@leon1912)

    Das habe ich schon verstanden, dass das nicht funktioniert.
    Ich dachte nur, dass mir da jemand vielleicht ein funktionierendes Plugin empfehlen kann, die dieses ermöglicht.

    Danke für eure Antworten. 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Du kannst als Workaround in Einstellungen > Permalinks eine individuelle Struktur einstellen und als Platzhalter /?p=%post_id% eintragen. Dann erscheinen alle Beiträge in der Form https://example.com/?p=42, alle Seiten aber als https://example.com/beispielseite.

    Das sprechende Permalinks (https://example.com/wie-ich-wordpress-liebe-lernte statt https://example.com/?p=42) wichtig für eine Suchmaschinenoptimierung sind und auch Webseitenbesucher die Eingabe erleichtern (wer merkt sich schon IDs?) ist dir aber bekannt?

    Moderator Angelika Reisiger

    (@la-geek)

    +1 für sprechende Links.

    Wie auch immer. Eine weitere Option statt der von @pixolin genannten (Beiträge
    /?p=%post_id% usw.) wäre noch, die Seiten Datenschutz und Impressum als reine HTML-Seiten zu erstellen und diese ins Root-Verzeichnis von WordPress abzulegen.

    Dafür muss man natürlich schon ein wenig mit der Erstellung von HTML-Seiten vertraut sein.

    Moderator Bego Mario Garde

    (@pixolin)

    @la-geek völlig richtig, eigenständige HTML-Seiten kommen als Lösung auch in Frage. Danke für den Hinweis.
    Alternativ kann man auch die Webseiten in WordPress erstellen, in einem privaten Browserfenster aufrufen, Datei speichern > nur HTML und dann diese HTML-Dokumente auf den Server als datenschutz.html, impressum.html usw. hochladen. Das erspart HTML- und CSS-Kenntnisse.

    Meine Aussage „Du kannst Permalinks nicht auf einzelne Seiten beschränken.“ bezog sich auf eine Lösung ausschließlich innerhalb von WordPress.

    Thread-Ersteller leon1912

    (@leon1912)

    Hallo,
    Da gebe ich dir recht…
    Eigentlich sind sprechende Links besser.
    Auf jeden Fall funktioniert jetzt das Plugin und die benutzerdefinierten Permalinks.

    @la-geek
    HTML wäre für mich tatsächlich kein Problem.

    Ich muss mir das mit den Links nochmal überlegen, aber tatsächlich funktioniert es jetzt komischerweise.

    Danke für euere Antworten 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Auf jeden Fall funktioniert jetzt das Plugin und die benutzerdefinierten Permalinks.

    Für welche Lösung mit welchem Plugin und welchen Permalink-Einstellungen hast du dich denn nun entschieden?

    Thread-Ersteller leon1912

    (@leon1912)

    So…

    Ich verwende jetzt als Plugin Permalinks Manager Lite .
    Meine Permalink Einstellungen sind:
    – Individuelle Struktur: %post_name%

    Für die Datenschutzerklärung ist jetzt die URL: https://example.com/datenschutz und für das Impressum: https://example.com/impressum

    Jetzt kann ich aber, wenn ich %post_name% als URL nicht möchte, einen individuellen Link eingeben.

    • Diese Antwort wurde geändert vor 8 Monaten von leon1912.
    Moderator Bego Mario Garde

    (@pixolin)

    Hört sich mühsam an, aber Danke fürs Teilen deiner Lösung.

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Das Thema „Benutzerdefinierte Permalinks funktionieren nicht“ ist für neue Antworten geschlossen.