Support » Plugins » Bestätigungsmail Contact Form 7

  • Gelöst maddoccc

    (@maddoccc)


    Hi Leute.

    Habe ein Formular in Contat Form 7 erstellt welches funktioniert. Doch möchte ich (via E-Mail 2) das der Absender eine Bestätigungsmail erhält. Normal tut man ja in die erste Zeile AN den Email Tag setzen. Quasi [mail 1] welcher im Formular ausgelesen wird. Dort kommt aber beim speichern immer die Meldung „Es wurde ein Konfigurationsfehler in diesem Reiter gefunden“ Nun hörte ich das das nicht mehr geht sondern über die eMail wordpress@Ihre-Domain.de im AN Feld klappt. Doch das geht auch nicht. Es kommt keine Mail an. Das kann doch nicht so schwer sein. Was mache ich nur falsch?

    Viele Grüße Maddoc

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Wenn du in deinem Kontaktformular

    <label> Deine E-Mail-Adresse (Pflichtfeld)
        [email* your-email] </label>

    verwendest, kannst du die „E-Mail 2“ an diese Adresse senden. Du musst nur darauf achten, dass der Absender der E-Mail eine Adresse mit deiner eigenen Domain ist, weil einige Webhoster das sonst als Spam-Versuch werten.

    Das sieht dann sinngemäß so aus:
    Screenshot CF7

    Hi und danke für die Antwort.

    Die Abfrage lautet so

    <p>E-Mail des Bestellers<br/>[email email-7]</p>

    In E-Mail2 schreibe ich also bei An [email-7] rein und bei von die Mail Adresse die auch zum Domainnamen passt. Korrekt?

    Das [email-7] steht auch oben als Email Tag zur verfügung.

    Es kommt aber trotzdem noch die Fehlermeldung. Unter dem An Feld steht auch immer Syntaxfehler. Ich verzweifel noch.

    Wie soll ich das jetzt beurteilen? ¯\_(ツ)_/¯

    Teil doch bitte mal den Inhalt der Antwort-E-Mails, ggf. auch als Bild.

    Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    Ok. Hier. Habe die Mailadresse unkenntlich gemacht. Ist die Domain mit einem info@ davor.

    Nun zeigt es mit logischer Weise noch an das die Adresse nicht zur Domain passt. Diese Meldung kommt natürlich mit der richtigen Andresse nicht. Geht also quasi nur oben um die AN Zeile.

    • Diese Antwort wurde geändert vor 4 Monaten, 3 Wochen von maddoccc.
    • Diese Antwort wurde geändert vor 4 Monaten, 3 Wochen von maddoccc.
    • Diese Antwort wurde geändert vor 4 Monaten, 3 Wochen von maddoccc.

    Hallo,
    wenn deine Mailadresse mit [email-7] identisch ist, dann wäre das – so weit ich das hier sehen kann – ok. Mich wundert nur die Bezeichnung [email-7], weil nach der Einrichtung eines neuen Formulars normalerweise dieses Feld [your-email] heißt.
    Mir ist nicht klar, warum du das geändert hast. Ich vermute mal, dass du da im Rahmen deiner Versuche das so gestaltet hast.
    Viele Grüße
    Hans-Gerd

    Ich kann halt auch nichts feststellen warum es nicht geht. Habe die Seite so übernommen. Aber wie das letztendlich genannt wird wäre ja egal. Oben als Email Tag steht die email-7 auch. Also sollte das auch gehen. Was mich irritiert ist das mit der Syntax. Die Meldung kommt übrigens immer wenn ich den Tag neutze. Auch im Von Feld und auch bei Reaply-To..

    Ich habe das jetzt einmal auf your-email umgeschrieben. Als Tag stand das your-email auf einmal fett geschrieben und als ich es speicherte stand es wieder als nicht fett und der Syntaxfehler bleibt aber bestehen..

    Der Fehlerhinweis kommt, wenn das E-Mail-Feld kein Pflichtfeld ist. Lässt der Anwender das Feld leer und sendet das Formular ab, kann die E-Mail nicht zugestellt werden.

    Was könnte ich also noch probieren?

    Was meinst du? Reicht dir der Hinweis nicht, wo die Fehlermeldung herkommt?

    Was meinst du? Bin eigentlich gerade wieder am Anfang. Im Grunde wie du schon sagst alles richtig gemacht und trotzdem kommt die Meldung.

    Liest du eigentlich die Antworten? 🙂

    Ich hatte doch geschrieben, wieso die Fehlermeldung kommt:

    Der Fehlerhinweis kommt, wenn das E-Mail-Feld kein Pflichtfeld ist. Lässt der Anwender das Feld leer und sendet das Formular ab, kann die E-Mail nicht zugestellt werden.

    Screenshot Generierung Feld E-Mail-Adresse mit Pflichtfeld

    [email email-7] ist ein Eingabefeld für eine E-Mailadresse, aber kein Pflichtfeld.

    [email* email-7] ist ein Eingabefeld für eine E-Mailadresse und ein Pflichtfeld.

    Nur wenn das Feld ein Pflichtfeld ist, wird sichergestellt, dass zum Versand der E-Mail eine E-Mail-Adresse angegeben wurde. Ist das nicht sichergestellt, vermerkt das Formular bei der Validierung einen Fehler.

    Das habe ich nicht kapiert. Pflichtfeld? Das was drinnen steht ist doch korrekt und sollte funktionieren? Auch auch mit [email email-7] funktioniert es nicht. Helf mir mal auf die Sprünge und wie ich es beheben kann bitte.

    Ein Pflichtfeld in einem Formular ist ein Feld, dass Webseitenbesucher ausfüllen müssen, wenn sie das Formular absenden möchten.

    Ist das Eingabefeld für die E-Mail-Adresse kein Pflichtfeld, kann der Nutzer das Feld leer lassen. Das hätte dann zur Folge, dass das An-Feld der E-Mail ebenfalls leer bliebe und die Bestätigungsmail nicht versand werden kann. Das ist ein Fehler. Deshalb wird eine Fehlermeldung angezeigt.

    Ob ein Feld ein Pflichtfeld ist, wird beim Anlegen des Feldes durch Klick in das Kontrollkästchen „Pflichtfeld“ festgelegt. Der Shortcode enthält dann zur Unterscheidung hinter dem Feldnamen ein Sternchen.

    Ah. Ok.
    Wie bekomme ich das jetzt im Nachhinein noch geregelt? Formular neu anlegen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)