Support » Allgemeine Fragen » Bild bearbeiten – Vorschaubild defekt

  • wiesnerjens

    (@wiesnerjens)


    Hallo!
    Seit einiger Zeit schon kann ich Bilder, die ich in die Mediathek hochgeladen habe, nicht mehr zuschneiden – ganz egal ob mit den internen Möglichkeiten von WordPress (unter Anhang-Details) oder mithilde von Plugins wie Manual Image Crop. Das Vorschaubild wird schlicht nicht angezeigt. Unter Chrome wird mir zumindest ein Icon angezeigt, das auf einen Broken Link hinweist, bei Firefox ist an der Stelle, an der normalerweise das Vorschaubild sein sollte, einfach nichts.

    Ich habe schon alle möglichen Plugins deaktiviert, die stören könnten und auf die neueste WordPress-Version geupdatet, aber es hat leider nichts gebracht – und in deversen Forum bislang auch noch keine Lösung für mein Problem gefunden. Vielleicht könnt ihr mir helfen..

    Beste Grüße, Jens

    • Dieses Thema wurde geändert vor 4 Jahre von wiesnerjens.
    • Dieses Thema wurde geändert vor 4 Jahre von Bego Mario Garde. Grund: Bild richtig eingebunden
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Moderator Bego Mario Garde

    (@pixolin)

    Schau doch mal, ob es besser klappt, wenn du das hier in der functions.php deines Themes anhängst:

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    
    function change_graphic_lib($array) {
    return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
    }
    joemeissl

    (@joemeissl)

    Hallo,

    ich habe genau das gleiche Problem.
    Die WordPress Installation ist relativ neu, es sind keine Plugins aktiv und es ist egal welches Theme ich nutze.
    Wenn ich über das Bild oder den Medienbereich auf bearbeiten gehe, wird mir das Bild als „broken link“ angezeigt und kann dieses nicht schneiden, drehen, kippen usw.

    Aber sonst funktionieren die Bilder ohne Probleme. Ich habe den uploads-Ordner via FTP überprüft, hier sind die Rechte „777“ vergeben, also kann es daran auch nicht liegen.

    @pixolino: Ihren Code habe ich am Ende der function.php des Themes „Twenty Fifteen“ kopiert und ausprobiert, ohne Erfolg.

    Hat noch jemand eine Idee?

    Vielen Danke!

    joemeissl

    (@joemeissl)

    Hier noch ein paar Details, evtl. hilfreich:

    PHP Version : 5.4.45-0+deb7u5 / 64Bit OS
    Memory limit : 256 MB
    Memory usage : 23.35 MB

    Die Auslastung des memorys liegt bei 9%

    • Diese Antwort wurde geändert vor 4 Jahre von joemeissl.

    Hallo, leider habe ich immer noch dieses Problem.

    Ich hab auch schon den Code von
    http://forum.wpde.org/konfiguration/134233-mediathek-bild-bearbeiten-funktioniert-nicht.html
    ausprobiert, ohne erfolg.

    Wenn ich auf die Medienbibliothek gehe, sehe ich alle Bilder.
    Auch wenn ich eines öffne um die Anhang-Details zu bearbeiten.
    Aber wenn ich auf „Bild bearbeiten“ klicke, ist nur noch dieses Broken-Link-Bild vorhanden.

    Wo kann der Fehler noch liegen?

    Danke schon mal.
    fg

    Hallo, noch ein paar weitere Daten.

    Ich hab das debug log in der config aktiviert, es gibt keine Fehlermeldung hierzu.

    Wenn ich versuche das nicht geladene Bild zu bearbeiten, kommt die Meldung: „Konnte das Vorschaubild nicht laden. Bitte lade die Seite neu und versuche es erneut.“

    Ich habe mittlerweile die Verzeichnisse wp-admin und wp-includes per FTP gelöscht und aus einem aktuellen Download von WordPress ersetzt.

    Am Server ist die GD Library für PHP5 installiert.

    Ich hab auch nochmals alle Plugins deaktiviert und es getestet, auch ein anderes Theme habe ich versucht, beides ohne Erfolg.

    Ich nutze das Theme „Twenty Fifteen“, bzw. habe ich mir in Child gemacht, mit nur wenigen optischen Anpassungen.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Bild bearbeiten – Vorschaubild defekt“ ist für neue Antworten geschlossen.