Support » Allgemeine Fragen » Bild im blog einbauen

  • Gelöst lilakakadu

    (@lilakakadu)


    Hallo, ich habe einige Zeit nicht in meinem blog gearbeitet. Jetzt will ich in einen neuen Artikel, ebenso einen alten, Fotos einfügen. Geht nicht !
    Bei neuem Block erscheint nur die Möglichkeit, Einbetten, Überschrift hinzufügen, Youtube-Video einbetten.
    Kein Foto, weder zum Hochladen noch aus der Mediathek.

    Mache ich was falsch ? Oder ? Wie kriege Fotos rein?

    Danke für Eure Hilfe
    Uwe

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Hallo,
    leider fehlen uns einige Informationen: Setzt du den Classic-Editor oder den Block-Editor ein?
    Außerdem nutzt du auf deiner Webseite noch WordPress 5.3.6. Die Version solltest du zumindest zeitnah aktualisieren (aktuell ist 5.7).
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller lilakakadu

    (@lilakakadu)

    Hallo Hans-Gerd, danke erstmal.

    Ich hab die Seite aktualisiert. Jetzt läßt sich im Block überhaupt nichts mehr einfügen
    Welchen Editor ich einsetze ? keine Ahnung . Ich weiß garnicht, daß ich da eine Auswahl. Ich klicke auf Beitrag erstellen oder bearbeiten.

    Hier der Bericht:

    
    ### wp-core ###
    
    version: 5.7
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/web1146/html/asia-drogerie.de/blog
    wordpress_size: 48,65 MB (51018147 bytes)
    uploads_path: /var/www/web1146/html/asia-drogerie.de/blog/wp-content/uploads
    uploads_size: 75,39 MB (79055722 bytes)
    themes_path: /var/www/web1146/html/asia-drogerie.de/blog/wp-content/themes
    themes_size: 14,10 MB (14788413 bytes)
    plugins_path: /var/www/web1146/html/asia-drogerie.de/blog/wp-content/plugins
    plugins_size: 59,22 MB (62101506 bytes)
    database_size: 3,55 MB (3724070 bytes)
    total_size: 200,93 MB (210687858 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Thirteen (twentythirteen)
    version: 2.4 (latest version: 3.3)
    author: dem WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, editor-style, automatic-feed-links, html5, post-formats, menus, post-thumbnails, customize-selective-refresh-widgets, custom-header, widgets
    theme_path: /var/www/web1146/html/asia-drogerie.de/blog/wp-content/themes/twentythirteen
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (8) ###
    
    Appointment: version: 2.7.1, author: Webriti (latest version: 2.8.9), Automatische Aktualisierungen deaktiviert
    Shk Corporate: version: 2.1.4, author: webriti (latest version: 2.2.5), Automatische Aktualisierungen deaktiviert
    Twenty Fourteen: version: 2.2, author: dem WordPress-Team (latest version: 3.1), Automatische Aktualisierungen deaktiviert
    Twenty Nineteen: version: 1.0, author: WordPress-Team (latest version: 2.0), Automatische Aktualisierungen deaktiviert
    Twenty Twelve: version: 2.5, author: dem WordPress-Team (latest version: 3.3), Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.0, author: WordPress-Team (latest version: 1.7), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.2, author: WordPress-Team, Automatische Aktualisierungen deaktiviert
    zeeTasty: version: 1.0.7, author: ThemeZee, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (6) ###
    
    BuddyPress: version: 3.1.0, author: The BuddyPress Community (latest version: 7.2.0), Automatische Aktualisierungen deaktiviert
    MaxButtons: version: 7.13.4, author: Max Foundry (latest version: 8.5), Automatische Aktualisierungen deaktiviert
    Optimus: version: 1.6.0, author: KeyCDN, Automatische Aktualisierungen deaktiviert
    Shariff Wrapper: version: 4.6.4, author: Jan-Peter Lambeck & 3UU (latest version: 4.6.5), Automatische Aktualisierungen deaktiviert
    WP SEO HTML Sitemap: version: 0.9.6, author: Magna Technology, LLC, Automatische Aktualisierungen deaktiviert
    Yoast SEO Premium: version: 14.0, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (6) ###
    
    Akismet Anti-Spam: version: 4.1, author: Automattic (latest version: 4.1.9), Automatische Aktualisierungen deaktiviert
    Gutenberg: version: 7.5.1, author: Gutenberg Team (latest version: 10.1.1), Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.6, author: Matt Mullenweg (latest version: 1.7.2), Automatische Aktualisierungen deaktiviert
    Jetpack by WordPress.com: version: 6.3.4, author: Automattic (latest version: 9.5), Automatische Aktualisierungen deaktiviert
    Surbma | Yoast SEO Breadcrumb Shortcode: version: 1.1, author: Surbma, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 13.1, author: Team Yoast (latest version: 15.9.2), Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1673
    imagemagick_version: ImageMagick 6.8.9-9 Q16 x86_64 2019-12-29 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 4M
    max_effective_size: 4 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 96 GB
    	imagick::RESOURCETYPE_DISK: -1
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 96 GB
    	imagick::RESOURCETYPE_MEMORY: 48 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.18-13-pve x86_64
    httpd_software: Apache
    php_version: 7.2.26 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 120
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 4M
    php_post_max_size: 8M
    curl_version: 7.38.0 OpenSSL/1.0.1t
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.25
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/web1146/html/asia-drogerie.de/blog/wp-content
    WP_PLUGIN_DIR: /var/www/web1146/html/asia-drogerie.de/blog/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    herzliche grüße
    uwe

    Du hast in der WordPress-Konfigurationsdatei wp-config.php eingetragen, dass deine Website nur 40MB Arbeitsspeicher nutzen darf, obwohl dir vom Server 512MB zur Verfügung gestellt werden. Das könnte die Ursache für Probleme sein.
    Öffne doch bitte mal die Datei mit einem geeigneten Code-Editor (z.B. VS Code, kostenlos für alle Betriebssysteme erhältlich) und kommentier die betreffenden Zeilen mit zwei vorangestellten Schrägstrichen aus:

    // define( 'WP_MEMORY_LIMIT', '40M' );
    // define( 'WP_MAX_MEMORY_LIMIT', '512M' );

    Du verwendest außerdem eine veraltete PHP-Version. Im Kundenmenü deines Webhosters (unter Umständen auch in „Experten-Einstellungen“) solltest du eine aktuellere Version auswählen können. PHP 7.4 wäre ideal, PHP 7.3 auch OK.

    Schau mal, wie es danach aussieht und gib uns eine Rückmeldung.

    Übrigens verwendest du die Entwicklungs-Version des Block-Editor von WordPress „Gutenberg“. Da während der Entwicklung auch schon mal eher Fehler entstehen, solltest du das Plugin deaktivieren. WordPress verwendet dann die stabilere Standard-Version des Block-Editor.

    Thread-Ersteller lilakakadu

    (@lilakakadu)

    Danke
    Ich muß blöd fragen. Hintergrundwissen fehlt mir oft. Ich weiß nicht, wo ich die wp-config.php finde. Ich denke, sie müßte in einem Unterverzeichnis von asia-drogerie.de liegen. Bloß, da finde ich nichts.

    PHP hab ich erhöht, Gutenberg werde ich rausnehmen

    Kannst du per FTP-Programm (z.B. FileZilla) auf die Dateien auf deinem Webserver zugreifen? Du solltest die Datei in dem Verzeichnis finden, in dem auch deine anderen WordPress-Dateien liegen, also im Unterverzeichnis /blog.

    Thread-Ersteller lilakakadu

    (@lilakakadu)

    Hallo,
    zugreifen kann ich. Und jetzt auch das Unterverzeichnis gefunden. Nur in WP-config.php finde ich die zu ändernde Datei nicht.

    Hier ist wp-config.php:

    /** * In dieser Datei werden die Grundeinstellungen für WordPress vorgenommen. * * Zu diesen Einstellungen gehören: 
    MySQL-Zugangsdaten, Tabellenpräfix, * Secret-Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es * auf 
    der {@link http://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren} * Seite im Codex. Die Informationen für 
    die MySQL-Datenbank bekommst du von deinem Webhoster. * * Diese Datei wird von der wp-config.php-Erzeugungsroutine verwendet. 
    Sie wird ausgeführt, * wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist, * und die 
    Installationsroutine (/wp-admin/install.php) aufgerufen wird. * Man kann aber auch direkt in dieser Datei alle Eingaben 
    vornehmen und sie von * wp-config-sample.php in wp-config.php umbenennen und die Installation starten. * * @package WordPress 
    *//**  MySQL Einstellungen - diese Angaben bekommst du von deinem Webhoster. *//**  Ersetze database_name_here mit dem Namen 
    der Datenbank, die du verwenden m�chtest. */
    
    define('DB_NAME', '***');/** Ersetze username_here mit deinem MySQL-Datenbank-Benutzernamen */
    define('DB_USER', '***');/** Ersetze password_here mit deinem MySQL-Passwort */
    define('DB_PASSWORD', '***');/** Ersetze localhost mit der MySQL-Serveradresse */
    define('DB_HOST', 'localhost');/** 
    Der Datenbankzeichensatz der beim Erstellen der Datenbanktabellen verwendet werden soll */
    define('DB_CHARSET', 'utf8');/** Der collate type sollte nicht geändert werden */
    define('DB_COLLATE', '');/**#@+ * Sicherheitsschlüssel * * Ändere jeden KEY 
    in eine beliebige, möglichst einzigartige Phrase. * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ 
    WordPress.org secret-key service} * kannst du dir alle KEYS generieren lassen. * Bitte trage für jeden KEY eine eigene Phrase 
    ein. Du kannst die Schlüssel jederzeit wieder ändern, * alle angemeldeten Benutzer müssen sich danach erneut anmelden. * * 
    @seit 2.6.0 */
    [Schlüssel gelöscht] * WordPress Datenbanktabellen-Präfix * *  Wenn du  verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank *  verschiedene WordPress-Installationen betreiben. Nur Zahlen, Buchstaben und Unterstriche bitte! */
    $table_prefix  = 'wp_'; /** * For developers: WordPress debugging mode. * *  Change this to true to enable the display of notices during development. * It is strongly recommended that plugin and theme developers use WP_DEBUG * in their development environments. */
    define('WP_DEBUG', false);/* That's all, stop editing! Happy  blogging. *//** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )	define('ABSPATH', dirname(__FILE__) . '/');/** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');


    Moderationshinweis: bitte keine Zugangsdaten veröffentlichen. Du solltest die Zugangsdaten deiner MySQL-Datenbank vorsichtshalber ändern.

    • Diese Antwort wurde geändert vor 6 Monaten, 2 Wochen von Bego Mario Garde. Grund: bitte keine Zugangsdaten veröffentlichen

    Vielleicht sollte man die sensiblen Daten vor Veröffentlichung löschen!!

    schon gemacht 😉

    • Diese Antwort wurde geändert vor 6 Monaten, 2 Wochen von jostu55.
    • Diese Antwort wurde geändert vor 6 Monaten, 2 Wochen von jostu55.

    @jostu55 nicht nur vielleicht …

    Leider hat gerade der Paketdienst geklingelt, als ich schon dabei war, die Zugangsdaten zu löschen. Dadurch hat’s dann noch einen Moment länger gedauert.

    @lilakakadu du solltest wie gesagt die Zugangsdaten deiner MySQL-Datenbank ändern. Zumindest jemand mit Zugriff auf den gleichen Server könnte die Inhalte mit den Zugangsdaten manipulieren.

    Um einen Bedienungsfehler auszuschließen: Wenn du eine Seite oder einen Beitrag erstellst oder bearbeitest und dann auf das [+]-Icon oben links [1] klickst, solltest du im Abschnitt Medien [2] Blöcke für Bilder [3] oder Galerien [4] angezeigt bekommen. Damit müsstest du auch Bilder neu hinzufügen können.

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Alternativ kannst du auch im Editor /Bild eingeben und bekommst dann ein Fenster angezeigt, auf das du aus dem Dateimanager deines Betriebssystem eine Bilddatei ziehen kannst.

    Thread-Ersteller lilakakadu

    (@lilakakadu)

    Danke, ja so gehts.
    Oh man, naiv, Passwort hab ich geändert

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Bild im blog einbauen“ ist für neue Antworten geschlossen.